summaryrefslogtreecommitdiff
path: root/system/easy-kernel/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-02 16:08:23 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-12-02 16:08:23 -0600
commit6030e98a3dd0696a3ba6e22d465ea8fca16d0d2e (patch)
treea4586d69bedbd6609a4c769ef17c621cff6b58dd /system/easy-kernel/APKBUILD
parent3360712b49cd3f29b7012731d208cd04320b9ea8 (diff)
downloadpackages-6030e98a3dd0696a3ba6e22d465ea8fca16d0d2e.tar.gz
packages-6030e98a3dd0696a3ba6e22d465ea8fca16d0d2e.tar.bz2
packages-6030e98a3dd0696a3ba6e22d465ea8fca16d0d2e.tar.xz
packages-6030e98a3dd0696a3ba6e22d465ea8fca16d0d2e.zip
system/easy-kernel: new package
Diffstat (limited to 'system/easy-kernel/APKBUILD')
-rw-r--r--system/easy-kernel/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
new file mode 100644
index 000000000..944593610
--- /dev/null
+++ b/system/easy-kernel/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=easy-kernel
+pkgver=4.14.0
+pkgrel=0
+pkgdesc="The Linux kernel, packaged for your convenience"
+url="https://kernel.org/"
+arch="all"
+options="!check !dbg !strip"
+license="GPL-2.0"
+depends=""
+makedepends="lzop openssl-dev"
+install=""
+subpackages="$pkgname-modules $pkgname-src"
+source="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
+ https://distfiles.adelielinux.org/source/linux-4.14-mc0.patch.xz
+ config-x86_64"
+builddir="$srcdir/linux-4.14"
+
+prepare() {
+ default_prepare
+ cd "$srcdir"
+ cat linux-4.14-mc0.patch.xz | unxz -> linux-4.14-mc0.patch
+ cd "$builddir"
+ patch -Np1 <../linux-4.14-mc0.patch
+ cd "$srcdir"
+ cp config-$CARCH linux-4.14/.config
+ cp -pr linux-4.14 linux-src
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/boot
+ make INSTALL_PATH="$pkgdir"/boot \
+ INSTALL_MOD_PATH="$pkgdir" \
+ install modules_install
+}
+
+modules() {
+ pkgdesc="Modules / device drivers for easy-kernel"
+ mkdir -p "$subpkgdir"/lib
+ mv "$pkgdir"/lib/modules "$subpkgdir"/lib/
+}
+
+src() {
+ pkgdesc="Kernel source code used to build THIS kernel"
+ mkdir -p "$subpkgdir"/usr/src
+ mv "$srcdir"/linux-src "$subpkgdir"/usr/src/linux
+}
+sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
+6a119b2e01e4cc11911c1151cffb068f2a42bd986b280bee44c714879d8ee7dcebf2de51a9bc64c1915964867e98d438c09db89c1d7bd3a98ed845924ee11cfa linux-4.14-mc0.patch.xz
+8e8520cc5ae96b55d498462fd4c321c886870f8ad90ae681613216a01c1bfbbc86a3cd6f805a5f1271f1f9685632be0e3fafd932e08568b368fb39fb8abc63b8 config-x86_64"