summaryrefslogtreecommitdiff
path: root/system/easy-kernel
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-22 04:51:09 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-22 04:51:09 +0000
commit183242d05e8da399024b9b1ba4387f4a942367ad (patch)
tree47bd95d682ac5396dadf236108a7acbebd7e7e9c /system/easy-kernel
parent303ff8413dec04b15857538dacdb7da3ceedd235 (diff)
downloadpackages-183242d05e8da399024b9b1ba4387f4a942367ad.tar.gz
packages-183242d05e8da399024b9b1ba4387f4a942367ad.tar.bz2
packages-183242d05e8da399024b9b1ba4387f4a942367ad.tar.xz
packages-183242d05e8da399024b9b1ba4387f4a942367ad.zip
system/easy-kernel: Add modprobe configuration for fb modules
Diffstat (limited to 'system/easy-kernel')
-rw-r--r--system/easy-kernel/APKBUILD9
-rw-r--r--system/easy-kernel/no-autoload-fb.conf19
2 files changed, 27 insertions, 1 deletions
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
index a59fd6f2a..a78758702 100644
--- a/system/easy-kernel/APKBUILD
+++ b/system/easy-kernel/APKBUILD
@@ -33,6 +33,8 @@ source="https://cdn.kernel.org/pub/linux/kernel/v${_pkgmajver}.x/linux-${_pkgmin
config-x86_64
kernel.h
uapi-iphdr.patch
+
+ no-autoload-fb.conf
"
builddir="$srcdir/linux-${_pkgminver}"
@@ -103,6 +105,10 @@ modules() {
"$subpkgdir"/lib/modules/$pkgver-mc$_patchver-easy$_kflavour/build
ln -s "../../../usr/src/linux-$pkgver-mc$_patchver$_kflavour" \
"$subpkgdir"/lib/modules/$pkgver-mc$_patchver-easy$_kflavour/source
+
+ mkdir -p "$subpkgdir"/etc/modprobe.d
+ install -m644 "$srcdir"/no-autoload-fb.conf \
+ "$subpkgdir"/etc/modprobe.d/no-autoload-fb.conf
}
headers() {
@@ -143,4 +149,5 @@ c61fa4613d0d75a5387d12c2f72dc8ba1e6635cc47cc9fb46253095c6417241ef59639ddf9ad2209
f43ae12574c81f6e0161c547eff93d70ff4686e6ec1654edbdea10447e424218a33b81c664828f82617e4ef522128f2e0460da0c9523538724048174b53a7313 config-sparc64
557db84d1f45c91ed3e3ab5d0e7100766060507ae98632b735580813974e136343500f9683bb51dc3994277716651821523b476bc5143e636ebde14aa5e67f48 config-x86_64
61dcd633d72876566b7738dd08856b26850c935b4a81ab2364711335fe01c397083160f530b3382bbc239c6a8135be6a032e93039083ec2cefdae2902429a2e0 kernel.h
-6f309a18c65c991240265afd200cc79a706f5d9e5d072838a9a641ab3676a5e4c32033f9767fc723ff4c45ee462169a0f77bd7dfe63b547d521dadd073f827a7 uapi-iphdr.patch"
+6f309a18c65c991240265afd200cc79a706f5d9e5d072838a9a641ab3676a5e4c32033f9767fc723ff4c45ee462169a0f77bd7dfe63b547d521dadd073f827a7 uapi-iphdr.patch
+7bb07eb22002cc48caf0cd55d17ce4097aa583e0ca4048c11c92e1519761b2ae982ffe98311543d4b0dfc991c8bc411b2e1c7be9488b6c6f19ffaa08e69e2f47 no-autoload-fb.conf"
diff --git a/system/easy-kernel/no-autoload-fb.conf b/system/easy-kernel/no-autoload-fb.conf
new file mode 100644
index 000000000..dd0a9b358
--- /dev/null
+++ b/system/easy-kernel/no-autoload-fb.conf
@@ -0,0 +1,19 @@
+# Welcome to Adélie Linux.
+#
+# This file prevents automatic loading of framebuffer drivers.
+# They conflict with the DRM drivers that work better with X.Org.
+#
+# You may comment out a module that you would like to use, but note that this
+# may cause issues with display managers or X11.
+#
+# Maintainer Note: We *only* blacklist modules that have DRM equivalents.
+# This isn't Debian, we don't prevent people from using PCI framebuffers.
+
+blacklist aty128fb
+blacklist atyfb
+blacklist matroxfb_base
+blacklist radeonfb
+blacklist rivafb
+blacklist savagefb
+blacklist sisfb
+blacklist tdfxfb