summaryrefslogtreecommitdiff
path: root/system/ed
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:32:35 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:32:35 +0000
commit53d65f2558b41eb6e7140565dc30e2dcb44fc017 (patch)
treea62a317be75fad8b0d0a9a30f1f2605905ede482 /system/ed
parentd75086acb9d3df6fe2973196e49eef5821dc65cf (diff)
downloadpackages-53d65f2558b41eb6e7140565dc30e2dcb44fc017.tar.gz
packages-53d65f2558b41eb6e7140565dc30e2dcb44fc017.tar.bz2
packages-53d65f2558b41eb6e7140565dc30e2dcb44fc017.tar.xz
packages-53d65f2558b41eb6e7140565dc30e2dcb44fc017.zip
system/e*: modernise, fix metadata
Diffstat (limited to 'system/ed')
-rw-r--r--system/ed/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/system/ed/APKBUILD b/system/ed/APKBUILD
index 38acc491c..d13ab5a2b 100644
--- a/system/ed/APKBUILD
+++ b/system/ed/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ed
pkgver=1.15
pkgrel=0
-pkgdesc="GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files"
+pkgdesc="GNU version of standard text editor"
url="https://www.gnu.org/software/ed/"
arch="all"
license="GPL-3.0+"
@@ -14,24 +14,19 @@ source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
builddir=$srcdir/$pkgname-$pkgver
build() {
- cd "$builddir"
- # bindir needs correspond with busybox location
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --bindir=/bin \
--mandir=/usr/share/man
make all
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}