summaryrefslogtreecommitdiff
path: root/system/fakeroot
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-01-14 21:34:44 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:45 -0500
commit2802f651906efae1ff0a6ee9aca9930342440a72 (patch)
treec326fbe49d39d2b650c3dba21a7454c3cf45c79e /system/fakeroot
parent53561b489d4770216aa7d72de23994db55e86c4c (diff)
downloadpackages-2802f651906efae1ff0a6ee9aca9930342440a72.tar.gz
packages-2802f651906efae1ff0a6ee9aca9930342440a72.tar.bz2
packages-2802f651906efae1ff0a6ee9aca9930342440a72.tar.xz
packages-2802f651906efae1ff0a6ee9aca9930342440a72.zip
system/fakeroot: update to 1.26
fakeroot-skip-ipc-sanity-check: Applied upstream fix-shell-in-fakeroot: Was never required
Diffstat (limited to 'system/fakeroot')
-rw-r--r--system/fakeroot/APKBUILD13
-rw-r--r--system/fakeroot/fakeroot-skip-ipc-sanity-check.patch46
-rw-r--r--system/fakeroot/fix-shell-in-fakeroot.patch13
3 files changed, 5 insertions, 67 deletions
diff --git a/system/fakeroot/APKBUILD b/system/fakeroot/APKBUILD
index c2eba9832..4728af5f5 100644
--- a/system/fakeroot/APKBUILD
+++ b/system/fakeroot/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=fakeroot
-pkgver=1.25.3
+pkgver=1.26
pkgrel=0
pkgdesc="Tool for simulating superuser privileges"
arch="all"
@@ -13,18 +13,17 @@ makedepends="$makedepends_build $makedepends_host"
checkdepends="bash sharutils"
subpackages="$pkgname-doc"
# find timestamp here: https://snapshot.debian.org/package/fakeroot/
-source="https://snapshot.debian.org/archive/debian/20201008T205817Z/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
+source="https://snapshot.debian.org/archive/debian/20210907T092512Z/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
fakeroot-no64.patch
- fakeroot-skip-ipc-sanity-check.patch
fakeroot-stdint.patch
- fix-shell-in-fakeroot.patch
xstatjunk.patch
"
build() {
# musl does not have _STAT_VER, it's really not used for
# anything, so define it as zero
- export CFLAGS="-D_STAT_VER=0 $CFLAGS"
+ # define _ID_T so libfakeroot knows headers define it
+ export CFLAGS="-D_STAT_VER=0 -D_ID_T $CFLAGS"
./bootstrap
./configure \
@@ -46,9 +45,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b54366ef82b49af414d7214d069a4bc7dd188dfa4f8e3121f6bd65fd67268b02346ff72e857087243ab0efe9fa82faaa9f9c3309cac4b5af0ea00908c2e5eb6e fakeroot_1.25.3.orig.tar.gz
+sha512sums="dad193b283b48a25806c5bcd06d1f5bbd183ccd40a3fc25f3e7bb88fd6579024f958321f8336654348a1d0a547d4ad19ed11aab5ec9441d6ef493ee6e4c78081 fakeroot_1.26.orig.tar.gz
7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
-f1dcd9c34e74eb225c6a96262847e70f86f437c6bcf41c5d554ced2e3d08798296a66310296cc0ab177a7ea5a0271151326a3e79f72e4ed640b3bd20dbaabec1 fakeroot-skip-ipc-sanity-check.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
-47593b3d86a66bab832c50a1d967cdc70e42bbd9ef4436f18140067ccefdd6418516e5157102c67e604f3623ed1b9f4fe1423fc5dad4dfe5356fc250c12818a7 fix-shell-in-fakeroot.patch
5efd33fd778bd94a529ed7e439fb8fea25ff865dda3f6f9e431264e942b37f3b5d7a0ad14107b55c5fa81b86efd5a82aedb3803cfab08ec57f27f5b229d2fe88 xstatjunk.patch"
diff --git a/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch b/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch
deleted file mode 100644
index fc96c2922..000000000
--- a/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -urN fakeroot-1.25.3.orig/configure.ac fakeroot-1.25.3/configure.ac
---- fakeroot-1.25.3.orig/configure.ac 2020-12-15 02:33:22.866626448 -0700
-+++ fakeroot-1.25.3/configure.ac 2020-12-15 02:33:40.563359415 -0700
-@@ -25,42 +25,6 @@
- [ac_cv_use_ipc],
- [ac_cv_use_ipc=sysv])
-
--if test $ac_cv_use_ipc = "sysv"; then
-- AC_MSG_CHECKING([whether SysV IPC message queues are actually working on the host])
--
-- AC_LANG_PUSH(C)
-- AC_TRY_RUN([
--#include <stdlib.h>
--#include <sys/types.h>
--#include <sys/ipc.h>
--#include <sys/msg.h>
--#include <time.h>
--#include <unistd.h>
--
--int main() {
--
-- srandom(time(NULL)+getpid()*33151);
-- key_t msg_key = random();
-- int msg_get = msgget(msg_key, IPC_CREAT|0600);
--
-- if (msg_get==-1) {
-- return 1;
-- } else {
-- msgctl(msg_get, IPC_RMID, NULL);
-- return 0;
-- }
--
--}], [ac_cv_use_ipc=sysv], [ac_cv_use_ipc=tcp])
--
-- if test $ac_cv_use_ipc = "tcp"; then
-- AC_MSG_RESULT([No, using TCP])
-- else
-- AC_MSG_RESULT([Yes])
-- fi
--
-- AC_LANG_POP(C)
--fi
--
- AC_ARG_WITH([dbformat],
- AS_HELP_STRING([--with-dbformat@<:@=DBFORMAT@:>@],
- [database format to use: either inode (default) or path]),
diff --git a/system/fakeroot/fix-shell-in-fakeroot.patch b/system/fakeroot/fix-shell-in-fakeroot.patch
deleted file mode 100644
index ce5d23f0c..000000000
--- a/system/fakeroot/fix-shell-in-fakeroot.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Description: Fix shell in fakeroot.in
- Use /bin/sh instead of @SHELL@ in fakeroot.in
-Author: Juan Picca <jumapico@gmail.com>
-Last-Update: 2016-06-27
----
---- a/scripts/fakeroot.in
-+++ b/scripts/fakeroot.in
-@@ -1,4 +1,4 @@
--#!@SHELL@
-+#!/bin/sh
-
- # This script first starts faked (the daemon), and then it will run
- # the requested program with fake root privileges.