summaryrefslogtreecommitdiff
path: root/system/fakeroot
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-08 15:35:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:41 -0500
commit67036d66488115901510a51c83147ad37dd871e9 (patch)
tree41add2d48aa3eec3e4c5f4435bceec8a2b8fc2d8 /system/fakeroot
parent473a51c44dc72c39a14eef332a68c6e50cf2fdc6 (diff)
downloadpackages-67036d66488115901510a51c83147ad37dd871e9.tar.gz
packages-67036d66488115901510a51c83147ad37dd871e9.tar.bz2
packages-67036d66488115901510a51c83147ad37dd871e9.tar.xz
packages-67036d66488115901510a51c83147ad37dd871e9.zip
system/fakeroot: bump { 1.24 --> 1.25.3 } and pull Alpine patches. fixes test failure on ppc64.
Diffstat (limited to 'system/fakeroot')
-rw-r--r--system/fakeroot/APKBUILD16
-rw-r--r--system/fakeroot/fakeroot-hide-dlsym-errors.patch20
-rw-r--r--system/fakeroot/fakeroot-no-ldlibrarypath.patch80
-rw-r--r--system/fakeroot/fakeroot-skip-ipc-sanity-check.patch46
-rw-r--r--system/fakeroot/fix-shell-in-fakeroot.patch13
5 files changed, 67 insertions, 108 deletions
diff --git a/system/fakeroot/APKBUILD b/system/fakeroot/APKBUILD
index cc7b0eefa..c2eba9832 100644
--- a/system/fakeroot/APKBUILD
+++ b/system/fakeroot/APKBUILD
@@ -1,6 +1,6 @@
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=fakeroot
-pkgver=1.24
+pkgver=1.25.3
pkgrel=0
pkgdesc="Tool for simulating superuser privileges"
arch="all"
@@ -13,11 +13,11 @@ makedepends="$makedepends_build $makedepends_host"
checkdepends="bash sharutils"
subpackages="$pkgname-doc"
# find timestamp here: https://snapshot.debian.org/package/fakeroot/
-source="https://snapshot.debian.org/archive/debian/20190908T172415Z/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
- fakeroot-hide-dlsym-errors.patch
+source="https://snapshot.debian.org/archive/debian/20201008T205817Z/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
fakeroot-no64.patch
+ fakeroot-skip-ipc-sanity-check.patch
fakeroot-stdint.patch
- fakeroot-no-ldlibrarypath.patch
+ fix-shell-in-fakeroot.patch
xstatjunk.patch
"
@@ -46,9 +46,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b15db7bbfb03264f294fb3b42813e17758b43ef7f121e55a24af9ec30ff3f4ec8eb0392db88133e56f9728b3828f6c1432d1e5d2e881a69d083ad444b9177487 fakeroot_1.24.orig.tar.gz
-666f41d6adc5e65eba419e08d5bbc4f561e40b0fc7bfa82090eb87962a7f3193bf319754e04aca289e865c66df2ecced1dbb45c9aa9f093657f22193dda25354 fakeroot-hide-dlsym-errors.patch
+sha512sums="b54366ef82b49af414d7214d069a4bc7dd188dfa4f8e3121f6bd65fd67268b02346ff72e857087243ab0efe9fa82faaa9f9c3309cac4b5af0ea00908c2e5eb6e fakeroot_1.25.3.orig.tar.gz
7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
+f1dcd9c34e74eb225c6a96262847e70f86f437c6bcf41c5d554ced2e3d08798296a66310296cc0ab177a7ea5a0271151326a3e79f72e4ed640b3bd20dbaabec1 fakeroot-skip-ipc-sanity-check.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
-acfc1e5efce132279adddf9e11c28d65602059d5cd723ad98b67cb9183e1de68445f3bba7ac54ee60265b85f25141fcc9b2156f551aa5c624a92631320f5b743 fakeroot-no-ldlibrarypath.patch
+47593b3d86a66bab832c50a1d967cdc70e42bbd9ef4436f18140067ccefdd6418516e5157102c67e604f3623ed1b9f4fe1423fc5dad4dfe5356fc250c12818a7 fix-shell-in-fakeroot.patch
5efd33fd778bd94a529ed7e439fb8fea25ff865dda3f6f9e431264e942b37f3b5d7a0ad14107b55c5fa81b86efd5a82aedb3803cfab08ec57f27f5b229d2fe88 xstatjunk.patch"
diff --git a/system/fakeroot/fakeroot-hide-dlsym-errors.patch b/system/fakeroot/fakeroot-hide-dlsym-errors.patch
deleted file mode 100644
index aeeb347da..000000000
--- a/system/fakeroot/fakeroot-hide-dlsym-errors.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-it's normal that the acl_* symbols are not found if the application
-is not linked against -lacl. these errors harmless, but mighty
-annoying.
-
---- fakeroot-1.20/libfakeroot.c.orig 2014-03-07 11:20:26.120532847 +0200
-+++ fakeroot-1.20/libfakeroot.c 2014-03-07 11:21:26.486872482 +0200
-@@ -258,10 +258,12 @@
- /* clear dlerror() just in case dlsym() legitimately returns NULL */
- msg = dlerror();
- *(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
-- if ( (msg = dlerror()) != NULL){
-+#ifdef LIBFAKEROOT_DEBUGGING
-+ if ( fakeroot_debug && (msg = dlerror()) != NULL) {
- fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
- /* abort ();*/
- }
-+#endif
- }
- }
-
diff --git a/system/fakeroot/fakeroot-no-ldlibrarypath.patch b/system/fakeroot/fakeroot-no-ldlibrarypath.patch
deleted file mode 100644
index e7b9a037d..000000000
--- a/system/fakeroot/fakeroot-no-ldlibrarypath.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -ru fakeroot-1.20.2.orig/scripts/fakeroot.in fakeroot-1.20.2/scripts/fakeroot.in
---- fakeroot-1.20.2.orig/scripts/fakeroot.in 2015-11-12 10:51:23.241681379 +0200
-+++ fakeroot-1.20.2/scripts/fakeroot.in 2015-11-12 10:56:53.331985288 +0200
-@@ -34,8 +34,7 @@
- FAKEROOT_BINDIR=@bindir@
-
- USEABSLIBPATH=@LDPRELOADABS@
--LIB=lib@fakeroot_transformed@@DLSUFFIX@
--PATHS=@libdir@:${FAKEROOT_PREFIX}/lib64/libfakeroot:${FAKEROOT_PREFIX}/lib32/libfakeroot
-+LIB=@libdir@/lib@fakeroot_transformed@@DLSUFFIX@
- FAKED=${FAKEROOT_BINDIR}/@faked_transformed@
-
- FAKED_MODE="unknown-is-root"
-@@ -68,7 +67,6 @@
- -l|--lib)
- shift
- LIB=`eval echo "$1"`
-- PATHS=
- ;;
- -f|--faked)
- shift
-@@ -111,23 +109,11 @@
-
- # make sure the preload is available
- ABSLIB=""
--if [ -n "$PATHS" ]
--then
-- for dir in `echo $PATHS | sed 's/:/ /g'`
-- do
-- if test -r "$dir/$LIB"
-- then
-- libfound=yes
-- ABSLIB="$dir/$LIB"
-- fi
-- done
--else
- if test -r "$LIB"
- then
- libfound=yes
- ABSLIB="$LIB"
- fi
--fi
-
- if test $libfound = no
- then
-@@ -148,7 +134,7 @@
- if [ "$WAITINTRAP" -eq 0 ]; then
- trap "kill -s @signal@ $PID" EXIT INT
- else
-- @MACOSX_FALSE@trap 'FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDPRELOADVAR@="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
-+ @MACOSX_FALSE@trap 'FAKEROOTKEY=$FAKEROOTKEY @LDPRELOADVAR@="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
- @MACOSX_TRUE@trap 'FAKEROOTKEY=$FAKEROOTKEY @LDPRELOADVAR@="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
- fi
-
-@@ -159,10 +145,6 @@
- if test $USEABSLIBPATH -ne 0 ; then
- LIB=$ABSLIB
- fi
--# Keep other library paths
--if test -n "$@LDLIBPATHVAR@"; then
-- PATHS="$PATHS:$@LDLIBPATHVAR@"
--fi
- # ...and preloaded libs
- if test -n "$@LDPRELOADVAR@"; then
- LIB="$LIB:$@LDPRELOADVAR@"
-@@ -171,11 +153,11 @@
- export FAKEROOT_FD_BASE
-
- if test -z "$*"; then
-- @MACOSX_FALSE@FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
-+ @MACOSX_FALSE@FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
- @MACOSX_TRUE@FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
- RESULT=$?
- else
-- @MACOSX_FALSE@FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
-+ @MACOSX_FALSE@FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
- @MACOSX_TRUE@FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
- RESULT=$?
- fi
-
diff --git a/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch b/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch
new file mode 100644
index 000000000..fc96c2922
--- /dev/null
+++ b/system/fakeroot/fakeroot-skip-ipc-sanity-check.patch
@@ -0,0 +1,46 @@
+diff -urN fakeroot-1.25.3.orig/configure.ac fakeroot-1.25.3/configure.ac
+--- fakeroot-1.25.3.orig/configure.ac 2020-12-15 02:33:22.866626448 -0700
++++ fakeroot-1.25.3/configure.ac 2020-12-15 02:33:40.563359415 -0700
+@@ -25,42 +25,6 @@
+ [ac_cv_use_ipc],
+ [ac_cv_use_ipc=sysv])
+
+-if test $ac_cv_use_ipc = "sysv"; then
+- AC_MSG_CHECKING([whether SysV IPC message queues are actually working on the host])
+-
+- AC_LANG_PUSH(C)
+- AC_TRY_RUN([
+-#include <stdlib.h>
+-#include <sys/types.h>
+-#include <sys/ipc.h>
+-#include <sys/msg.h>
+-#include <time.h>
+-#include <unistd.h>
+-
+-int main() {
+-
+- srandom(time(NULL)+getpid()*33151);
+- key_t msg_key = random();
+- int msg_get = msgget(msg_key, IPC_CREAT|0600);
+-
+- if (msg_get==-1) {
+- return 1;
+- } else {
+- msgctl(msg_get, IPC_RMID, NULL);
+- return 0;
+- }
+-
+-}], [ac_cv_use_ipc=sysv], [ac_cv_use_ipc=tcp])
+-
+- if test $ac_cv_use_ipc = "tcp"; then
+- AC_MSG_RESULT([No, using TCP])
+- else
+- AC_MSG_RESULT([Yes])
+- fi
+-
+- AC_LANG_POP(C)
+-fi
+-
+ AC_ARG_WITH([dbformat],
+ AS_HELP_STRING([--with-dbformat@<:@=DBFORMAT@:>@],
+ [database format to use: either inode (default) or path]),
diff --git a/system/fakeroot/fix-shell-in-fakeroot.patch b/system/fakeroot/fix-shell-in-fakeroot.patch
new file mode 100644
index 000000000..ce5d23f0c
--- /dev/null
+++ b/system/fakeroot/fix-shell-in-fakeroot.patch
@@ -0,0 +1,13 @@
+Description: Fix shell in fakeroot.in
+ Use /bin/sh instead of @SHELL@ in fakeroot.in
+Author: Juan Picca <jumapico@gmail.com>
+Last-Update: 2016-06-27
+---
+--- a/scripts/fakeroot.in
++++ b/scripts/fakeroot.in
+@@ -1,4 +1,4 @@
+-#!@SHELL@
++#!/bin/sh
+
+ # This script first starts faked (the daemon), and then it will run
+ # the requested program with fake root privileges.