summaryrefslogtreecommitdiff
path: root/system/fakeroot
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-20 17:51:02 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-20 17:51:02 +0000
commite460f2590f10be1fb9c43ec0a7638b0e32b743d7 (patch)
tree580ada60ce9f22e7f36dc2ec6b78ada1e3201d5f /system/fakeroot
parentcf4bf28b20a66efe13fd8aac764145250008e84f (diff)
downloadpackages-e460f2590f10be1fb9c43ec0a7638b0e32b743d7.tar.gz
packages-e460f2590f10be1fb9c43ec0a7638b0e32b743d7.tar.bz2
packages-e460f2590f10be1fb9c43ec0a7638b0e32b743d7.tar.xz
packages-e460f2590f10be1fb9c43ec0a7638b0e32b743d7.zip
system/fakeroot: unmaintained bump to 1.23
Diffstat (limited to 'system/fakeroot')
-rw-r--r--system/fakeroot/APKBUILD22
-rw-r--r--system/fakeroot/busybox-getopt.patch14
-rw-r--r--system/fakeroot/fakeroot-uclibc.patch20
3 files changed, 9 insertions, 47 deletions
diff --git a/system/fakeroot/APKBUILD b/system/fakeroot/APKBUILD
index 984739111..b08cd6289 100644
--- a/system/fakeroot/APKBUILD
+++ b/system/fakeroot/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=fakeroot
-pkgver=1.22
+pkgver=1.23
pkgrel=0
pkgdesc="Utility to provide a 'fake' root environment as a non-privileged user"
arch="all"
@@ -12,8 +12,7 @@ makedepends_host="libcap-dev acl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
checkdepends="bash"
subpackages="$pkgname-doc"
-source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
- busybox-getopt.patch
+source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.xz
fakeroot-hide-dlsym-errors.patch
fakeroot-no64.patch
fakeroot-stdint.patch
@@ -22,14 +21,12 @@ source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.o
"
build() {
- if [ "$CLIBC" = "musl" ]; then
- # musl does not have _STAT_VER, it's really not used for
- # anything, so define it as zero (just like uclibc does)
- export CFLAGS="-D_STAT_VER=0 $CFLAGS"
- fi
+ # musl does not have _STAT_VER, it's really not used for
+ # anything, so define it as zero
+ export CFLAGS="-D_STAT_VER=0 $CFLAGS"
- CONFIG_SHELL=/bin/sh ./bootstrap
- CONFIG_SHELL=/bin/sh ./configure \
+ ./bootstrap
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -41,15 +38,14 @@ build() {
}
check() {
- bash -c 'make check'
+ make check
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="193478d9ff88ca2ae69fe47b73b6c61aeb2ba3f2a9e7ed5d455022705857c6f34cdcbe2d3f614c4c4c9509368dc78b9a7b7aa56fb3b50bb3309448140abd796a fakeroot_1.22.orig.tar.bz2
-9024263f4452bcb46c9670f8b8106e67c2d9b4cf45215def7ff4e78d2c908e4f98d494dd6f514fb3325165b0f61571fa031632b4642163cf9b1b3386d0867c5f busybox-getopt.patch
+sha512sums="0984679207e6e340abf715d4b26a213f85420cd8c58f21e65eb069337a3bd67436c6f80168412c10b28701689ec63290f122a5ff5d44a57b2b166aa72799d036 fakeroot_1.23.orig.tar.xz
666f41d6adc5e65eba419e08d5bbc4f561e40b0fc7bfa82090eb87962a7f3193bf319754e04aca289e865c66df2ecced1dbb45c9aa9f093657f22193dda25354 fakeroot-hide-dlsym-errors.patch
7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
diff --git a/system/fakeroot/busybox-getopt.patch b/system/fakeroot/busybox-getopt.patch
deleted file mode 100644
index e8172e8f1..000000000
--- a/system/fakeroot/busybox-getopt.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./scripts/fakeroot.in.orig
-+++ ./scripts/fakeroot.in
-@@ -43,9 +43,9 @@
-
- libfound=no
-
--GETOPTEST=`getopt --version`
-+GETOPTEST=`getopt --version 2>&1 | head -n2`
- case $GETOPTEST in
--getopt*) # GNU getopt
-+getopt*|*BusyBox*) # GNU getopt
- FAKE_TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
- ;;
- *) # POSIX getopt ?
diff --git a/system/fakeroot/fakeroot-uclibc.patch b/system/fakeroot/fakeroot-uclibc.patch
deleted file mode 100644
index 63708092d..000000000
--- a/system/fakeroot/fakeroot-uclibc.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- fakeroot-1.18.2.orig/libfakeroot.c
-+++ fakeroot-1.18.2/libfakeroot.c
-@@ -1551,7 +1551,7 @@
- #endif /* LIBFAKEROOT_DEBUGGING */
- r=next_fts_read(ftsp);
- if(r && r->fts_statp) { /* Should we bother checking fts_info here? */
--# if defined(STAT64_SUPPORT) && !defined(__APPLE__)
-+# if defined(STAT64_SUPPORT) && !defined(__APPLE__) && !defined(__UCLIBC__)
- SEND_GET_STAT64(r->fts_statp, _STAT_VER);
- # else
- SEND_GET_STAT(r->fts_statp, _STAT_VER);
-@@ -1574,7 +1574,7 @@
- first=next_fts_children(ftsp, options);
- for(r = first; r; r = r->fts_link) {
- if(r && r->fts_statp) { /* Should we bother checking fts_info here? */
--# if defined(STAT64_SUPPORT) && !defined(__APPLE__)
-+# if defined(STAT64_SUPPORT) && !defined(__APPLE__) && !defined(__UCLIBC__)
- SEND_GET_STAT64(r->fts_statp, _STAT_VER);
- # else
- SEND_GET_STAT(r->fts_statp, _STAT_VER);