summaryrefslogtreecommitdiff
path: root/system/file
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:38:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:38:18 +0000
commit7417c7aaf9619beaa518e0b4f392074dcee66724 (patch)
tree4f0bb3de3de0c3c818a8d4faace5914c84af07bb /system/file
parent53d65f2558b41eb6e7140565dc30e2dcb44fc017 (diff)
downloadpackages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.gz
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.bz2
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.tar.xz
packages-7417c7aaf9619beaa518e0b4f392074dcee66724.zip
system/f*: press 'f' to pay respects to old metadata
Diffstat (limited to 'system/file')
-rw-r--r--system/file/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/system/file/APKBUILD b/system/file/APKBUILD
index 86a09ce68..da9059a2b 100644
--- a/system/file/APKBUILD
+++ b/system/file/APKBUILD
@@ -8,17 +8,17 @@ pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
arch="all"
license="BSD-2-Clause"
+depends=""
+makedepends="autoconf automake"
subpackages="$pkgname-dev $pkgname-doc libmagic"
source="$pkgname-$pkgver.tar.gz::https://github.com/file/file/archive/FILE${pkgver%.*}_${pkgver#*.}.tar.gz"
builddir="$srcdir/$pkgname-FILE${pkgver%.*}_${pkgver#*.}"
prepare() {
- cd "$builddir"
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}