summaryrefslogtreecommitdiff
path: root/system/findutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-03 01:50:36 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-03 01:50:36 -0500
commit549c7f27002c9593022c8f616b7bc385d333c722 (patch)
tree335821c4abd8f86952ee6d61e02fb5d617ecb605 /system/findutils
parent0281cfdc20a522e4a42c667eae0f8f62493dd36f (diff)
downloadpackages-549c7f27002c9593022c8f616b7bc385d333c722.tar.gz
packages-549c7f27002c9593022c8f616b7bc385d333c722.tar.bz2
packages-549c7f27002c9593022c8f616b7bc385d333c722.tar.xz
packages-549c7f27002c9593022c8f616b7bc385d333c722.zip
system/{diff,find}utils: fix dumb GPG test thing
Diffstat (limited to 'system/findutils')
-rw-r--r--system/findutils/APKBUILD4
-rw-r--r--system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch10
2 files changed, 13 insertions, 1 deletions
diff --git a/system/findutils/APKBUILD b/system/findutils/APKBUILD
index a568df317..71b3ecdb5 100644
--- a/system/findutils/APKBUILD
+++ b/system/findutils/APKBUILD
@@ -15,6 +15,7 @@ install=
subpackages="$pkgname-doc $pkgname-lang"
source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
localename-test-fix.patch
+ gnulib-tests-dont-require-gpg-passphrase.patch
"
options="!checkroot"
@@ -44,4 +45,5 @@ package() {
}
sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz
-39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch"
+39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch
+96351821572bee9e23760568b5a9f326c8727b6904a8b9f6fc8e5b8e14b42265c632cea09a913db830844f3015f91a03b9c4dd72862f40a3c3814556497434e2 gnulib-tests-dont-require-gpg-passphrase.patch"
diff --git a/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch b/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch
new file mode 100644
index 000000000..755126f64
--- /dev/null
+++ b/system/findutils/gnulib-tests-dont-require-gpg-passphrase.patch
@@ -0,0 +1,10 @@
+--- findutils-4.6.0/tests/test-vc-list-files-git.sh.old 2018-01-03 18:36:29.000000000 -0600
++++ findutils-4.6.0/tests/test-vc-list-files-git.sh 2018-06-18 21:57:08.305562148 -0500
+@@ -32,6 +32,7 @@
+ touch d/a b c &&
+ git config user.email "you@example.com" &&
+ git config user.name "Your Name" &&
++ git config commit.gpgsign false &&
+ git add . > /dev/null &&
+ git commit -q -a -m log &&
+ printf '%s\n' b c d/a > expected &&