summaryrefslogtreecommitdiff
path: root/system/gcc/332-gccgo-remove-ustat.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 17:47:14 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-23 17:47:40 -0500
commit5e8af11be96eeb359aaa93607233f6b9c475b213 (patch)
tree60bf9eb58c10c48f3576dc25d1aeadb3b52c67b7 /system/gcc/332-gccgo-remove-ustat.patch
parentcd914cda236483a3818031d3122ae75e71f311e9 (diff)
downloadpackages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.gz
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.bz2
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.tar.xz
packages-5e8af11be96eeb359aaa93607233f6b9c475b213.zip
system/gcc: actually remove ustat properly
Diffstat (limited to 'system/gcc/332-gccgo-remove-ustat.patch')
-rw-r--r--system/gcc/332-gccgo-remove-ustat.patch73
1 files changed, 55 insertions, 18 deletions
diff --git a/system/gcc/332-gccgo-remove-ustat.patch b/system/gcc/332-gccgo-remove-ustat.patch
index 95b3cb1d2..90aa65ad7 100644
--- a/system/gcc/332-gccgo-remove-ustat.patch
+++ b/system/gcc/332-gccgo-remove-ustat.patch
@@ -108,24 +108,6 @@ index 3cee2c0f..1c192752 100644
AM_CONDITIONAL(HAVE_SYS_MMAN_H, test "$ac_cv_header_sys_mman_h" = yes)
AC_CHECK_FUNCS(strerror_r strsignal wait4 mincore setenv unsetenv dl_iterate_phdr)
-diff --git a/libgo/go/syscall/libcall_linux_ustat.go b/libgo/go/syscall/libcall_linux_ustat.go
-deleted file mode 100644
-index f515fce3..00000000
---- a/libgo/go/syscall/libcall_linux_ustat.go
-+++ /dev/null
-@@ -1,12 +0,0 @@
--// Copyright 2015 The Go Authors. All rights reserved.
--// Use of this source code is governed by a BSD-style
--// license that can be found in the LICENSE file.
--
--// GNU/Linux library ustat call.
--// This is not supported on some kernels, such as arm64.
--// +build !arm64,!nios2,!riscv64
--
--package syscall
--
--//sys Ustat(dev int, ubuf *Ustat_t) (err error)
--//ustat(dev _dev_t, ubuf *Ustat_t) _C_int
diff --git a/libgo/mksysinfo.sh b/libgo/mksysinfo.sh
index 92ecb479..48bc71db 100755
--- a/libgo/mksysinfo.sh
@@ -151,3 +133,58 @@ index 92ecb479..48bc71db 100755
# The utimbuf struct.
grep '^type _utimbuf ' gen-sysinfo.go | \
sed -e 's/_utimbuf/Utimbuf/' \
+--- gcc-6.4.0/libgo/Makefile.am.old 2016-02-03 15:58:02.419872000 -0600
++++ gcc-6.4.0/libgo/Makefile.am 2018-06-23 02:55:45.772611885 -0500
+@@ -1,4 +1,3 @@
+-# Makefile.am -- Go library Makefile.
+
+ # Copyright 2009 The Go Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style
+@@ -1989,17 +1988,6 @@
+ syscall_lsf_file =
+ endif
+
+-# GNU/Linux specific ustat support.
+-if LIBGO_IS_LINUX
+-if LIBGO_IS_ARM64
+-syscall_ustat_file =
+-else
+-syscall_ustat_file = go/syscall/libcall_linux_ustat.go
+-endif
+-else
+-syscall_ustat_file =
+-endif
+-
+ # GNU/Linux specific utimesnano support.
+ if LIBGO_IS_LINUX
+ syscall_utimesnano_file = go/syscall/libcall_linux_utimesnano.go
+@@ -2051,7 +2039,6 @@
+ $(syscall_uname_file) \
+ $(syscall_netlink_file) \
+ $(syscall_lsf_file) \
+- $(syscall_ustat_file) \
+ $(syscall_utimesnano_file) \
+ $(GO_LIBCALL_OS_FILE) \
+ $(GO_LIBCALL_OS_ARCH_FILE) \
+--- gcc-6.4.0/libgo/Makefile.in.old 2016-02-03 15:58:02.419872000 -0600
++++ gcc-6.4.0/libgo/Makefile.in 2018-06-23 02:56:04.842611681 -0500
+@@ -2080,11 +2080,6 @@
+
+ # GNU/Linux specific socket filters.
+ @LIBGO_IS_LINUX_TRUE@syscall_lsf_file = go/syscall/lsf_linux.go
+-@LIBGO_IS_ARM64_FALSE@@LIBGO_IS_LINUX_TRUE@syscall_ustat_file = go/syscall/libcall_linux_ustat.go
+-
+-# GNU/Linux specific ustat support.
+-@LIBGO_IS_ARM64_TRUE@@LIBGO_IS_LINUX_TRUE@syscall_ustat_file =
+-@LIBGO_IS_LINUX_FALSE@syscall_ustat_file =
+ @LIBGO_IS_LINUX_FALSE@syscall_utimesnano_file = go/syscall/libcall_posix_utimesnano.go
+
+ # GNU/Linux specific utimesnano support.
+@@ -2122,7 +2117,6 @@
+ $(syscall_uname_file) \
+ $(syscall_netlink_file) \
+ $(syscall_lsf_file) \
+- $(syscall_ustat_file) \
+ $(syscall_utimesnano_file) \
+ $(GO_LIBCALL_OS_FILE) \
+ $(GO_LIBCALL_OS_ARCH_FILE) \