summaryrefslogtreecommitdiff
path: root/system/gcc/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-22 21:33:47 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-22 21:33:47 -0500
commit1318fa654f51d5349b8b8b11657f89c4da0d1c51 (patch)
treec5458af07bdae99a25597d306104996589309fab /system/gcc/APKBUILD
parentc8f9f3c01c830ad95cde91757a65e3660373f961 (diff)
downloadpackages-1318fa654f51d5349b8b8b11657f89c4da0d1c51.tar.gz
packages-1318fa654f51d5349b8b8b11657f89c4da0d1c51.tar.bz2
packages-1318fa654f51d5349b8b8b11657f89c4da0d1c51.tar.xz
packages-1318fa654f51d5349b8b8b11657f89c4da0d1c51.zip
system/gcc: [PD] add gcc-go, add m68k stuff, etc
Diffstat (limited to 'system/gcc/APKBUILD')
-rw-r--r--system/gcc/APKBUILD41
1 files changed, 28 insertions, 13 deletions
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index de4431f5b..aebf3b666 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -6,26 +6,26 @@ pkgver=6.4.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=8
+pkgrel=9
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
-license="GPL LGPL"
+license="GPL-3.0+ AND LGPL-2.1+"
_gccrel=$pkgver-r$pkgrel
depends="binutils$_target isl"
makedepends_build="gcc$_cross g++$_cross paxmark bison flex texinfo zip gmp-dev mpfr-dev mpc1-dev zlib-dev"
-makedepends_host="linux-headers gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev !gettext-dev"
+makedepends_host="linux-headers gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev libucontext-dev"
subpackages=" "
-[ "$CHOST" = "$CTARGET" ] && subpackages="gcc-doc$_target"
+[ "$CHOST" = "$CTARGET" ] && subpackages="gcc-doc$_target gcc-lang$_target"
replaces="libstdc++ binutils"
-options="$options !check !dbg strip"
+options="$options !check !dbg strip toolchain"
: ${LANG_CXX:=true}
: ${LANG_OBJC:=true}
: ${LANG_JAVA:=true}
: ${LANG_GO:=true}
: ${LANG_FORTRAN:=true}
-: ${LANG_ADA:=true}
+: ${LANG_ADA:=false}
LIBGOMP=true
LIBGCC=true
@@ -90,12 +90,11 @@ else
_builddir="$srcdir/build"
fi
-# Go needs {set,make,swap}context, unimplemented in musl
-[ "$CTARGET_LIBC" = musl ] && LANG_GO=false
-
# libitm has TEXTRELs in ARM build, so disable for now
+# gcc itself has TEXTRELs in m68k; until this is fixed, we need it
case "$CTARGET_ARCH" in
arm*) LIBITM=false ;;
+m68k) options="$options textrels" ;;
esac
# Fortran uses libquadmath if toolchain has __float128
@@ -184,6 +183,9 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgba
300-main-gcc-add-musl-s390x-dynamic-linker.patch
310-build-gcj-s390x.patch
320-libffi-gnulinux.patch
+ 330-gccgo-link-to-ucontext.patch
+ 331-gccgo-use-real-off_t-type.patch
+ 332-gccgo-remove-ustat.patch
fix-rs6000-pie.patch
add-classic_table-support.patch
@@ -238,6 +240,7 @@ build() {
armv5-*-*-*eabi) _arch_configure="--with-arch=armv5te --with-tune=arm926ej-s --with-float=soft --with-abi=aapcs-linux";;
armv6-*-*-*eabihf) _arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
armv7-*-*-*eabihf) _arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;
+ m68k-*-*-*) _arch_configure="--with-arch=68020 --with-tune=68020-40";;
mipsel-*-*-*) _arch_configure="--with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=32 --with-mips-plt --with-float=hard --with-abi=32";;
mips-*-*-*) _arch_configure="--with-arch=mips3 --with-mips-plt --with-abi=32"; _hash_style="sysv";;
mips32el-*-*-*) _arch_configure="--with-arch=mips32 --with-mips-plt --with-abi=32"; _hash_style="sysv";;
@@ -254,10 +257,10 @@ build() {
musl)
# musl does not support mudflap, or libsanitizer
# libmpx uses secure_getenv and struct _libc_fpstate not present in musl
- # alpine musl provides libssp_nonshared.a, so we don't need libssp either
- _libc_configure="--disable-libssp --disable-libmpx --disable-libmudflap --disable-libsanitizer"
+ _libc_configure="--disable-libmpx --disable-libmudflap --disable-libsanitizer"
_symvers="--disable-symvers"
export libat_cv_have_ifunc=no
+ export ac_cv_type_off64_t=no
;;
esac
@@ -303,7 +306,6 @@ build() {
--disable-fixed-point \
--disable-libstdcxx-pch \
--disable-multilib \
- --disable-nls \
--disable-werror \
$_symvers \
--enable-__cxa_atexit \
@@ -474,7 +476,7 @@ java() {
paxmark -pm "$pkgdir"/$_gcclibexec/ecj1
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib "$subpkgdir"/$_gcclibdir/
cd "$pkgdir"/usr/bin
- mv gcj gcj-dbtool gjavah gcjh jcf-dump "$subpkgdir"/usr/bin/
+ mv *gcj *gcj-dbtool *gjavah *gcjh *jcf-dump "$subpkgdir"/usr/bin/
cd "$pkgdir"
for i in $(find usr/ -name ecj1 -o -name jc1 -o -name jvgenmain); do
mkdir -p "$subpkgdir"/${i%/*}
@@ -485,6 +487,9 @@ java() {
mv "$i" "$subpkgdir"/usr/lib/
fi
done
+ mkdir -p "$subpkgdir"/usr/share/gcc-6.4.0/python
+ mv "$pkgdir"/usr/share/gcc-6.4.0/python/libjava \
+ "$subpkgdir"/usr/share/gcc-6.4.0/python
mv "$pkgdir"/usr/lib/libgij.so "$subpkgdir"/usr/lib/
mv "$pkgdir"/usr/lib/libgcj.spec "$subpkgdir"/$_gcclibdir/
}
@@ -516,6 +521,9 @@ libgcj() {
"$pkgdir"/usr/lib/security \
"$subpkgdir"/usr/lib/
+ mkdir -p "$subpkgdir"/usr/lib/pkgconfig
+ mv "$pkgdir"/usr/lib/pkgconfig/libgcj* "$subpkgdir"/usr/lib/pkgconfig/
+
mkdir -p "$subpkgdir"/usr/share/
mv "$pkgdir"/usr/share/java "$subpkgdir"/usr/share/
}
@@ -537,10 +545,15 @@ go() {
"$subpkgdir"/usr/bin
mv "$pkgdir"/usr/lib/go "$subpkgdir"/usr/lib/
mv "$pkgdir"/usr/bin/*gccgo "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/bin/*go "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/*gofmt "$subpkgdir"/usr/bin
mv "$pkgdir"/$_gcclibexec/go1 "$subpkgdir"/$_gcclibexec/
+ mv "$pkgdir"/$_gcclibexec/cgo "$subpkgdir"/$_gcclibexec/
mv "$pkgdir"/usr/lib/libgo.a \
"$pkgdir"/usr/lib/libgo.so \
"$pkgdir"/usr/lib/libgobegin.a \
+ "$pkgdir"/usr/lib/libgolibbegin.a \
+ "$pkgdir"/usr/lib/libnetgo.a \
"$subpkgdir"/usr/lib/
}
@@ -641,6 +654,8 @@ fa44c8158111627aa0e91c43e7cc3aa38642c2041c96532dd4f0932dae4d6f92ea2850b683abcf10
4b4a0ff306a8ef34ff6e3284fbfca869012164a47ba7cb099085c1dd03e6ca0cdd462f82710e08c9a02895adc7484e4c5eef17b5aa264cf5d978fe8ad78eea93 300-main-gcc-add-musl-s390x-dynamic-linker.patch
385bc2fa50204f678964e5148c6170f572701dab920fbec8301f505bda34d182cde0adb7da042fee71719e12fb59f59181897f9b1bb4f4716ff59aad46ca1998 310-build-gcj-s390x.patch
f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45b58ba8764ab1eb575d4eb6d6dfc550a87a183f8b94e76181 320-libffi-gnulinux.patch
+8efd028febb962ae100be32f72f7450c4f77d67ad96a5f47072136cdf47043f9d54835a87c7ab5aaa0fa0108c4c7a97ba2d7732d5aaf2efce70fe1f7e1c39d6e 330-gccgo-link-to-ucontext.patch
+24c8708f64b9b7945b3f07e9bbecf17ab8bcde2524f49cbd694ca2f6146ccc3f13bb027db282f326525ea79d50a2868fa3fa2b0d688a914b5ea77bbfd7e5cbe4 331-gccgo-use-real-off_t-type.patch
01c71cd5881fc07ea3b9b980697e89b3ca0fe98502958ceafc3fca18b2604c844e2f457feab711baf8e03f00a5383b0e38aac7eb954034e306f43d4a37f165ed fix-rs6000-pie.patch
1860593584f629d24d5b6db14b0a3412e9f93449b663aaa4981301a0923db0159314905e694f27366fbfef72dce06636ab6df86862b7e9e9564847e03bee82c1 add-classic_table-support.patch
4e1b421ed72668b66ecbcb0a34afa99d2a34cb2ea9ee51c4aad605fc8a0e94e3bfbabae4ebe236efc5ec86fc01a472cbe93f36fe25cf579714939d8102a9b84a lra-pentium.patch"