summaryrefslogtreecommitdiff
path: root/system/gcc
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-03 16:43:31 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:38 -0500
commit89cfefa32d245642eccf2ba02e1c7afd005abdc1 (patch)
treee843f8c84eb480a21e435586dd78bfb74a5f7383 /system/gcc
parentde28c81fe1f3fc591a3fc5fa84cc97ac3f3a0775 (diff)
downloadpackages-89cfefa32d245642eccf2ba02e1c7afd005abdc1.tar.gz
packages-89cfefa32d245642eccf2ba02e1c7afd005abdc1.tar.bz2
packages-89cfefa32d245642eccf2ba02e1c7afd005abdc1.tar.xz
packages-89cfefa32d245642eccf2ba02e1c7afd005abdc1.zip
system/gcc: bump { 8.3.0 --> 8.5.0 }
Diffstat (limited to 'system/gcc')
-rw-r--r--system/gcc/APKBUILD12
-rw-r--r--system/gcc/backport-r268048-memcpy-bounds.patch21
-rw-r--r--system/gcc/disable-multiarch-ppc32.patch15
3 files changed, 4 insertions, 44 deletions
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index 32de06be4..b22b88753 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=gcc
-pkgver=8.3.0
+pkgver=8.5.0
[ "$BOOTSTRAP" = "nolibc" ] && pkgname="gcc-pass2"
[ "$CBUILD" != "$CHOST" ] && _cross="-$CARCH" || _cross=""
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=2
+pkgrel=0
pkgdesc="The GNU Compiler Collection"
url="https://gcc.gnu.org"
arch="all"
@@ -181,11 +181,9 @@ source="https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
340-gccgo-time64-stat.patch
add-classic_table-support.patch
- disable-multiarch-ppc32.patch
gcc-5.4.0-locale.patch
backport-r267157-posix-conformant-snprintf.patch
- backport-r268048-memcpy-bounds.patch
"
# we build out-of-tree
@@ -541,7 +539,7 @@ gnat() {
mv "$pkgdir"/usr/bin/*gnat* "$subpkgdir"/usr/bin/
}
-sha512sums="1811337ae3add9680cec64968a2509d085b6dc5b6783fc1e8c295e3e47416196fd1a3ad8dfe7e10be2276b4f62c357659ce2902f239f60a8648548231b4b5802 gcc-8.3.0.tar.xz
+sha512sums="92f599680e6b7fbce88bcdda810f468777d541e5fddfbb287f7977d51093de2a5178bd0e6a08dfe37090ea10a0508a43ccd00220041abbbec33f1179bfc174d8 gcc-8.5.0.tar.xz
6d84354e6df96d5ea244eb3bb5f044781796b88040b11c78fb6ee509e5aac19d46e0e92ca836e98e6495d9751f52439833b748efc419e4f5d5301fb549c4dcc9 0002-posix_memalign.patch
7f434a7350c9b06d0ae7cc18a569d813238483afa34b0801d112844a0dfe6164ae36b0416955fd4da7a8caa54672247f319a8ec7ce4b6a97a5f4e17ec083112a 0008-s390x-muslldso.patch
b8207c1be82b20fdad2596bb0a60469db52257456d0925bacf48b44899f4c6ece93c501347e1ffe92fd372c30f90d05a6d8d8078876abf4cf2deae3dbb1a1f58 0009-microblaze-pr65649.patch
@@ -578,7 +576,5 @@ c2916948b028e1e990e1953875b884561c0f8dd105c1ec03073795df9a47ec2c627cbc95ca0ec98a
b32d496a3a04c2357200b75dbf7f667fb57bf5af4f0c68926bc58f6600e4f23caa48aad2eaf073f1408168cacf27e8f11a6062c65bf5bb67458eedef698871d4 339-gccgo-errstr.patch
4db4a00dff1d3cb3ecbc713659316782ac839478ff1fd7166cfa64a2c7cee0ba2a0d3fa23cb858af7d8f59a6ac2bdf40e63a45c307b89eefe2a4e888707f615b 340-gccgo-time64-stat.patch
1860593584f629d24d5b6db14b0a3412e9f93449b663aaa4981301a0923db0159314905e694f27366fbfef72dce06636ab6df86862b7e9e9564847e03bee82c1 add-classic_table-support.patch
-db8c4ab3eae7c01943a61e9e3e20af45d4f6d196184eee5b94068b212900ccdeecaf4fb4145983226954f64e7c989fcd13e0b506176d2b3e781c2e9dc8b5a5a8 disable-multiarch-ppc32.patch
67a75a94fdba69de96b98dbc2978a50cb197857c464b81f7c956176da7066b3be937e40cb15e0870fc1e7382d662c5101bcd18cf457fc4112de41802042b51c4 gcc-5.4.0-locale.patch
-65a4d8bf9cefcbc79e86015ef4376b2794492d6cae77065359b35bb4ed630dde6256982cd5e43ed837cbbdab366ea376da9f1c83f80ddf6dc53ab017b378c3cd backport-r267157-posix-conformant-snprintf.patch
-23c20f258d1a21d0d706945376df8b93c0277a8dcd5183cc0b15c9f22250ef179833c725f877279f74e89364d772148526af5544ab7758172bfb758618554ad3 backport-r268048-memcpy-bounds.patch"
+65a4d8bf9cefcbc79e86015ef4376b2794492d6cae77065359b35bb4ed630dde6256982cd5e43ed837cbbdab366ea376da9f1c83f80ddf6dc53ab017b378c3cd backport-r267157-posix-conformant-snprintf.patch"
diff --git a/system/gcc/backport-r268048-memcpy-bounds.patch b/system/gcc/backport-r268048-memcpy-bounds.patch
deleted file mode 100644
index eebecd832..000000000
--- a/system/gcc/backport-r268048-memcpy-bounds.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88273
-
-GCC 8.2+ fails to build 32-bit PowerPC kernel due to this.
-
---- trunk/gcc/gimple-ssa-warn-restrict.c 2019/01/17 16:33:55 268037
-+++ trunk/gcc/gimple-ssa-warn-restrict.c 2019/01/17 22:52:47 268048
-@@ -319,13 +319,9 @@
- offrange[0] += offset_int::from (min, SIGNED);
- offrange[1] += offset_int::from (max, SIGNED);
- }
-- else if (rng == VR_ANTI_RANGE)
-- {
-- offrange[0] += offset_int::from (max + 1, SIGNED);
-- offrange[1] += offset_int::from (min - 1, SIGNED);
-- }
- else
- {
-+ /* Handle an anti-range the same as no range at all. */
- gimple *stmt = SSA_NAME_DEF_STMT (offset);
- tree type;
- if (is_gimple_assign (stmt)
diff --git a/system/gcc/disable-multiarch-ppc32.patch b/system/gcc/disable-multiarch-ppc32.patch
deleted file mode 100644
index 5ca9a1d0d..000000000
--- a/system/gcc/disable-multiarch-ppc32.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- gcc-8.3.0/gcc/config/rs6000/t-linux.old 2019-03-04 07:18:12.770000000 +0000
-+++ gcc-8.3.0/gcc/config/rs6000/t-linux 2019-03-05 03:22:15.030000000 +0000
-@@ -5,10 +5,10 @@
- MULTILIB_OSDIRNAMES := m64=../lib
- MULTILIB_OSDIRNAMES += m32=../lib32
- else
--MULTIARCH_DIRNAME := powerpc-linux-gnu
-+MULTIARCH_DIRNAME = $(call if_multiarch,powerpc-linux-gnu)
- endif
- ifneq (,$(findstring powerpcle,$(target)))
--MULTIARCH_DIRNAME := $(subst -linux,le-linux,$(MULTIARCH_DIRNAME))
-+MULTIARCH_DIRNAME := $(call if_multiarch,$(subst -linux,le-linux,$(MULTIARCH_DIRNAME)))
- endif
- ifneq (,$(findstring powerpc64le,$(target)))
- MULTILIB_OSDIRNAMES := m64=../lib