summaryrefslogtreecommitdiff
path: root/system/gcc
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-12 05:23:51 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-12 05:23:51 +0000
commitd09b437deebac78578edb9904a7f9981487e6cbb (patch)
treeb6055cb2865261206e87cea7950ab3a5137d0798 /system/gcc
parentd04fd494b968bcc786ea013b70e7423b38bfe179 (diff)
downloadpackages-d09b437deebac78578edb9904a7f9981487e6cbb.tar.gz
packages-d09b437deebac78578edb9904a7f9981487e6cbb.tar.bz2
packages-d09b437deebac78578edb9904a7f9981487e6cbb.tar.xz
packages-d09b437deebac78578edb9904a7f9981487e6cbb.zip
system/gcc: fix locale in libstdc++ (thanks @smaeul)
Diffstat (limited to 'system/gcc')
-rw-r--r--system/gcc/APKBUILD7
-rw-r--r--system/gcc/gcc-5.4.0-locale.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index e1c1957c1..0c97d5ef5 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -6,7 +6,7 @@ pkgver=6.4.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=9
+pkgrel=10
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -190,6 +190,8 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${_pkgbase:-$pkgver}/gcc-${_pkgba
fix-rs6000-pie.patch
add-classic_table-support.patch
lra-pentium.patch
+
+ gcc-5.4.0-locale.patch
"
# we build out-of-tree
@@ -660,4 +662,5 @@ f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45
cf19fcc6abee70210a9061e5385fe361a5eb59a74f7d34297420a53e351400da23a060164bef5b322daba4be90019481731acf93c45fb5a93430018f1aa7ce35 332-gccgo-remove-ustat.patch
01c71cd5881fc07ea3b9b980697e89b3ca0fe98502958ceafc3fca18b2604c844e2f457feab711baf8e03f00a5383b0e38aac7eb954034e306f43d4a37f165ed fix-rs6000-pie.patch
1860593584f629d24d5b6db14b0a3412e9f93449b663aaa4981301a0923db0159314905e694f27366fbfef72dce06636ab6df86862b7e9e9564847e03bee82c1 add-classic_table-support.patch
-4e1b421ed72668b66ecbcb0a34afa99d2a34cb2ea9ee51c4aad605fc8a0e94e3bfbabae4ebe236efc5ec86fc01a472cbe93f36fe25cf579714939d8102a9b84a lra-pentium.patch"
+4e1b421ed72668b66ecbcb0a34afa99d2a34cb2ea9ee51c4aad605fc8a0e94e3bfbabae4ebe236efc5ec86fc01a472cbe93f36fe25cf579714939d8102a9b84a lra-pentium.patch
+67a75a94fdba69de96b98dbc2978a50cb197857c464b81f7c956176da7066b3be937e40cb15e0870fc1e7382d662c5101bcd18cf457fc4112de41802042b51c4 gcc-5.4.0-locale.patch"
diff --git a/system/gcc/gcc-5.4.0-locale.patch b/system/gcc/gcc-5.4.0-locale.patch
new file mode 100644
index 000000000..dca3ba9e8
--- /dev/null
+++ b/system/gcc/gcc-5.4.0-locale.patch
@@ -0,0 +1,13 @@
+diff --git gcc-5.4.0/libstdc++-v3/config/locale/generic/c_locale.cc.orig gcc-5.4.0/libstdc++-v3/config/locale/generic/c_locale.cc
+--- gcc-5.4.0/libstdc++-v3/config/locale/generic/c_locale.cc.orig
++++ gcc-5.4.0/libstdc++-v3/config/locale/generic/c_locale.cc
+@@ -213,9 +213,6 @@ _GLIBCXX_BEGIN_NAMESPACE_VERSION
+ // Currently, the generic model only supports the "C" locale.
+ // See http://gcc.gnu.org/ml/libstdc++/2003-02/msg00345.html
+ __cloc = 0;
+- if (strcmp(__s, "C"))
+- __throw_runtime_error(__N("locale::facet::_S_create_c_locale "
+- "name not valid"));
+ }
+
+ void