summaryrefslogtreecommitdiff
path: root/system/gcc
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-21 04:02:27 -0400
committerMax Rees <maxcrees@me.com>2019-07-21 04:43:04 -0400
commit23bcb3767f6d16eaba523055f0b8474bfbae16ba (patch)
tree95327b88bac6651c45ca92c099d4fb300716ba49 /system/gcc
parentd3eb7058d8f66a7fa94c262314df4c95a76a36fc (diff)
downloadpackages-23bcb3767f6d16eaba523055f0b8474bfbae16ba.tar.gz
packages-23bcb3767f6d16eaba523055f0b8474bfbae16ba.tar.bz2
packages-23bcb3767f6d16eaba523055f0b8474bfbae16ba.tar.xz
packages-23bcb3767f6d16eaba523055f0b8474bfbae16ba.zip
system/*: initial bashism removal
Diffstat (limited to 'system/gcc')
-rw-r--r--system/gcc/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index 5eaae5163..68771a8aa 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -343,7 +343,7 @@ package() {
rm -f "$pkgdir"/usr/lib/libffi* "$pkgdir"/usr/share/man/man3/ffi*
find "$pkgdir" -name 'ffi*.h' | xargs rm -f
- local gdblib=${_target:+$CTARGET/}lib
+ local gdblib="${_target:+$CTARGET/}lib"
for i in $(find "$pkgdir"/usr/$gdblib/ -type f -maxdepth 1 -name "*-gdb.py" ); do
mkdir -p "$pkgdir"/usr/share/gdb/python/auto-load/usr/$gdblib
mv "$i" "$pkgdir"/usr/share/gdb/python/auto-load/usr/$gdblib/
@@ -368,7 +368,7 @@ package() {
# linker finds the libs from relocated sysroot
for so in "$pkgdir"/usr/$CTARGET/lib/*.so; do
if [ -h "$so" ]; then
- local _real=$(basename $(readlink "$so"))
+ local _real="$(basename $(readlink "$so"))"
rm -f "$so"
echo "GROUP ($_real)" > "$so"
fi