summaryrefslogtreecommitdiff
path: root/system/gettext-tiny
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-22 00:59:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-22 00:59:56 +0000
commitb116a08e20b134eea6fd90f7a47c9a239c6fc531 (patch)
tree23bdcc838caa5f4e8a8841dc663f5e2ab50393ff /system/gettext-tiny
parent5b06cb003037fe9214cd1e76fbf09f1c7ea05312 (diff)
downloadpackages-b116a08e20b134eea6fd90f7a47c9a239c6fc531.tar.gz
packages-b116a08e20b134eea6fd90f7a47c9a239c6fc531.tar.bz2
packages-b116a08e20b134eea6fd90f7a47c9a239c6fc531.tar.xz
packages-b116a08e20b134eea6fd90f7a47c9a239c6fc531.zip
system/gettext-tiny: Bump line length
Diffstat (limited to 'system/gettext-tiny')
-rw-r--r--system/gettext-tiny/APKBUILD4
-rw-r--r--system/gettext-tiny/line-length.patch15
2 files changed, 18 insertions, 1 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 3d064e116..702b85130 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.3.1_git20191130
-pkgrel=0
+pkgrel=1
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -12,6 +12,7 @@ depends=""
makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
+ line-length.patch
respect-cflags.patch
stop-doing-macro-crap.patch
"
@@ -25,5 +26,6 @@ package() {
}
sha512sums="a318135626a0403a30a81fa475f7e1878b8af5a87053b0e00876c73b591508f3cf1e66d01f8d6a45013d1dc36a4da9f21fbf2b5050676826cb618b5b659aaaf7 gettext-tiny-0.3.1_git20191130.tar.xz
+0a26a8481bffe2ce8c73f7f500963aea9db8379fb87849142d8efabf1656604b22f6ad345483256f14c388466f2f44e5924b9f65d88f26867a753a96d1529270 line-length.patch
b4e7db4e415f6bc31f2214f2044506ad18ea0bd3cae4200d93bbd34aa493c7478a7f953d0a7e08f29f0fd5a5d7b7cbfa2bcfd5692c37e423706a1c193239bf1d respect-cflags.patch
cd4cfc8cc6ea998f1e33ef666e3b9c3de3f3253994bccc942b177773c94f785e3892cb7d5f34bec1102dc7558236c07c5eac90e15d755e12ee06836336373526 stop-doing-macro-crap.patch"
diff --git a/system/gettext-tiny/line-length.patch b/system/gettext-tiny/line-length.patch
new file mode 100644
index 000000000..0ba978197
--- /dev/null
+++ b/system/gettext-tiny/line-length.patch
@@ -0,0 +1,15 @@
+https://github.com/sabotage-linux/gettext-tiny/issues/50
+
+We're losing the battle of the bulge; someone really should make this use malloc.
+
+--- gettext-tiny-0.3.1_git20191130/src/msgfmt.c.old 2020-01-14 08:03:11.000000000 +0000
++++ gettext-tiny-0.3.1_git20191130/src/msgfmt.c 2020-01-21 18:58:28.257709860 +0000
+@@ -160,7 +160,7 @@
+
+ int process(FILE *in, FILE *out, bool strict) {
+ struct mo_hdr mohdr = def_hdr;
+- char line[8192]; char *lp;
++ char line[12288]; char *lp;
+ size_t off, i;
+ enum po_error t;
+ char convbuf[32768];