summaryrefslogtreecommitdiff
path: root/system/gettext-tiny
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-16 21:24:30 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-16 21:24:30 -0500
commit758909b6019d61735430457a1be3c41228836104 (patch)
tree22b5e0e35f88ca154f1f0d848e7b51455a5be876 /system/gettext-tiny
parent82e94e7e4a3eb810722a7692e8aa058edc5f1f0b (diff)
downloadpackages-758909b6019d61735430457a1be3c41228836104.tar.gz
packages-758909b6019d61735430457a1be3c41228836104.tar.bz2
packages-758909b6019d61735430457a1be3c41228836104.tar.xz
packages-758909b6019d61735430457a1be3c41228836104.zip
system/gettext-tiny: respect CFLAGS if set
Diffstat (limited to 'system/gettext-tiny')
-rw-r--r--system/gettext-tiny/APKBUILD4
-rw-r--r--system/gettext-tiny/respect-cflags.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 4a6d253d6..ec3ed5afc 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.2.0
-pkgrel=3
+pkgrel=4
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -14,6 +14,7 @@ install=""
subpackages="$pkgname-dev"
source="http://ftp.barfooze.de/pub/sabotage/tarballs/gettext-tiny-$pkgver.tar.xz
cheap-hack-for-autopoint.patch
+ respect-cflags.patch
stop-doing-macro-crap.patch
"
@@ -29,4 +30,5 @@ package() {
sha512sums="4d8d9d02042adf023bfd2502fa7598f9b16ef2e03dd3d39fd3ba36f1be1d884d1b891600d9263e11948e3979909ea810a1d1b8cefc7e522feda8b422a1107a2e gettext-tiny-0.2.0.tar.xz
ffb10a0ee12acb843d94f160ae0f508cdd6e20a51a3207647ed312da4261247dcf0f16b7b5536b92c62fc0c274cf8ecc2de978fe936201d26d955b9723b1e1ea cheap-hack-for-autopoint.patch
+cea1596f3f20c8983e57d2e49e955a43ed2e261b244f6c4c2ae7d8b869e3cfce3bb87b0a17c16bdac59afd99703cef9c7ef4e93fca536bf1bf9aa5f9be9fa34f respect-cflags.patch
d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch"
diff --git a/system/gettext-tiny/respect-cflags.patch b/system/gettext-tiny/respect-cflags.patch
new file mode 100644
index 000000000..b949371c4
--- /dev/null
+++ b/system/gettext-tiny/respect-cflags.patch
@@ -0,0 +1,11 @@
+--- gettext-tiny-0.2.0/Makefile.old 2017-08-02 06:14:20.000000000 -0500
++++ gettext-tiny-0.2.0/Makefile 2018-06-16 21:21:57.148735892 -0500
+@@ -29,7 +29,7 @@
+ ALL_TOOLS=msgfmt msgmerge xgettext autopoint
+ ALL_M4S=$(sort $(wildcard m4/*.m4))
+
+-CFLAGS=-O0 -fPIC
++CFLAGS ?= -O0 -fPIC
+
+ AR ?= $(CROSS_COMPILE)ar
+ RANLIB ?= $(CROSS_COMPILE)ranlib