summaryrefslogtreecommitdiff
path: root/system/gettext-tiny
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-15 02:52:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-15 02:52:29 -0500
commit847761ee92ded0fabdcbeb077045d8ce1a5d2899 (patch)
tree62103bd16587f76c9794dc3e68244dec4c0819cf /system/gettext-tiny
parenta45727815b1d1d76262ac60cc52c4886c30b39db (diff)
downloadpackages-847761ee92ded0fabdcbeb077045d8ce1a5d2899.tar.gz
packages-847761ee92ded0fabdcbeb077045d8ce1a5d2899.tar.bz2
packages-847761ee92ded0fabdcbeb077045d8ce1a5d2899.tar.xz
packages-847761ee92ded0fabdcbeb077045d8ce1a5d2899.zip
system/gettext-tiny: fix macro crap
Diffstat (limited to 'system/gettext-tiny')
-rw-r--r--system/gettext-tiny/APKBUILD8
-rw-r--r--system/gettext-tiny/stop-doing-macro-crap.patch20
2 files changed, 25 insertions, 3 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 38e2cc972..cb80dfcbe 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -12,7 +12,8 @@ depends="!gettext"
depends_dev="!gettext-dev"
install=""
subpackages="$pkgname-dev"
-source="http://ftp.barfooze.de/pub/sabotage/tarballs/gettext-tiny-$pkgver.tar.xz"
+source="http://ftp.barfooze.de/pub/sabotage/tarballs/gettext-tiny-$pkgver.tar.xz
+ stop-doing-macro-crap.patch"
build() {
cd "$builddir"
@@ -24,4 +25,5 @@ package() {
make DESTDIR="$pkgdir" prefix=/usr install
}
-sha512sums="4d8d9d02042adf023bfd2502fa7598f9b16ef2e03dd3d39fd3ba36f1be1d884d1b891600d9263e11948e3979909ea810a1d1b8cefc7e522feda8b422a1107a2e gettext-tiny-0.2.0.tar.xz"
+sha512sums="4d8d9d02042adf023bfd2502fa7598f9b16ef2e03dd3d39fd3ba36f1be1d884d1b891600d9263e11948e3979909ea810a1d1b8cefc7e522feda8b422a1107a2e gettext-tiny-0.2.0.tar.xz
+d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch"
diff --git a/system/gettext-tiny/stop-doing-macro-crap.patch b/system/gettext-tiny/stop-doing-macro-crap.patch
new file mode 100644
index 000000000..8886b4eb5
--- /dev/null
+++ b/system/gettext-tiny/stop-doing-macro-crap.patch
@@ -0,0 +1,20 @@
+--- gettext-tiny-0.2.0/include/libintl.h.old 2017-08-02 06:14:20.000000000 -0500
++++ gettext-tiny-0.2.0/include/libintl.h 2018-06-15 02:31:14.241446687 -0500
+@@ -15,14 +15,14 @@
+ #undef gettext_noop
+ #define gettext_noop(X) X
+
+-#ifndef LIBINTL_NO_MACROS
++#ifdef LIBINTL_MACROS
+ /* if these macros are defined, configure checks will detect libintl as
+ * built into the libc because test programs will work without -lintl.
+ * for example:
+ * checking for ngettext in libc ... yes
+ * the consequence is that -lintl will not be added to the LDFLAGS.
+- * so if for some reason you want that libintl.a gets linked,
+- * add -DLIBINTL_NO_MACROS=1 to your CPPFLAGS. */
++ * so if for some reason you dont want that libintl.a gets linked,
++ * add -DLIBINTL_MACROS=1 to your CPPFLAGS. */
+
+ #define gettext(X) ((char*) (X))
+ #define dgettext(dom, X) ((void)(dom), (char*) (X))