summaryrefslogtreecommitdiff
path: root/system/git
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-12 18:09:32 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:44 -0500
commitcb77e59c49b16e0383d1989b1efaea52f845b669 (patch)
tree9f5fde649d8e185d8b3db4041706fb5cb830079c /system/git
parent3c74645a3f795c6d5be1a50549bfb18bfda3b16c (diff)
downloadpackages-cb77e59c49b16e0383d1989b1efaea52f845b669.tar.gz
packages-cb77e59c49b16e0383d1989b1efaea52f845b669.tar.bz2
packages-cb77e59c49b16e0383d1989b1efaea52f845b669.tar.xz
packages-cb77e59c49b16e0383d1989b1efaea52f845b669.zip
system/git: disable part 2/5 of test t2082. fixes #466.
Diffstat (limited to 'system/git')
-rw-r--r--system/git/APKBUILD5
-rw-r--r--system/git/disable-t2082-2.patch36
2 files changed, 40 insertions, 1 deletions
diff --git a/system/git/APKBUILD b/system/git/APKBUILD
index c2860df51..4b721680d 100644
--- a/system/git/APKBUILD
+++ b/system/git/APKBUILD
@@ -28,6 +28,8 @@ source="https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar.xz
dont-test-other-encodings.patch
git-daemon.initd
git-daemon.confd
+
+ disable-t2082-2.patch
"
_gitcoredir=/usr/libexec/git-core
@@ -168,4 +170,5 @@ subtree() {
sha512sums="a1a8e9e6f64b1da25508fbd2f783564dcdbe181fb5ff1ebab3bdac6db6094e18acc334479a1abf22ac17ce4f733cc3e10a664db9ab234cd523735a3f027b42db git-2.34.1.tar.xz
0a0935d876024d96156df3aeec06b47fd9e370484d4552786c450cb500ae671a631e64c30994ec39f43a2f313f75d68909688ea92b47327d1af65e365dc77480 dont-test-other-encodings.patch
89528cdd14c51fd568aa61cf6c5eae08ea0844e59f9af9292da5fc6c268261f4166017d002d494400945e248df6b844e2f9f9cd2d9345d516983f5a110e4c42a git-daemon.initd
-fbf1f425206a76e2a8f82342537ed939ff7e623d644c086ca2ced5f69b36734695f9f80ebda1728f75a94d6cd2fcb71bf845b64239368caab418e4d368c141ec git-daemon.confd"
+fbf1f425206a76e2a8f82342537ed939ff7e623d644c086ca2ced5f69b36734695f9f80ebda1728f75a94d6cd2fcb71bf845b64239368caab418e4d368c141ec git-daemon.confd
+6d7cbb701584a078328056a67bfd32dde5795a80c0911734b38bd534699fb0165ac2b486b267c5c39b90bbb0d7c5ab0ab6ada1d068748865617326da28304eb4 disable-t2082-2.patch"
diff --git a/system/git/disable-t2082-2.patch b/system/git/disable-t2082-2.patch
new file mode 100644
index 000000000..b18a9caa7
--- /dev/null
+++ b/system/git/disable-t2082-2.patch
@@ -0,0 +1,36 @@
+--- a/t/t2082-parallel-checkout-attributes.sh 2021-11-24 19:29:21.000000000 +0000
++++ b/t/t2082-parallel-checkout-attributes.sh 2022-01-12 17:29:58.890000000 +0000
+@@ -33,33 +33,6 @@
+ )
+ '
+
+-test_expect_success 'parallel-checkout with re-encoding' '
+- set_checkout_config 2 0 &&
+- git init encoding &&
+- (
+- cd encoding &&
+- echo text >utf8-text &&
+- write_utf16 <utf8-text >utf16-text &&
+-
+- echo "A working-tree-encoding=UTF-16" >.gitattributes &&
+- cp utf16-text A &&
+- cp utf8-text B &&
+- git add A B .gitattributes &&
+- git commit -m encoding &&
+-
+- # Check that A is stored in UTF-8
+- git cat-file -p :A >A.internal &&
+- test_cmp_bin utf8-text A.internal &&
+-
+- rm A B &&
+- test_checkout_workers 2 git checkout A B &&
+-
+- # Check that A (and only A) is re-encoded during checkout
+- test_cmp_bin utf16-text A &&
+- test_cmp_bin utf8-text B
+- )
+-'
+-
+ test_expect_success 'parallel-checkout with eol conversions' '
+ set_checkout_config 2 0 &&
+ git init eol &&