summaryrefslogtreecommitdiff
path: root/system/glib-networking
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:11:51 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:11:51 -0500
commitc86aec496298fb20f0770f5ce9a2a37935f7aa5b (patch)
treeb95d17ae82ab73a2a147a2f0c9734c309e5f9807 /system/glib-networking
parentfd2bb2f751c13b3c0c002b8e012810902b9da364 (diff)
downloadpackages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.gz
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.bz2
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.xz
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.zip
put user stuff in user, not system
Diffstat (limited to 'system/glib-networking')
-rw-r--r--system/glib-networking/APKBUILD43
-rw-r--r--system/glib-networking/proxy-test.patch13
2 files changed, 0 insertions, 56 deletions
diff --git a/system/glib-networking/APKBUILD b/system/glib-networking/APKBUILD
deleted file mode 100644
index 65ae109a0..000000000
--- a/system/glib-networking/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=glib-networking
-pkgver=2.54.1
-_maj=${pkgver%%.*}
-_min=${pkgver#${_maj}.}
-_min=${_min%%.*}
-_ver=$_maj.$_min
-pkgrel=1
-pkgdesc="Networking support for GLib"
-url="http://www.gnome.org"
-arch="all"
-license="LGPL-2.1+"
-depends="ca-certificates"
-makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash p11-kit-dev"
-install=
-subpackages="$pkgname-lang"
-source="http://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
-
-build() {
- cd "$builddir"
- CONFIG_SHELL=/bin/bash ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-more-warnings \
- --with-libproxy \
- --with-gnutls
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- rm -f "$pkgdir"/usr/lib/gio/modules/*.a
-}
-
-sha512sums="8356d835914e33df43f4f2bb6a915ddcd48dd0565e4d5bc1f1d692e9c3124ee4421b99f87f2586f74e9fed24ef7421159f3242fd1eb7bd74950bd25e860896ec glib-networking-2.54.1.tar.xz"
diff --git a/system/glib-networking/proxy-test.patch b/system/glib-networking/proxy-test.patch
deleted file mode 100644
index 2cab5d9f6..000000000
--- a/system/glib-networking/proxy-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./Makefile.am.orig
-+++ ./Makefile.am
-@@ -11,9 +11,9 @@
-
- if HAVE_GNOME_PROXY
- SUBDIRS += proxy/gnome
-+SUBDIRS += proxy/tests
- endif
-
--SUBDIRS += proxy/tests
-
- if HAVE_GNUTLS
- SUBDIRS += tls/gnutls