summaryrefslogtreecommitdiff
path: root/system/glib
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:11:51 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-08 02:11:51 -0500
commitc86aec496298fb20f0770f5ce9a2a37935f7aa5b (patch)
treeb95d17ae82ab73a2a147a2f0c9734c309e5f9807 /system/glib
parentfd2bb2f751c13b3c0c002b8e012810902b9da364 (diff)
downloadpackages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.gz
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.bz2
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.tar.xz
packages-c86aec496298fb20f0770f5ce9a2a37935f7aa5b.zip
put user stuff in user, not system
Diffstat (limited to 'system/glib')
-rw-r--r--system/glib/0001-gquark-fix-initialization-with-c-constructors.patch47
-rw-r--r--system/glib/APKBUILD103
-rw-r--r--system/glib/broken-gio-tests.patch100
-rw-r--r--system/glib/fix-spawn.patch22
-rw-r--r--system/glib/glib.trigger16
-rw-r--r--system/glib/i386-fpu-test.patch13
-rw-r--r--system/glib/musl-no-locale.patch55
-rw-r--r--system/glib/ridiculous-strerror-nonconformance.patch11
-rw-r--r--system/glib/thread-test-fix.patch11
9 files changed, 0 insertions, 378 deletions
diff --git a/system/glib/0001-gquark-fix-initialization-with-c-constructors.patch b/system/glib/0001-gquark-fix-initialization-with-c-constructors.patch
deleted file mode 100644
index 50a9a8c28..000000000
--- a/system/glib/0001-gquark-fix-initialization-with-c-constructors.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From e4216dee57f5156e192b2910f13eb855a104cb18 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 6 Jul 2016 12:38:40 +0200
-Subject: [PATCH] gquark: fix initialization with c++ constructors
-
-C++ constructors may want create new quarks, but we can not guarantee
-that the glib library ctor is executed first. Therefore we make sure
-that quarks are always initialized from g_quark_from_string and
-g_quark_from_static_string
-
-This fixes crashes in glibmm with musl which likely happens on AIX too.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=768215
-https://bugzilla.gnome.org/show_bug.cgi?id=756139#c14
----
- glib/gquark.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/glib/gquark.c b/glib/gquark.c
-index 9e51a92..17ecd7f 100644
---- a/glib/gquark.c
-+++ b/glib/gquark.c
-@@ -57,6 +57,11 @@ static gint quark_block_offset = 0;
- void
- g_quark_init (void)
- {
-+ /* we may be initialized from c++ constructor or the glib ctor, but we
-+ cannot guarantee in what order. So we check if we have been initialized */
-+ if (quark_ht != NULL)
-+ return;
-+
- g_assert (quark_seq_id == 0);
- quark_ht = g_hash_table_new (g_str_hash, g_str_equal);
- quarks = g_new (gchar*, QUARK_BLOCK_SIZE);
-@@ -179,6 +184,9 @@ quark_from_string (const gchar *string,
- {
- GQuark quark = 0;
-
-+ if (G_UNLIKELY (quark_ht == NULL))
-+ g_quark_init();
-+
- quark = GPOINTER_TO_UINT (g_hash_table_lookup (quark_ht, string));
-
- if (!quark)
---
-2.9.0
-
diff --git a/system/glib/APKBUILD b/system/glib/APKBUILD
deleted file mode 100644
index 89a98754f..000000000
--- a/system/glib/APKBUILD
+++ /dev/null
@@ -1,103 +0,0 @@
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=glib
-pkgver=2.54.2
-pkgrel=1
-pkgdesc="Common C routines used by Gtk+ and other libs"
-url="https://developer.gnome.org/glib/"
-arch="all"
-license="GPL"
-depends=
-triggers="$pkgname.trigger=/usr/share/glib-2.0/schemas:/usr/lib/gio/modules"
-depends_dev="perl python3 attr-dev gettext-dev zlib-dev bzip2-dev libffi-dev
- util-linux-dev"
-makedepends="$depends_dev pcre-dev xmlto"
-checkdepends="tzdata"
-options="!checkroot"
-source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
- 0001-gquark-fix-initialization-with-c-constructors.patch
- broken-gio-tests.patch
- fix-spawn.patch
- i386-fpu-test.patch
- musl-no-locale.patch
- ridiculous-strerror-nonconformance.patch
- thread-test-fix.patch
- "
-subpackages="$pkgname-dbg $pkgname-doc $pkgname-static $pkgname-dev $pkgname-lang $pkgname-bash-completion:bashcomp:noarch"
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$builddir"
- default_prepare
-
- # workaround packaging issue. gtk-doc.make timestamp was newer than
- # Makefile.am, which triggers automake re-run
- touch -r docs/reference/glib/Makefile.am gtk-doc.make
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --disable-gtk-doc \
- --disable-compile-warnings \
- --disable-selinux \
- --with-pcre=system \
- --with-python=python3 \
- --with-pic \
- --enable-static
- make
-}
-
-check() {
- cd "$builddir"
- make check
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/lib/charset.alias
-}
-
-dev() {
- default_dev
- mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/share
- find "$pkgdir"/usr/bin ! -name "glib-compile-schemas" -a \( \
- -name "gdbus-codegen" -o \
- -name "gobject-query" -o \
- -name "gresource" -o \
- -name "gtester*" -o \
- -name "glib-*" \) \
- -exec mv {} "$subpkgdir"/usr/bin \;
- mv "$pkgdir"/usr/share/gdb "$pkgdir"/usr/share/glib-2.0 \
- "$subpkgdir"/usr/share
-}
-
-static() {
- pkgdesc="glib static libraries"
- depends="gettext-static"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
-}
-
-bashcomp() {
- pkgdesc="Bash completion for $pkgname"
- depends=
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
- [ "$(ls -A "$pkgdir"/usr/share)" ] || rmdir "$pkgdir"/usr/share
-}
-
-sha512sums="09ee6fa3a6f3f15af229bd789bef536e3570f36d1e4ce624a57e97c4040577f6baccd6ab5746257863ccf7173b558cfa753951d562a278f854e52604104ba7ee glib-2.54.2.tar.xz
-32e5aca9a315fb985fafa0b4355e4498c1f877fc1f0b58ad4ac261fb9fbced9f026c7756a5f2af7d61ce756b55c8cd02811bb08df397040e93510056f073756b 0001-gquark-fix-initialization-with-c-constructors.patch
-9bf99de4672765704759098c883cfc4d2747cf10d9d568ae97134806a089e4bebae57886bae45dcc53694e0190248abe6ae52cc38dc742cd754d352406ac0680 broken-gio-tests.patch
-0f0a98784aeed92f33cd9239d2f668bdc6c09b84ed020825ae88f6aacf6a922152dc3e1384c40d9f30f54c5ab78fe17e0ee5c42b268b297b595d2a6cde5b8998 fix-spawn.patch
-aa7444bbdf7b88798adc67c15cdb8b7459450c0b7357caea16b74462c5c9179ba80d4018b1e656e90a5e3be5b2e3c14e9b8c0ccbb2ee4d8c92dc8fa627518b84 i386-fpu-test.patch
-10d23961072e3d8c8bbe5ee9a6b6ad709734690485c7148f1f8a2081a3ecc06cc3e3ff02ea870e1b429cd8464df6ef6e9f266148010d889fd187f4e411f65bab musl-no-locale.patch
-56c10a0f64cbd8ce584d428f818e7e678fdeb40a32df792843208ddfa3135d362cc2077bc9fe3bfebe13ee6af0ecf6403a593ad727e0a92276074a17a9c7029c ridiculous-strerror-nonconformance.patch
-0cebf9cbf87a92c3160054eb30189a827847f5820a8b90f4842b4ad5ab5cc343ba06e5f55214864bd0f0d5a21e55ec5e7f35c66207e77b1496142b7ee0c75567 thread-test-fix.patch"
diff --git a/system/glib/broken-gio-tests.patch b/system/glib/broken-gio-tests.patch
deleted file mode 100644
index d7006db87..000000000
--- a/system/glib/broken-gio-tests.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-Requires update-desktop-database
---- glib-2.52.1/gio/tests/appinfo.c.old 2016-10-22 00:17:49.000000000 -0500
-+++ glib-2.52.1/gio/tests/appinfo.c 2017-08-20 23:23:32.581229536 -0500
-@@ -486,7 +486,7 @@
- g_test_add_func ("/appinfo/launch-context", test_launch_context);
- g_test_add_func ("/appinfo/launch-context-signals", test_launch_context_signals);
- g_test_add_func ("/appinfo/tryexec", test_tryexec);
-- g_test_add_func ("/appinfo/associations", test_associations);
-+ //g_test_add_func ("/appinfo/associations", test_associations);
- g_test_add_func ("/appinfo/environment", test_environment);
- g_test_add_func ("/appinfo/startup-wm-class", test_startup_wm_class);
- g_test_add_func ("/appinfo/supported-types", test_supported_types);
-
-
-Requires shared-mime-info
---- glib-2.53.7/gio/tests/contenttype.c.old 2017-07-13 18:03:39.000000000 -0500
-+++ glib-2.53.7/gio/tests/contenttype.c 2017-09-05 21:41:46.312547646 -0500
-@@ -345,9 +345,9 @@
-
- g_test_bug_base ("http://bugzilla.gnome.org/");
-
-- g_test_add_func ("/contenttype/guess", test_guess);
-+ //g_test_add_func ("/contenttype/guess", test_guess);
- g_test_add_func ("/contenttype/unknown", test_unknown);
-- g_test_add_func ("/contenttype/subtype", test_subtype);
-+ /*g_test_add_func ("/contenttype/subtype", test_subtype);
- g_test_add_func ("/contenttype/list", test_list);
- g_test_add_func ("/contenttype/executable", test_executable);
- g_test_add_func ("/contenttype/description", test_description);
-@@ -355,7 +355,7 @@
- g_test_add_func ("/contenttype/symbolic-icon", test_symbolic_icon);
- g_test_add_func ("/contenttype/tree", test_tree);
- g_test_add_func ("/contenttype/test_type_is_a_special_case",
-- test_type_is_a_special_case);
-+ test_type_is_a_special_case);*/
-
- return g_test_run ();
- }
-
-
-Requires working iconv
---- glib-2.52.1/gio/tests/converter-stream.c.old 2016-10-22 00:18:11.000000000 -0500
-+++ glib-2.52.1/gio/tests/converter-stream.c 2017-08-20 23:21:31.711358101 -0500
-@@ -1203,7 +1203,7 @@
- };
- CharsetTest charset_tests[] = {
- { "/converter-input-stream/charset/utf8->latin1", "UTF-8", "\303\205rr Sant\303\251", "ISO-8859-1", "\305rr Sant\351", 0 },
-- { "/converter-input-stream/charset/latin1->utf8", "ISO-8859-1", "\305rr Sant\351", "UTF-8", "\303\205rr Sant\303\251", 0 },
-+ //{ "/converter-input-stream/charset/latin1->utf8", "ISO-8859-1", "\305rr Sant\351", "UTF-8", "\303\205rr Sant\303\251", 0 },
-- { "/converter-input-stream/charset/fallbacks", "UTF-8", "Some characters just don't fit into latin1: πא", "ISO-8859-1", "Some characters just don't fit into latin1: \\CF\\80\\D7\\90", 4 },
-+ //{ "/converter-input-stream/charset/fallbacks", "UTF-8", "Some characters just don't fit into latin1: πא", "ISO-8859-1", "Some characters just don't fit into latin1: \\CF\\80\\D7\\90", 4 },
- };
-
-
-
-Requires dconf
---- glib-2.52.1/gio/tests/gsettings.c.old 2017-08-20 23:26:31.284378974 -0500
-+++ glib-2.52.1/gio/tests/gsettings.c 2017-08-20 23:26:46.637699607 -0500
-@@ -2603,6 +2603,8 @@
- gchar *schema_text;
- gchar *enums;
- gint result;
-+ printf("1..0\n");
-+ return 0;
-
- setlocale (LC_ALL, "");
-
-
-Requires update-desktop-database
---- glib-2.52.1/gio/tests/desktop-app-info.c.old 2016-10-22 00:17:55.000000000 -0500
-+++ glib-2.52.1/gio/tests/desktop-app-info.c 2017-08-20 23:38:16.840439686 -0500
-@@ -761,6 +761,8 @@
- {
- gint result;
-
-+ printf("1..0\n");
-+ return 0;
- g_test_init (&argc, &argv, NULL);
-
- basedir = g_get_current_dir ();
-
-
---- glib-2.52.1/gio/tests/resources.c.old 2016-10-22 00:18:12.000000000 -0500
-+++ glib-2.52.1/gio/tests/resources.c 2017-08-20 23:39:47.127025718 -0500
-@@ -426,6 +426,7 @@
- g_assert_cmpstr (g_bytes_get_data (data, NULL), ==, "test1\n");
- g_bytes_unref (data);
-
-+#if 0 // dlclose is noop on musl
- g_type_module_unuse (G_TYPE_MODULE (module));
-
- found = g_resources_get_info ("/resourceplugin/test1.txt",
-@@ -434,6 +435,7 @@
- g_assert (!found);
- g_assert_error (error, G_RESOURCE_ERROR, G_RESOURCE_ERROR_NOT_FOUND);
- g_clear_error (&error);
-+#endif
- }
- }
-
diff --git a/system/glib/fix-spawn.patch b/system/glib/fix-spawn.patch
deleted file mode 100644
index df352fdc3..000000000
--- a/system/glib/fix-spawn.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- glib-2.52.1/glib/tests/spawn-singlethread.c.old 2016-10-22 00:21:35.000000000 -0500
-+++ glib-2.52.1/glib/tests/spawn-singlethread.c 2017-08-20 22:31:52.548311424 -0500
-@@ -210,7 +210,7 @@
- g_test_init (&argc, &argv, NULL);
-
- dirname = g_path_get_dirname (argv[0]);
-- echo_prog_path = g_build_filename (dirname, "test-spawn-echo" EXEEXT, NULL);
-+ echo_prog_path = g_build_filename (dirname, "../test-spawn-echo" EXEEXT, NULL);
- if (!g_file_test (echo_prog_path, G_FILE_TEST_EXISTS))
- {
- g_free (echo_prog_path);
---- glib-2.52.1/glib/tests/spawn-multithreaded.c.old 2016-10-22 00:21:44.000000000 -0500
-+++ glib-2.52.1/glib/tests/spawn-multithreaded.c 2017-08-20 22:32:15.981614460 -0500
-@@ -222,7 +222,7 @@
- g_test_init (&argc, &argv, NULL);
-
- dirname = g_path_get_dirname (argv[0]);
-- echo_prog_path = g_build_filename (dirname, "test-spawn-echo" EXEEXT, NULL);
-+ echo_prog_path = g_build_filename (dirname, "../test-spawn-echo" EXEEXT, NULL);
- if (!g_file_test (echo_prog_path, G_FILE_TEST_EXISTS))
- {
- g_free (echo_prog_path);
diff --git a/system/glib/glib.trigger b/system/glib/glib.trigger
deleted file mode 100644
index cf23eff7d..000000000
--- a/system/glib/glib.trigger
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-for i in "$@"; do
- if ! [ -e "$i" ]; then
- continue
- fi
- case "$i" in
- */modules)
- /usr/bin/gio-querymodules "$i"
- ;;
- */schemas)
- /usr/bin/glib-compile-schemas "$i"
- ;;
- esac
-done
-
diff --git a/system/glib/i386-fpu-test.patch b/system/glib/i386-fpu-test.patch
deleted file mode 100644
index 986c33164..000000000
--- a/system/glib/i386-fpu-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- glib-2.54.2/glib/tests/timer.c.old 2016-10-22 00:21:30.000000000 -0500
-+++ glib-2.54.2/glib/tests/timer.c 2018-03-03 18:39:40.424741042 -0600
-@@ -203,7 +203,10 @@
- {
- g_test_init (&argc, &argv, NULL);
-
-+ /* This test fails on the i386 because of crappy FPU */
-+#ifndef __i386__
- g_test_add_func ("/timer/basic", test_timer_basic);
-+#endif
- g_test_add_func ("/timer/stop", test_timer_stop);
- g_test_add_func ("/timer/continue", test_timer_continue);
- g_test_add_func ("/timer/reset", test_timer_reset);
diff --git a/system/glib/musl-no-locale.patch b/system/glib/musl-no-locale.patch
deleted file mode 100644
index 4b36b0b2e..000000000
--- a/system/glib/musl-no-locale.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- glib-2.52.1/glib/tests/option-context.c.old 2016-10-22 05:21:34.000000000 +0000
-+++ glib-2.52.1/glib/tests/option-context.c 2017-08-20 23:14:46.364133517 +0000
-@@ -638,7 +638,7 @@
-
- old_locale = g_strdup (setlocale (LC_NUMERIC, locale));
- current_locale = setlocale (LC_NUMERIC, NULL);
-- if (strcmp (current_locale, locale) != 0)
-+ //if (strcmp (current_locale, locale) != 0)
- {
- fprintf (stderr, "Cannot set locale to %s, skipping\n", locale);
- goto cleanup;
---- glib-2.52.1/glib/tests/gdatetime.c.old 2017-03-16 20:12:05.000000000 -0500
-+++ glib-2.52.1/glib/tests/gdatetime.c 2017-08-20 22:20:37.805908983 -0500
-@@ -1068,7 +1068,7 @@
-
- oldlocale = g_strdup (setlocale (LC_ALL, NULL));
- setlocale (LC_ALL, "fa_IR.utf-8");
-- if (strstr (setlocale (LC_ALL, NULL), "fa_IR") != NULL)
-+ if ((1 == 0) && strstr (setlocale (LC_ALL, NULL), "fa_IR") != NULL)
- {
- TEST_PRINTF_TIME (23, 0, 0, "%OH", "\333\262\333\263"); /* '23' */
- TEST_PRINTF_TIME (23, 0, 0, "%OI", "\333\261\333\261"); /* '11' */
---- glib-2.52.1/glib/tests/convert.c.old 2016-10-22 00:21:34.000000000 -0500
-+++ glib-2.52.1/glib/tests/convert.c 2017-08-20 22:51:48.363430954 -0500
-@@ -707,7 +707,7 @@
-
- g_test_add_func ("/conversion/no-conv", test_no_conv);
- g_test_add_func ("/conversion/iconv-state", test_iconv_state);
-- g_test_add_func ("/conversion/illegal-sequence", test_one_half);
-+ //g_test_add_func ("/conversion/illegal-sequence", test_one_half);
-- g_test_add_func ("/conversion/byte-order", test_byte_order);
-+ //g_test_add_func ("/conversion/byte-order", test_byte_order);
- g_test_add_func ("/conversion/unicode", test_unicode_conversions);
- g_test_add_func ("/conversion/filename-utf8", test_filename_utf8);
---- glib-2.54.2/glib/tests/collate.c.old 2017-03-08 21:37:21.000000000 -0600
-+++ glib-2.54.2/glib/tests/collate.c 2018-03-01 01:07:56.957714447 -0600
-@@ -279,7 +279,7 @@
-
- g_setenv ("LC_ALL", "en_US", TRUE);
- locale = setlocale (LC_ALL, "");
-- if (locale == NULL || strcmp (locale, "en_US") != 0)
-+ //if (locale == NULL || strcmp (locale, "en_US") != 0)
- {
- g_test_message ("No suitable locale, skipping tests");
- missing_locale = TRUE;
---- glib-2.54.2/tests/run-collate-tests.sh.old 2016-10-22 00:17:10.000000000 -0500
-+++ glib-2.54.2/tests/run-collate-tests.sh 2018-03-01 01:22:01.107722429 -0600
-@@ -1,5 +1,7 @@
- #! /bin/sh
-
-+exit 77
-+
- fail ()
- {
- echo "Test failed: $*"
diff --git a/system/glib/ridiculous-strerror-nonconformance.patch b/system/glib/ridiculous-strerror-nonconformance.patch
deleted file mode 100644
index 3ffc0aafa..000000000
--- a/system/glib/ridiculous-strerror-nonconformance.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- glib-2.52.1/glib/tests/strfuncs.c.old 2016-10-22 00:21:44.000000000 -0500
-+++ glib-2.52.1/glib/tests/strfuncs.c 2017-08-20 22:48:18.233702952 -0500
-@@ -1335,7 +1335,7 @@
- setlocale (LC_ALL, "C");
-
- strs = g_hash_table_new (g_str_hash, g_str_equal);
-- for (i = 1; i < 200; i++)
-+ for (i = 1; i < 40; i++)
- {
- str = g_strerror (i);
- g_assert (str != NULL);
diff --git a/system/glib/thread-test-fix.patch b/system/glib/thread-test-fix.patch
deleted file mode 100644
index bcfcfc441..000000000
--- a/system/glib/thread-test-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- glib-2.52.1/glib/tests/thread.c.old 2016-10-22 05:21:37.000000000 +0000
-+++ glib-2.52.1/glib/tests/thread.c 2017-08-20 04:51:46.756496035 +0000
-@@ -174,7 +174,7 @@
- static gpointer
- thread6_func (gpointer data)
- {
--#ifdef HAVE_PTHREAD_SETNAME_NP_WITH_TID
-+#if 0
- char name[16];
-
- pthread_getname_np (pthread_self(), name, 16);