summaryrefslogtreecommitdiff
path: root/system/gzip
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:56 -0500
commitb1eb50599e4db7eb4501af75cbbfa22007081ea5 (patch)
treec94a34c882cc17adedd781e8c5f34349b2a62416 /system/gzip
parentb9e85bbdcf38547ef2ca4e5c2a6e6293bbcd2752 (diff)
downloadpackages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.gz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.bz2
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.xz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.zip
The New Plan
all pkgs needed to bootstrap -> system others -> user
Diffstat (limited to 'system/gzip')
-rw-r--r--system/gzip/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/system/gzip/APKBUILD b/system/gzip/APKBUILD
new file mode 100644
index 000000000..0c61d9b28
--- /dev/null
+++ b/system/gzip/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gzip
+pkgver=1.9
+pkgrel=0
+pkgdesc="A popular data compression program"
+subpackages="$pkgname-doc"
+url="https://www.gnu.org/software/gzip/"
+arch="all"
+license="GPL-2.0"
+depends=
+makedepends=
+checkdepends="perl coreutils diffutils less"
+install=
+source="http://ftp.gnu.org/gnu/gzip/gzip-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+
+ # avoid text relocation
+ export DEFS="NO_ASM"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=$pkgdir install
+
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+
+ mkdir -p "$pkgdir"/bin
+ mv "$pkgdir"/usr/bin/gzip "$pkgdir"/usr/bin/gunzip "$pkgdir"/bin/
+ ln -s /bin/gzip "$pkgdir"/usr/bin/gzip
+ ln -s /bin/gunzip "$pkgdir"/usr/bin/gunzip
+
+ # http://bugs.alpinelinux.org/issues/4011
+ ln -sf /bin/gunzip "$pkgdir"/usr/bin/uncompress
+}
+
+sha512sums="686cb920701e2e19178143a0714edf46da5456bcdc5f5f99c2c186eb195078bc1039e4552f6e0eb4b870cc9beb1042ca3b8922d0b81e378c27bbbc55ba8f4a2f gzip-1.9.tar.gz"