summaryrefslogtreecommitdiff
path: root/system/icu
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-04 07:20:39 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-04 07:20:39 +0000
commit8424452d5a75e53cfaafceeceb0f5f4edc3eb4ff (patch)
tree51133cd87a900fef8267c6dc82711e7952d882ea /system/icu
parent2992f0d1c7675dad0e83f8544bbbba4a4907d20f (diff)
downloadpackages-8424452d5a75e53cfaafceeceb0f5f4edc3eb4ff.tar.gz
packages-8424452d5a75e53cfaafceeceb0f5f4edc3eb4ff.tar.bz2
packages-8424452d5a75e53cfaafceeceb0f5f4edc3eb4ff.tar.xz
packages-8424452d5a75e53cfaafceeceb0f5f4edc3eb4ff.zip
system/icu: fix regression that breaks Mozilla
Diffstat (limited to 'system/icu')
-rw-r--r--system/icu/APKBUILD6
-rw-r--r--system/icu/checkimpl.patch37
2 files changed, 41 insertions, 2 deletions
diff --git a/system/icu/APKBUILD b/system/icu/APKBUILD
index c8db97c53..1c7c7fb34 100644
--- a/system/icu/APKBUILD
+++ b/system/icu/APKBUILD
@@ -6,7 +6,7 @@ pkgver=63.1
# convert x.y.z to x_y_z
_ver=${pkgver//./_}
-pkgrel=0
+pkgrel=1
pkgdesc="International Components for Unicode library"
url="http://www.icu-project.org/"
arch="all"
@@ -17,6 +17,7 @@ checkdepends="diffutils"
makedepends=""
source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz
icu-60.2-always-use-utf8.patch
+ checkimpl.patch
"
# secfixes:
@@ -85,4 +86,5 @@ static() {
}
sha512sums="9ab407ed840a00cdda7470dcc4c40299a125ad246ae4d019c4b1ede54781157fd63af015a8228cd95dbc47e4d15a0932b2c657489046a19788e5e8266eac079c icu4c-63_1-src.tgz
-f86c62422f38f6485c58d4766e629bab69e4b0e00fa910854e40e7db1ace299152eaefa99ae2fbab7465e65d3156cbea7124612defa60680db58ab5c34d6262f icu-60.2-always-use-utf8.patch"
+f86c62422f38f6485c58d4766e629bab69e4b0e00fa910854e40e7db1ace299152eaefa99ae2fbab7465e65d3156cbea7124612defa60680db58ab5c34d6262f icu-60.2-always-use-utf8.patch
+af27a474af041a6ac522901a635c3f328dee5f2b8e42d1229970908c740cd2b97fc06e5432541773d7c80339382f75d795911540f844b6d89ec0ee99d4fa6ff9 checkimpl.patch"
diff --git a/system/icu/checkimpl.patch b/system/icu/checkimpl.patch
new file mode 100644
index 000000000..53cfa724f
--- /dev/null
+++ b/system/icu/checkimpl.patch
@@ -0,0 +1,37 @@
+From 8baff8f03e07d8e02304d0c888d0bb21ad2eeb01 Mon Sep 17 00:00:00 2001
+From: Jeff Genovy <29107334+jefgen@users.noreply.github.com>
+Date: Wed, 17 Oct 2018 19:47:35 -0700
+Subject: [PATCH] ICU-20208 uspoof.cpp function checkImpl should be static,
+ regenerate urename.h
+
+(cherry picked from commit 9ec2c332c1c9156323944ea2b15c2b91952efae4)
+---
+ common/unicode/urename.h | 1 -
+ i18n/uspoof.cpp | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/common/unicode/urename.h b/common/unicode/urename.h
+index 5812173e39c..0512be3b6e5 100644
+--- a/common/unicode/urename.h
++++ b/common/unicode/urename.h
+@@ -110,7 +110,6 @@
+ #define _UTF7Data U_ICU_ENTRY_POINT_RENAME(_UTF7Data)
+ #define _UTF8Data U_ICU_ENTRY_POINT_RENAME(_UTF8Data)
+ #define allowedHourFormatsCleanup U_ICU_ENTRY_POINT_RENAME(allowedHourFormatsCleanup)
+-#define checkImpl U_ICU_ENTRY_POINT_RENAME(checkImpl)
+ #define cmemory_cleanup U_ICU_ENTRY_POINT_RENAME(cmemory_cleanup)
+ #define dayPeriodRulesCleanup U_ICU_ENTRY_POINT_RENAME(dayPeriodRulesCleanup)
+ #define deleteAllowedHourFormats U_ICU_ENTRY_POINT_RENAME(deleteAllowedHourFormats)
+diff --git a/i18n/uspoof.cpp b/i18n/uspoof.cpp
+index 8e3d69ede2b..66f228f037a 100644
+--- a/i18n/uspoof.cpp
++++ b/i18n/uspoof.cpp
+@@ -547,7 +547,7 @@ uspoof_checkUnicodeString(const USpoofChecker *sc,
+ return uspoof_check2UnicodeString(sc, id, NULL, status);
+ }
+
+-int32_t checkImpl(const SpoofImpl* This, const UnicodeString& id, CheckResult* checkResult, UErrorCode* status) {
++static int32_t checkImpl(const SpoofImpl* This, const UnicodeString& id, CheckResult* checkResult, UErrorCode* status) {
+ U_ASSERT(This != NULL);
+ U_ASSERT(checkResult != NULL);
+ checkResult->clear();