summaryrefslogtreecommitdiff
path: root/system/iproute2/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2021-10-16 01:12:16 +0000
committerZach van Rijn <me@zv.io>2021-10-16 01:12:16 +0000
commit6ca2ba5c92a7b0679a552725678a40ed5eb4ded5 (patch)
treeddc300a108dc4d10ed5ed0188175f54452e8bb0e /system/iproute2/APKBUILD
parentaa90e62ce757fa863685f44ce23f129f56b3225f (diff)
parentc0f3f757abe6ea39579119b99e9996c4e2bf0e11 (diff)
downloadpackages-6ca2ba5c92a7b0679a552725678a40ed5eb4ded5.tar.gz
packages-6ca2ba5c92a7b0679a552725678a40ed5eb4ded5.tar.bz2
packages-6ca2ba5c92a7b0679a552725678a40ed5eb4ded5.tar.xz
packages-6ca2ba5c92a7b0679a552725678a40ed5eb4ded5.zip
Merge branch 'master' into 'awilfox/bump/2021-09-system-abipreserve'
# Conflicts: # system/curl/APKBUILD
Diffstat (limited to 'system/iproute2/APKBUILD')
-rw-r--r--system/iproute2/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index ee22a4922..529af2696 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iproute2
-pkgver=5.5.0
+pkgver=5.14.0
pkgrel=0
pkgdesc="Advanced IP routing and network device configuration tools"
url="https://wiki.linuxfoundation.org/networking/iproute2"
@@ -10,7 +10,8 @@ arch="all"
options="!check"
license="GPL-2.0-only"
depends=""
-makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
+makedepends="bison flex bash db-dev libelf-dev libmnl-dev libcap-dev bsd-compat-headers
+ libbpf-dev"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz"
@@ -24,13 +25,7 @@ prepare() {
}
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
+ ./configure
make CCOPTS="-D_GNU_SOURCE $CFLAGS" LIBDIR=/lib
}
@@ -55,4 +50,4 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="a59fb6d620206aa17a4ff7d4510b99322e39b6cf34a00953a7d4cd4d62ca85de16d2e28e33cafa7b026edd4f63c81f3f337954aafe963b964ca0cd2d5c54ac78 iproute2-5.5.0.tar.xz"
+sha512sums="e2b9b0a2c3e6fc4c67cb50b0a9bf710e749648b83369a49bf905edd7e519d76c50c2cc818bb63cc605c409c66075d4d371f2371796e5f7a8f9d04101b80ef75c iproute2-5.14.0.tar.xz"