summaryrefslogtreecommitdiff
path: root/system/json-c
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:53:00 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:53:00 +0000
commit189db0744c81f6d63a4b2832c5a5a16bae446ace (patch)
tree19c42dc33e001720a047d7ca6fb77d43e63a2a50 /system/json-c
parentb33242a202ddb3a58f10998a9d540d8cf3e68391 (diff)
downloadpackages-189db0744c81f6d63a4b2832c5a5a16bae446ace.tar.gz
packages-189db0744c81f6d63a4b2832c5a5a16bae446ace.tar.bz2
packages-189db0744c81f6d63a4b2832c5a5a16bae446ace.tar.xz
packages-189db0744c81f6d63a4b2832c5a5a16bae446ace.zip
system/j*: modernise, fix metadata
Diffstat (limited to 'system/json-c')
-rw-r--r--system/json-c/APKBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/system/json-c/APKBUILD b/system/json-c/APKBUILD
index e5c44cfe8..32ee431dd 100644
--- a/system/json-c/APKBUILD
+++ b/system/json-c/APKBUILD
@@ -7,22 +7,18 @@ url="https://github.com/json-c/json-c/wiki"
arch="all"
license="MIT"
depends=""
-depends_dev=""
-makedepends="$depends_dev autoconf automake libtool"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-static $pkgname-dev"
source="https://s3.amazonaws.com/${pkgname}_releases/releases/$pkgname-${pkgver}.tar.gz
fix-libdir.patch
"
prepare() {
- cd "$builddir"
default_prepare
autoreconf -f -v -i
}
build() {
- cd "$builddir"
export CFLAGS="${CFLAGS} -Wno-error=unused-but-set-variable"
./configure --prefix=/usr \
--build=$CBUILD \
@@ -39,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}