summaryrefslogtreecommitdiff
path: root/system/libaio/APKBUILD
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2019-03-07 00:23:26 +0000
committerLaurent Bercot <ska-adelie@skarnet.org>2019-03-07 00:23:26 +0000
commit5dba7907e14196aa368b0d84d3a2df7a0fd55123 (patch)
tree56fdada6ebda794f877de30628ac949a0f3a46f6 /system/libaio/APKBUILD
parent506539dec83c52b7e24bbd3f98cb8bea68b2d886 (diff)
parent89573ea3c2e8ec27ad4433a00fa238f7be475c54 (diff)
downloadpackages-5dba7907e14196aa368b0d84d3a2df7a0fd55123.tar.gz
packages-5dba7907e14196aa368b0d84d3a2df7a0fd55123.tar.bz2
packages-5dba7907e14196aa368b0d84d3a2df7a0fd55123.tar.xz
packages-5dba7907e14196aa368b0d84d3a2df7a0fd55123.zip
Merge branch 'master' of code.foxkit.us:adelie/packages
Diffstat (limited to 'system/libaio/APKBUILD')
-rw-r--r--system/libaio/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
index b40b031aa..7423a10d7 100644
--- a/system/libaio/APKBUILD
+++ b/system/libaio/APKBUILD
@@ -2,20 +2,21 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname="libaio"
pkgver=0.3.111
-pkgrel=0
+pkgrel=1
pkgdesc="Asynchronous input/output library"
url="http://lse.sourceforge.net/io/aio.html"
arch="all"
license="LGPL-2.1+"
-depends=
+depends=""
makedepends="linux-headers"
-install=
subpackages="$pkgname-dev"
-source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz"
+source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
+ improper-strncpy-usage.patch
+ "
build() {
cd "$builddir"
- make
+ make LDFLAGS="$LDFLAGS -lssp_nonshared"
}
check() {
@@ -29,4 +30,5 @@ package() {
make prefix="$pkgdir/usr" install
}
-sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz"
+sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz
+8294a17b60676838375b3f17b84af19f3f3224788bdc944eda6b235305f48b6b292899f9d528be7b4b87305e7beac409afc0f250d052454b2a739bd990104b83 improper-strncpy-usage.patch"