summaryrefslogtreecommitdiff
path: root/system/libaio
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-06-22 04:27:41 +0000
committerDan Theisen <djt@hxx.in>2018-06-22 04:27:41 +0000
commit67f2c5e24c27f083667e2934624d939fb3708d40 (patch)
tree909395f656b8de5b015883f89fdffe1422cf8751 /system/libaio
parent34791c5a069dc1f67ebcdc5b22deac41b154f27d (diff)
downloadpackages-67f2c5e24c27f083667e2934624d939fb3708d40.tar.gz
packages-67f2c5e24c27f083667e2934624d939fb3708d40.tar.bz2
packages-67f2c5e24c27f083667e2934624d939fb3708d40.tar.xz
packages-67f2c5e24c27f083667e2934624d939fb3708d40.zip
system/libaio: import from alpine and fix up
Diffstat (limited to 'system/libaio')
-rw-r--r--system/libaio/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
new file mode 100644
index 000000000..b40b031aa
--- /dev/null
+++ b/system/libaio/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname="libaio"
+pkgver=0.3.111
+pkgrel=0
+pkgdesc="Asynchronous input/output library"
+url="http://lse.sourceforge.net/io/aio.html"
+arch="all"
+license="LGPL-2.1+"
+depends=
+makedepends="linux-headers"
+install=
+subpackages="$pkgname-dev"
+source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ # the full testsuite requires root and attempts to do a loop mount
+ make partcheck
+}
+
+package() {
+ cd "$builddir"
+ make prefix="$pkgdir/usr" install
+}
+
+sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz"