summaryrefslogtreecommitdiff
path: root/system/libaio
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 02:02:47 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 02:02:47 +0000
commite6bb4578b0a5c0f01f69414f9313dd574c6a3701 (patch)
tree62f417fe13ff1ef04934c04574ffdf613af18688 /system/libaio
parentfe9ea7bfa4a2128123047aedb3fe753fc586e17d (diff)
downloadpackages-e6bb4578b0a5c0f01f69414f9313dd574c6a3701.tar.gz
packages-e6bb4578b0a5c0f01f69414f9313dd574c6a3701.tar.bz2
packages-e6bb4578b0a5c0f01f69414f9313dd574c6a3701.tar.xz
packages-e6bb4578b0a5c0f01f69414f9313dd574c6a3701.zip
system/libaio: bump to 0.3.112, modernise
Diffstat (limited to 'system/libaio')
-rw-r--r--system/libaio/APKBUILD15
-rw-r--r--system/libaio/posix-header.patch11
2 files changed, 18 insertions, 8 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
index 7423a10d7..f46e8b582 100644
--- a/system/libaio/APKBUILD
+++ b/system/libaio/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname="libaio"
-pkgver=0.3.111
-pkgrel=1
+pkgver=0.3.112
+pkgrel=0
pkgdesc="Asynchronous input/output library"
url="http://lse.sourceforge.net/io/aio.html"
arch="all"
@@ -10,25 +10,24 @@ license="LGPL-2.1+"
depends=""
makedepends="linux-headers"
subpackages="$pkgname-dev"
-source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
+source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.xz
improper-strncpy-usage.patch
+ posix-header.patch
"
build() {
- cd "$builddir"
make LDFLAGS="$LDFLAGS -lssp_nonshared"
}
check() {
- cd "$builddir"
# the full testsuite requires root and attempts to do a loop mount
make partcheck
}
package() {
- cd "$builddir"
make prefix="$pkgdir/usr" install
}
-sha512sums="440f2b62f99ca2e72ffc8c2c04b4779a1a7cf24a8ba2a30b34d18b4ee77630a2078610fe8c435559f81a5c3bfa93049bd53d77464a0da8267833fbde3f40ceeb libaio_0.3.111.orig.tar.gz
-8294a17b60676838375b3f17b84af19f3f3224788bdc944eda6b235305f48b6b292899f9d528be7b4b87305e7beac409afc0f250d052454b2a739bd990104b83 improper-strncpy-usage.patch"
+sha512sums="612f0adeea4926ced914b43ec550bf821bef348e6c787f9e3c1a545e5667121692a9af7ebaab14744aca7132a071083a1120bd01e31726932f3ceb9be51891a7 libaio_0.3.112.orig.tar.xz
+8294a17b60676838375b3f17b84af19f3f3224788bdc944eda6b235305f48b6b292899f9d528be7b4b87305e7beac409afc0f250d052454b2a739bd990104b83 improper-strncpy-usage.patch
+4cc9ad9f1020bc6397c3847cc511bed93fe4c5391ef00094b6704c8ba3f9e295e35e60536ecb3e306713caac9fdb81ecc3d083d8e96cc20db39a105d16b7ab84 posix-header.patch"
diff --git a/system/libaio/posix-header.patch b/system/libaio/posix-header.patch
new file mode 100644
index 000000000..6a11c0e34
--- /dev/null
+++ b/system/libaio/posix-header.patch
@@ -0,0 +1,11 @@
+--- libaio-0.3.112/harness/cases/22.t.old 2018-10-22 18:55:23.000000000 +0000
++++ libaio-0.3.112/harness/cases/22.t 2019-03-08 01:52:02.840000000 +0000
+@@ -11,7 +11,7 @@
+ #include <signal.h>
+ #include <stdio.h>
+ #include <unistd.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/wait.h>
+ #include <stdlib.h>
+