summaryrefslogtreecommitdiff
path: root/system/libaio
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-20 19:06:11 +0000
committerZach van Rijn <me@zv.io>2022-05-20 19:22:26 +0000
commite424ab3bfe9fda0188d75567eacf94bf208759ce (patch)
tree579e2b84f1838314a4318b2f04a0381970b3bb7d /system/libaio
parent45e08a3f02ee5867ed562a9823166b50be7f10c3 (diff)
downloadpackages-e424ab3bfe9fda0188d75567eacf94bf208759ce.tar.gz
packages-e424ab3bfe9fda0188d75567eacf94bf208759ce.tar.bz2
packages-e424ab3bfe9fda0188d75567eacf94bf208759ce.tar.xz
packages-e424ab3bfe9fda0188d75567eacf94bf208759ce.zip
system/libaio: disable test 23. see #674.
Diffstat (limited to 'system/libaio')
-rw-r--r--system/libaio/APKBUILD7
-rw-r--r--system/libaio/disable-test-18.patch11
2 files changed, 4 insertions, 14 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
index 9f575a710..1cdb24e37 100644
--- a/system/libaio/APKBUILD
+++ b/system/libaio/APKBUILD
@@ -12,7 +12,6 @@ makedepends="linux-headers"
subpackages="$pkgname-dev"
source="https://releases.pagure.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
posix-header.patch
- disable-test-18.patch
"
build() {
@@ -20,6 +19,9 @@ build() {
}
check() {
+ rm harness/cases/18.t #405
+ rm harness/cases/23.t #674
+
# the full testsuite requires root and attempts to do a loop mount
make partcheck
}
@@ -29,5 +31,4 @@ package() {
}
sha512sums="65c30a102433bf8386581b03fc706d84bd341be249fbdee11a032b237a7b239e8c27413504fef15e2797b1acd67f752526637005889590ecb380e2e120ab0b71 libaio-0.3.113.tar.gz
-4cc9ad9f1020bc6397c3847cc511bed93fe4c5391ef00094b6704c8ba3f9e295e35e60536ecb3e306713caac9fdb81ecc3d083d8e96cc20db39a105d16b7ab84 posix-header.patch
-1324ffbbac8132b447237d8207c45c23bb6cde42f754bcbf8e726aa4c11d617ab41a35811972a5f755d9abafc2725cdd86ffd652c28a6472f798cb02be1743c3 disable-test-18.patch"
+4cc9ad9f1020bc6397c3847cc511bed93fe4c5391ef00094b6704c8ba3f9e295e35e60536ecb3e306713caac9fdb81ecc3d083d8e96cc20db39a105d16b7ab84 posix-header.patch"
diff --git a/system/libaio/disable-test-18.patch b/system/libaio/disable-test-18.patch
deleted file mode 100644
index 9b6e4aa40..000000000
--- a/system/libaio/disable-test-18.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur a/harness/Makefile b/harness/Makefile
---- a/harness/Makefile 2022-05-03 19:46:21.460000000 +0000
-+++ b/harness/Makefile 2022-05-03 19:46:57.450000000 +0000
-@@ -1,6 +1,6 @@
- # foo.
- TEST_SRCS:=$(shell find cases/ -name \*.t | sort -n -t/ -k2)
--EXTRAPROGS:=cases/8.p cases/10.p
-+EXTRAPROGS:=cases/8.p cases/10.p cases/18.p
- PARTPROGS:=$(filter-out $(EXTRAPROGS), $(patsubst %.t,%.p,$(TEST_SRCS)))
- PROGS:=$(PARTPROGS) $(EXTRAPROGS)
- HARNESS_SRCS:=main.c