summaryrefslogtreecommitdiff
path: root/system/libaio
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-03 19:51:23 +0000
committerZach van Rijn <me@zv.io>2022-05-06 12:37:30 -0500
commit87dbb4be56a3cbbcc652dbdf383f14a7a46d7e2c (patch)
treebe4cd4f67662c5890e45e70bdb1f8d39f7035ac0 /system/libaio
parentff04154b2cdc63d7cb057b4d80f894a3e9b37b91 (diff)
downloadpackages-87dbb4be56a3cbbcc652dbdf383f14a7a46d7e2c.tar.gz
packages-87dbb4be56a3cbbcc652dbdf383f14a7a46d7e2c.tar.bz2
packages-87dbb4be56a3cbbcc652dbdf383f14a7a46d7e2c.tar.xz
packages-87dbb4be56a3cbbcc652dbdf383f14a7a46d7e2c.zip
system/libaio: bump { 0.3.112 --> 0.3.113 }. disable test 18. fixes #405.
Diffstat (limited to 'system/libaio')
-rw-r--r--system/libaio/APKBUILD13
-rw-r--r--system/libaio/disable-test-18.patch11
-rw-r--r--system/libaio/improper-strncpy-usage.patch26
3 files changed, 18 insertions, 32 deletions
diff --git a/system/libaio/APKBUILD b/system/libaio/APKBUILD
index f46e8b582..efc8e8311 100644
--- a/system/libaio/APKBUILD
+++ b/system/libaio/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname="libaio"
-pkgver=0.3.112
+pkgver=0.3.113
pkgrel=0
pkgdesc="Asynchronous input/output library"
url="http://lse.sourceforge.net/io/aio.html"
@@ -10,10 +10,11 @@ license="LGPL-2.1+"
depends=""
makedepends="linux-headers"
subpackages="$pkgname-dev"
-source="http://ftp.debian.org/debian/pool/main/liba/$pkgname/${pkgname}_${pkgver}.orig.tar.xz
- improper-strncpy-usage.patch
+source="https://releases.pagure.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
posix-header.patch
+ disable-test-18.patch
"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
make LDFLAGS="$LDFLAGS -lssp_nonshared"
@@ -28,6 +29,6 @@ package() {
make prefix="$pkgdir/usr" install
}
-sha512sums="612f0adeea4926ced914b43ec550bf821bef348e6c787f9e3c1a545e5667121692a9af7ebaab14744aca7132a071083a1120bd01e31726932f3ceb9be51891a7 libaio_0.3.112.orig.tar.xz
-8294a17b60676838375b3f17b84af19f3f3224788bdc944eda6b235305f48b6b292899f9d528be7b4b87305e7beac409afc0f250d052454b2a739bd990104b83 improper-strncpy-usage.patch
-4cc9ad9f1020bc6397c3847cc511bed93fe4c5391ef00094b6704c8ba3f9e295e35e60536ecb3e306713caac9fdb81ecc3d083d8e96cc20db39a105d16b7ab84 posix-header.patch"
+sha512sums="8058c927de0b5f7079fc232d2be23272537694bf271488af1dc0330b58afc307931792ab138512c5e00aa3ea921935a6d862f575fb0cc2bf323de63d8df208cd libaio-0.3.113.tar.gz
+4cc9ad9f1020bc6397c3847cc511bed93fe4c5391ef00094b6704c8ba3f9e295e35e60536ecb3e306713caac9fdb81ecc3d083d8e96cc20db39a105d16b7ab84 posix-header.patch
+1324ffbbac8132b447237d8207c45c23bb6cde42f754bcbf8e726aa4c11d617ab41a35811972a5f755d9abafc2725cdd86ffd652c28a6472f798cb02be1743c3 disable-test-18.patch"
diff --git a/system/libaio/disable-test-18.patch b/system/libaio/disable-test-18.patch
new file mode 100644
index 000000000..9b6e4aa40
--- /dev/null
+++ b/system/libaio/disable-test-18.patch
@@ -0,0 +1,11 @@
+diff -ur a/harness/Makefile b/harness/Makefile
+--- a/harness/Makefile 2022-05-03 19:46:21.460000000 +0000
++++ b/harness/Makefile 2022-05-03 19:46:57.450000000 +0000
+@@ -1,6 +1,6 @@
+ # foo.
+ TEST_SRCS:=$(shell find cases/ -name \*.t | sort -n -t/ -k2)
+-EXTRAPROGS:=cases/8.p cases/10.p
++EXTRAPROGS:=cases/8.p cases/10.p cases/18.p
+ PARTPROGS:=$(filter-out $(EXTRAPROGS), $(patsubst %.t,%.p,$(TEST_SRCS)))
+ PROGS:=$(PARTPROGS) $(EXTRAPROGS)
+ HARNESS_SRCS:=main.c
diff --git a/system/libaio/improper-strncpy-usage.patch b/system/libaio/improper-strncpy-usage.patch
deleted file mode 100644
index b2f6b86a4..000000000
--- a/system/libaio/improper-strncpy-usage.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-It is invalid to use the src size as the strncpy size parameter.
-
-Found by GCC 8.3, fixed by awilfox.
-
---- libaio-0.3.111/harness/cases/19.t.old 2018-03-06 22:24:47.000000000 +0000
-+++ libaio-0.3.111/harness/cases/19.t 2019-02-28 22:20:03.170000000 +0000
-@@ -41,7 +41,7 @@
- int fd;
- char template[sizeof(TEMPLATE)];
-
-- strncpy(template, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(template, TEMPLATE, sizeof(template));
- fd = mkostemp(template, O_DIRECT);
- if (fd < 0) {
- perror("mkstemp");
---- libaio-0.3.111/harness/cases/21.t.old 2018-03-06 22:24:47.000000000 +0000
-+++ libaio-0.3.111/harness/cases/21.t 2019-02-28 22:20:13.120000000 +0000
-@@ -43,7 +43,7 @@
- int fd;
- char temp_file[sizeof(TEMPLATE)];
-
-- strncpy(temp_file, TEMPLATE, sizeof(TEMPLATE));
-+ strncpy(temp_file, TEMPLATE, sizeof(temp_file));
- fd = mkstemp(temp_file);
- if (fd < 0) {
- perror("mkstemp");