summaryrefslogtreecommitdiff
path: root/system/libarchive
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-04-11 22:21:41 +0000
committerZach van Rijn <me@zv.io>2023-04-11 22:21:43 +0000
commitc573ccb81980bbc8ce64e09c1eec0e08e49ccad0 (patch)
tree1dbae33607bd7a6e40af014d52903d5efd39c5d6 /system/libarchive
parentcf16eaed1fcb76a40d40469347385828f2a6bd62 (diff)
downloadpackages-c573ccb81980bbc8ce64e09c1eec0e08e49ccad0.tar.gz
packages-c573ccb81980bbc8ce64e09c1eec0e08e49ccad0.tar.bz2
packages-c573ccb81980bbc8ce64e09c1eec0e08e49ccad0.tar.xz
packages-c573ccb81980bbc8ce64e09c1eec0e08e49ccad0.zip
system/libarchive: revert autotools iconv nonsense. fixes #999.
This commit: https://github.com/libarchive/libarchive\ /pull/1723/commits/a83f3d327aefe8d628230f326621b014d82f55b4 is bullshit. BEGONE!
Diffstat (limited to 'system/libarchive')
-rw-r--r--system/libarchive/APKBUILD13
-rw-r--r--system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch49
2 files changed, 59 insertions, 3 deletions
diff --git a/system/libarchive/APKBUILD b/system/libarchive/APKBUILD
index 5c37f8a8d..18fae33b9 100644
--- a/system/libarchive/APKBUILD
+++ b/system/libarchive/APKBUILD
@@ -2,18 +2,19 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libarchive
pkgver=3.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="Multi-format archive and compression library"
url="https://www.libarchive.org/"
arch="all"
license="BSD-2-Clause AND BSD-3-Clause AND Public-Domain"
depends=""
makedepends="zlib-dev bzip2-dev xz-dev lz4-dev acl-dev openssl-dev expat-dev
- attr-dev zstd-dev"
+ attr-dev zstd-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://github.com/libarchive/libarchive/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
disable-locale-tests.patch
disable-unaligned-access-arm32-xxhash.patch
+ revert-autotools-Fix-static-linking-when-openssl-is-.patch
"
# secfixes:
@@ -26,6 +27,11 @@ source="https://github.com/libarchive/libarchive/releases/download/v$pkgver/$pkg
# 3.3.2-r1:
# - CVE-2017-14166
+prepare() {
+ default_prepare
+ autoreconf -i
+}
+
build () {
./configure \
--build=$CBUILD \
@@ -62,4 +68,5 @@ tools() {
sha512sums="24e476465054a29a2d48adf3c197a171b5361fa5038729a1f14d578c6701424de4e5dd6a2b20a6b697969ab43bdd8afc1585f8de0465c266f455d7eaa19e5048 libarchive-3.6.2.tar.gz
27cf2aaa3e70e3a2a9944fac0c96c411e669c7e1a48daad1423bff68eef0f49153e5ef9d22dc9591a65353119d7fe203a28258ab82278aeb86b46fe691bcfb6a disable-locale-tests.patch
-56a2b13b6cd7b127c04ac50ebf49994ec91ff2467d5d0f32b8428bd4df82b167459d4630dee5d1b5119f70b04ea6fe4411d44b768e0f313fa302c9e5fe51b7cd disable-unaligned-access-arm32-xxhash.patch"
+56a2b13b6cd7b127c04ac50ebf49994ec91ff2467d5d0f32b8428bd4df82b167459d4630dee5d1b5119f70b04ea6fe4411d44b768e0f313fa302c9e5fe51b7cd disable-unaligned-access-arm32-xxhash.patch
+1b69d47d900d658622de7a621056f8abeacaf6ad4871a2d326fc925d76f7fe8ae15b16d16979fb8c62e429e231e13a97a89e8d064b3ed2b53b1399722207e1ab revert-autotools-Fix-static-linking-when-openssl-is-.patch"
diff --git a/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch b/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch
new file mode 100644
index 000000000..24acd4080
--- /dev/null
+++ b/system/libarchive/revert-autotools-Fix-static-linking-when-openssl-is-.patch
@@ -0,0 +1,49 @@
+From 57b52cb8b54ec57d72ed0ccacacc1f6506749d17 Mon Sep 17 00:00:00 2001
+From: Zach van Rijn <me@zv.io>
+Date: Tue, 11 Apr 2023 17:14:18 -0500
+Subject: [PATCH] Revert "autotools: Fix static linking when openssl is enabled
+ in windows"
+
+This reverts commit a83f3d327aefe8d628230f326621b014d82f55b4.
+
+diff --git a/build/pkgconfig/libarchive.pc.in b/build/pkgconfig/libarchive.pc.in
+index 1f51e77f..4b631e63 100644
+--- a/build/pkgconfig/libarchive.pc.in
++++ b/build/pkgconfig/libarchive.pc.in
+@@ -10,4 +10,3 @@ Cflags: -I${includedir}
+ Cflags.private: -DLIBARCHIVE_STATIC
+ Libs: -L${libdir} -larchive
+ Libs.private: @LIBS@
+-Requires.private: @LIBSREQUIRED@
+diff --git a/configure.ac b/configure.ac
+index 349e7580..d60f66fb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -378,7 +378,6 @@ if test "x$with_iconv" != "xno"; then
+ AC_CHECK_HEADERS([localcharset.h])
+ am_save_LIBS="$LIBS"
+ LIBS="${LIBS} ${LIBICONV}"
+- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
+ AC_CHECK_FUNCS([locale_charset])
+ LIBS="${am_save_LIBS}"
+ if test "x$ac_cv_func_locale_charset" != "xyes"; then
+@@ -1210,7 +1209,6 @@ fi
+ if test "x$with_openssl" != "xno"; then
+ AC_CHECK_HEADERS([openssl/evp.h])
+ saved_LIBS=$LIBS
+- LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }libssl libcrypto"
+ AC_CHECK_LIB(crypto,OPENSSL_config)
+ CRYPTO_CHECK(MD5, OPENSSL, md5)
+ CRYPTO_CHECK(RMD160, OPENSSL, rmd160)
+@@ -1221,8 +1219,6 @@ if test "x$with_openssl" != "xno"; then
+ AC_CHECK_FUNCS([PKCS5_PBKDF2_HMAC_SHA1])
+ fi
+
+-AC_SUBST(LIBSREQUIRED)
+-
+ # Probe libmd AFTER OpenSSL/libcrypto.
+ # The two are incompatible and OpenSSL is more complete.
+ AC_CHECK_HEADERS([md5.h ripemd.h sha.h sha256.h sha512.h])
+--
+2.25.1
+