summaryrefslogtreecommitdiff
path: root/system/libtool
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-27 23:19:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-28 00:00:15 -0500
commitf3c441776255630552df763cdad0258f63fff94e (patch)
tree615f3aa17f0bf983ad25aecee8efa6dc9549b8e2 /system/libtool
parent900e6d2f97f78476c79145e63852eb369e394c22 (diff)
downloadpackages-f3c441776255630552df763cdad0258f63fff94e.tar.gz
packages-f3c441776255630552df763cdad0258f63fff94e.tar.bz2
packages-f3c441776255630552df763cdad0258f63fff94e.tar.xz
packages-f3c441776255630552df763cdad0258f63fff94e.zip
system/libtool: Move to legacy/
Replaced by system/slibtool. Tracking bug: #595
Diffstat (limited to 'system/libtool')
-rw-r--r--system/libtool/APKBUILD46
-rw-r--r--system/libtool/libtool-fix-cross-compile.patch36
2 files changed, 0 insertions, 82 deletions
diff --git a/system/libtool/APKBUILD b/system/libtool/APKBUILD
deleted file mode 100644
index 23de9cb0e..000000000
--- a/system/libtool/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer:
-pkgname=libtool
-pkgver=2.4.6
-pkgrel=6
-pkgdesc="A generic library support script"
-arch="all"
-license="GPL-2.0+"
-url="http://www.gnu.org/software/libtool"
-depends="bash libltdl"
-makedepends="m4 help2man"
-checkdepends="autoconf automake gzip"
-subpackages="libltdl $pkgname-doc"
-options="libtool"
-source="https://ftp.gnu.org/gnu/$pkgname/${pkgname}-${pkgver}.tar.gz
- libtool-fix-cross-compile.patch"
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
- lt_cv_shlibpath_overrides_runpath=yes
- make
-}
-
-check() {
- # Test 70 and 117 are known to fail
- # Test 170 repeats the entire test suite with shorter max_cmd_len
- make check TESTSUITEFLAGS="1-69 71-116 118-169"
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-libltdl() {
- pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
- license="LGPL-2.1+"
- depends=
- mkdir -p "$subpkgdir/usr/lib"
- mv "$pkgdir/usr/lib/libltdl.so"* "$subpkgdir/usr/lib/"
-}
-
-sha512sums="3233d81cb2739a54b840a0a82064eebbfaa4fb442fb993a35d6bd41d8395c51f038c90ae048b9252f172d0a5bbfb4b36e2b13d4477001f9ff7d4124237819a18 libtool-2.4.6.tar.gz
-aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
diff --git a/system/libtool/libtool-fix-cross-compile.patch b/system/libtool/libtool-fix-cross-compile.patch
deleted file mode 100644
index 585897e0d..000000000
--- a/system/libtool/libtool-fix-cross-compile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- libtool-2.4.6.orig/build-aux/ltmain.in
-+++ libtool-2.4.6/build-aux/ltmain.in
-@@ -6449,7 +6449,7 @@
- fi
- else
- # We cannot seem to hardcode it, guess we'll fake it.
-- add_dir=-L$libdir
-+ add_dir="-L$lt_sysroot$libdir"
- # Try looking first in the location we're being installed to.
- if test -n "$inst_prefix_dir"; then
- case $libdir in
-@@ -7628,9 +7628,11 @@
- test relink = "$opt_mode" || rpath=$compile_rpath$rpath
- for libdir in $rpath; do
- if test -n "$hardcode_libdir_flag_spec"; then
-+ func_replace_sysroot "$libdir"
-+ libdir=$func_replace_sysroot_result
-+ func_stripname '=' '' "$libdir"
-+ libdir=$func_stripname_result
- if test -n "$hardcode_libdir_separator"; then
-- func_replace_sysroot "$libdir"
-- libdir=$func_replace_sysroot_result
- if test -z "$hardcode_libdirs"; then
- hardcode_libdirs=$libdir
- else
-@@ -8360,6 +8362,10 @@
- hardcode_libdirs=
- for libdir in $compile_rpath $finalize_rpath; do
- if test -n "$hardcode_libdir_flag_spec"; then
-+ func_replace_sysroot "$libdir"
-+ libdir=$func_replace_sysroot_result
-+ func_stripname '=' '' "$libdir"
-+ libdir=$func_stripname_result
- if test -n "$hardcode_libdir_separator"; then
- if test -z "$hardcode_libdirs"; then
- hardcode_libdirs=$libdir