summaryrefslogtreecommitdiff
path: root/system/libtool
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
commit9a841fe2af5204c11e54bdb00a8f46088b30de7d (patch)
treec036b83ca4ac76a15eaa4c833523abddbcd290d4 /system/libtool
parent7833fcbe0f814b7ca0ea9bf5da6d0381de9c7d10 (diff)
downloadpackages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.gz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.bz2
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.xz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.zip
system/l*: modernise, fix metadata, etc
Diffstat (limited to 'system/libtool')
-rw-r--r--system/libtool/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/system/libtool/APKBUILD b/system/libtool/APKBUILD
index c4a3348f9..23de9cb0e 100644
--- a/system/libtool/APKBUILD
+++ b/system/libtool/APKBUILD
@@ -15,7 +15,6 @@ source="https://ftp.gnu.org/gnu/$pkgname/${pkgname}-${pkgver}.tar.gz
libtool-fix-cross-compile.patch"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,18 +24,16 @@ build() {
make
}
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
check() {
- cd "$builddir"
# Test 70 and 117 are known to fail
# Test 170 repeats the entire test suite with shorter max_cmd_len
make check TESTSUITEFLAGS="1-69 71-116 118-169"
}
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
libltdl() {
pkgdesc="Runtime libraries for GNU Libtool Dynamic Module Loader"
license="LGPL-2.1+"