summaryrefslogtreecommitdiff
path: root/system/libucontext
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
commit9a841fe2af5204c11e54bdb00a8f46088b30de7d (patch)
treec036b83ca4ac76a15eaa4c833523abddbcd290d4 /system/libucontext
parent7833fcbe0f814b7ca0ea9bf5da6d0381de9c7d10 (diff)
downloadpackages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.gz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.bz2
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.xz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.zip
system/l*: modernise, fix metadata, etc
Diffstat (limited to 'system/libucontext')
-rw-r--r--system/libucontext/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 534e6b137..93bc2b252 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -2,11 +2,12 @@
pkgname=libucontext
pkgver=0.9.0
pkgrel=0
-pkgdesc="ucontext function implementations"
+pkgdesc="Implementation of software-defined threading"
url="https://code.foxkit.us/adelie/libucontext/"
arch="all"
license="ISC"
depends=""
+makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
@@ -18,17 +19,14 @@ pmmx) LIBUCONTEXT_ARCH="x86" ;;
esac
build() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH"
}
check() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" check
}
package() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}