summaryrefslogtreecommitdiff
path: root/system/linenoise/build-shared-lib.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-01 03:21:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-01 03:21:13 +0000
commitd82043346979aa9e68e269b2ab52dfc039e3b3bb (patch)
tree1487ae2a1a2b4c7b857fc5dab989e4114b644a2d /system/linenoise/build-shared-lib.patch
parentd91b4d0f4400289df54d611bd6a5cf95afb18412 (diff)
downloadpackages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.gz
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.bz2
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.xz
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.zip
system/linenoise: allow stricter SONAME preference of GCC 8
Diffstat (limited to 'system/linenoise/build-shared-lib.patch')
-rw-r--r--system/linenoise/build-shared-lib.patch5
1 files changed, 3 insertions, 2 deletions
diff --git a/system/linenoise/build-shared-lib.patch b/system/linenoise/build-shared-lib.patch
index 2f9542dcf..b94d6ab4c 100644
--- a/system/linenoise/build-shared-lib.patch
+++ b/system/linenoise/build-shared-lib.patch
@@ -1,6 +1,6 @@
--- ./Makefile.orig
+++ ./Makefile
-@@ -1,7 +1,33 @@
+@@ -1,7 +1,34 @@
+MAJOR_VERSION = 0
+EXTRA_VERSION = .0.0
+SONAME = liblinenoise.so.$(MAJOR_VERSION)
@@ -34,4 +34,5 @@
+ install -m 0755 -d $(DESTDIR)$(LIBDIR)
+ install -m 0755 $(LIB) $(DESTDIR)$(LIBDIR)
+ ldconfig -n $(DESTDIR)$(LIBDIR)
-+ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/liblinenoise.so
++ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/$(SONAME)
++ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/liblinenoise.so