summaryrefslogtreecommitdiff
path: root/system/linenoise
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-01 03:21:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-01 03:21:13 +0000
commitd82043346979aa9e68e269b2ab52dfc039e3b3bb (patch)
tree1487ae2a1a2b4c7b857fc5dab989e4114b644a2d /system/linenoise
parentd91b4d0f4400289df54d611bd6a5cf95afb18412 (diff)
downloadpackages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.gz
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.bz2
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.tar.xz
packages-d82043346979aa9e68e269b2ab52dfc039e3b3bb.zip
system/linenoise: allow stricter SONAME preference of GCC 8
Diffstat (limited to 'system/linenoise')
-rw-r--r--system/linenoise/APKBUILD8
-rw-r--r--system/linenoise/build-shared-lib.patch5
2 files changed, 6 insertions, 7 deletions
diff --git a/system/linenoise/APKBUILD b/system/linenoise/APKBUILD
index 48012cda9..5e95f3927 100644
--- a/system/linenoise/APKBUILD
+++ b/system/linenoise/APKBUILD
@@ -2,16 +2,14 @@
# Maintainer:
pkgname=linenoise
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Minimal replacement for readline"
url="https://github.com/antirez/linenoise"
arch="all"
options="!check" # No test suite.
license="BSD-2-Clause-NetBSD"
depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
+makedepends=""
subpackages="$pkgname-dev"
source="linenoise-$pkgver.tar.gz::https://github.com/antirez/linenoise/archive/$pkgver.tar.gz
build-shared-lib.patch
@@ -28,4 +26,4 @@ package() {
}
sha512sums="9e68fade8d64d7ba8d5d681e74d0ca6c4ebd9576249bb0e885b1aa708a9af77a43ea6264307ae46fb74e52219387a2c831b570f9601e331837f35294af9883e3 linenoise-1.0.tar.gz
-e37fe58f414f48a6a6fcab9925881131d2dbca0c54fe2b17a359d0b5c58ce1e29dad92baa8dc7f7d390af1edace2a75091f20bed5aa381ff2599e734616b2418 build-shared-lib.patch"
+4f38ffc191c69e6a60fd064929ad0d442700a2928cd2de04e52c12e3ce67c8f1d49e993782d764fe8c59165eed20fb7725ea9147942a7e0e26ff1a8ebb145e9a build-shared-lib.patch"
diff --git a/system/linenoise/build-shared-lib.patch b/system/linenoise/build-shared-lib.patch
index 2f9542dcf..b94d6ab4c 100644
--- a/system/linenoise/build-shared-lib.patch
+++ b/system/linenoise/build-shared-lib.patch
@@ -1,6 +1,6 @@
--- ./Makefile.orig
+++ ./Makefile
-@@ -1,7 +1,33 @@
+@@ -1,7 +1,34 @@
+MAJOR_VERSION = 0
+EXTRA_VERSION = .0.0
+SONAME = liblinenoise.so.$(MAJOR_VERSION)
@@ -34,4 +34,5 @@
+ install -m 0755 -d $(DESTDIR)$(LIBDIR)
+ install -m 0755 $(LIB) $(DESTDIR)$(LIBDIR)
+ ldconfig -n $(DESTDIR)$(LIBDIR)
-+ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/liblinenoise.so
++ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/$(SONAME)
++ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/liblinenoise.so