summaryrefslogtreecommitdiff
path: root/system/linenoise
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 20:04:21 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 20:04:21 -0500
commit146dbadd4867c64bf5594cd51ee31057dc05b023 (patch)
tree856013e082edb16eb65321d2252eba1733b50712 /system/linenoise
parent7e8a986670ad147bcdb735cf2184357a5e5900b9 (diff)
downloadpackages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.gz
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.bz2
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.xz
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.zip
system: pull in lua bull crap for kyua
Diffstat (limited to 'system/linenoise')
-rw-r--r--system/linenoise/APKBUILD31
-rw-r--r--system/linenoise/build-shared-lib.patch37
2 files changed, 68 insertions, 0 deletions
diff --git a/system/linenoise/APKBUILD b/system/linenoise/APKBUILD
new file mode 100644
index 000000000..92443594f
--- /dev/null
+++ b/system/linenoise/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=linenoise
+pkgver=1.0
+pkgrel=1
+pkgdesc="Minimal replacement for readline"
+url="https://github.com/antirez/linenoise"
+arch="all"
+options="!check" # No test suite.
+license="BSD-2-Clause-NetBSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="linenoise-$pkgver.tar.gz::https://github.com/antirez/linenoise/archive/$pkgver.tar.gz
+ build-shared-lib.patch
+ "
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9e68fade8d64d7ba8d5d681e74d0ca6c4ebd9576249bb0e885b1aa708a9af77a43ea6264307ae46fb74e52219387a2c831b570f9601e331837f35294af9883e3 linenoise-1.0.tar.gz
+e37fe58f414f48a6a6fcab9925881131d2dbca0c54fe2b17a359d0b5c58ce1e29dad92baa8dc7f7d390af1edace2a75091f20bed5aa381ff2599e734616b2418 build-shared-lib.patch"
diff --git a/system/linenoise/build-shared-lib.patch b/system/linenoise/build-shared-lib.patch
new file mode 100644
index 000000000..2f9542dcf
--- /dev/null
+++ b/system/linenoise/build-shared-lib.patch
@@ -0,0 +1,37 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1,7 +1,33 @@
++MAJOR_VERSION = 0
++EXTRA_VERSION = .0.0
++SONAME = liblinenoise.so.$(MAJOR_VERSION)
++LIB = $(SONAME)$(EXTRA_VERSION)
++
++export CFLAGS ?= -Os -g
++CFLAGS += -Wall -fpic -DUSE_UTF8
++LIBDIR ?= /usr/lib
++INCLUDEDIR ?= /usr/include
++
++.PHONY: all
++all: $(LIB) linenoise_example
++
++$(LIB): linenoise.o
++ $(CC) $(CFLAGS) -shared -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $^
++
+ linenoise_example: linenoise.h linenoise.c
+
+ linenoise_example: linenoise.c example.c
+ $(CC) -Wall -W -Os -g -o linenoise_example linenoise.c example.c
+
++.PHONY: clean
+ clean:
+- rm -f linenoise_example
++ rm -f$(LIB) linenoise_example *.o
++
++.PHONY: install
++install: $(LIB)
++ install -m 0755 -d $(DESTDIR)$(INCLUDEDIR)
++ install -m 0644 linenoise.h $(DESTDIR)$(INCLUDEDIR)
++ install -m 0755 -d $(DESTDIR)$(LIBDIR)
++ install -m 0755 $(LIB) $(DESTDIR)$(LIBDIR)
++ ldconfig -n $(DESTDIR)$(LIBDIR)
++ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/liblinenoise.so