summaryrefslogtreecommitdiff
path: root/system/linenoise
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-29 16:05:33 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-29 16:05:33 -0500
commit9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf (patch)
tree2e23088c6630a97c89ef77f2a130aa9907422a6e /system/linenoise
parent4b6bbcad502d5e2299df4cb4f8d79297b4ea0ce7 (diff)
downloadpackages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.gz
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.bz2
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.xz
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.zip
system/linenoise: Don't call ldconfig(8) for .so
We do not need to add the build path to the ld path. Fixes: #753
Diffstat (limited to 'system/linenoise')
-rw-r--r--system/linenoise/APKBUILD8
-rw-r--r--system/linenoise/build-shared-lib.patch3
2 files changed, 5 insertions, 6 deletions
diff --git a/system/linenoise/APKBUILD b/system/linenoise/APKBUILD
index 1fd49a51f..83d5eb0b3 100644
--- a/system/linenoise/APKBUILD
+++ b/system/linenoise/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=linenoise
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Minimal replacement for readline"
url="https://github.com/antirez/linenoise"
arch="all"
options="!check" # No test suite.
license="BSD-2-Clause-NetBSD"
depends=""
-makedepends=""
+makedepends="musl-utils"
subpackages="$pkgname-dev"
source="linenoise-$pkgver.tar.gz::https://github.com/antirez/linenoise/archive/$pkgver.tar.gz
build-shared-lib.patch
@@ -20,8 +20,8 @@ build() {
}
package() {
- make DESTDIR="$pkgdir" install
+ PATH="/sbin:$PATH" make DESTDIR="$pkgdir" install
}
sha512sums="9e68fade8d64d7ba8d5d681e74d0ca6c4ebd9576249bb0e885b1aa708a9af77a43ea6264307ae46fb74e52219387a2c831b570f9601e331837f35294af9883e3 linenoise-1.0.tar.gz
-4f38ffc191c69e6a60fd064929ad0d442700a2928cd2de04e52c12e3ce67c8f1d49e993782d764fe8c59165eed20fb7725ea9147942a7e0e26ff1a8ebb145e9a build-shared-lib.patch"
+2b751a3fad995e7973e4cde01e4c7fce4dcce887564e5b756ae0200e0d5f4870b13f4ab634e9db4d9581c1c0161f36ca954acdb4fbc2bf6497f06840ab260a81 build-shared-lib.patch"
diff --git a/system/linenoise/build-shared-lib.patch b/system/linenoise/build-shared-lib.patch
index b94d6ab4c..12a98edda 100644
--- a/system/linenoise/build-shared-lib.patch
+++ b/system/linenoise/build-shared-lib.patch
@@ -1,6 +1,6 @@
--- ./Makefile.orig
+++ ./Makefile
-@@ -1,7 +1,34 @@
+@@ -1,7 +1,33 @@
+MAJOR_VERSION = 0
+EXTRA_VERSION = .0.0
+SONAME = liblinenoise.so.$(MAJOR_VERSION)
@@ -33,6 +33,5 @@
+ install -m 0644 linenoise.h $(DESTDIR)$(INCLUDEDIR)
+ install -m 0755 -d $(DESTDIR)$(LIBDIR)
+ install -m 0755 $(LIB) $(DESTDIR)$(LIBDIR)
-+ ldconfig -n $(DESTDIR)$(LIBDIR)
+ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/liblinenoise.so