summaryrefslogtreecommitdiff
path: root/system/linux-pam
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/linux-pam
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/linux-pam')
-rw-r--r--system/linux-pam/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/system/linux-pam/APKBUILD b/system/linux-pam/APKBUILD
index 0d1221a0d..44b603644 100644
--- a/system/linux-pam/APKBUILD
+++ b/system/linux-pam/APKBUILD
@@ -6,12 +6,12 @@ pkgrel=2
pkgdesc="Pluggable Authentication Modules"
url="https://www.kernel.org/pub/linux/libs/pam"
arch="all"
+options="suid"
license="BSD-3-Clause"
depends_dev="gettext-tiny-dev"
makedepends_host="$depends_dev utmps-dev"
makedepends_build="$depends_dev byacc flex-dev autoconf automake libtool"
makedepends="$makedepends_host $makedepends_build"
-options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-$pkgver.tar.xz
fix-compat.patch
@@ -27,17 +27,15 @@ source="https://github.com/$pkgname/$pkgname/releases/download/v1.3.1/Linux-PAM-
other.pamd
su.pamd
"
-
builddir="$srcdir"/Linux-PAM-$pkgver
+
prepare() {
- cd "$builddir"
default_prepare
# disable insecure modules
sed -e 's/pam_rhosts//g' -i modules/Makefile.am
}
build() {
- cd "$builddir"
autoreconf -vif
[ "$CLIBC" = "musl" ] && export ac_cv_search_crypt=no
LIBS="-lutmps -lskarnet" ./configure \
@@ -54,12 +52,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
# do not install pam.d files bundled with the source, they could be broken