summaryrefslogtreecommitdiff
path: root/system/llvm4/fix-CheckAtomic.cmake.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-15 20:01:45 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-15 20:01:45 +0000
commit8642108eae6cbb08930c10a883407a7ec2b2be1f (patch)
treed07f274152fd85a060cb72bf31ac70951804a79d /system/llvm4/fix-CheckAtomic.cmake.patch
parentde7967e51d8a8b525054bca4dd72dae1b32a48dd (diff)
downloadpackages-8642108eae6cbb08930c10a883407a7ec2b2be1f.tar.gz
packages-8642108eae6cbb08930c10a883407a7ec2b2be1f.tar.bz2
packages-8642108eae6cbb08930c10a883407a7ec2b2be1f.tar.xz
packages-8642108eae6cbb08930c10a883407a7ec2b2be1f.zip
Bump LLVM and Clang to 6.0.1, move to user/
Diffstat (limited to 'system/llvm4/fix-CheckAtomic.cmake.patch')
-rw-r--r--system/llvm4/fix-CheckAtomic.cmake.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/system/llvm4/fix-CheckAtomic.cmake.patch b/system/llvm4/fix-CheckAtomic.cmake.patch
deleted file mode 100644
index a5309de6c..000000000
--- a/system/llvm4/fix-CheckAtomic.cmake.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This cmake file uses command CHECK_LIBRARY_EXISTS that is defined in
-module CheckLibraryExists, but it does not include that module.
-
-This caused build error in lldb, but only on x86 (not x86_64)...
-
- -- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB - Failed
- CMake Error at /usr/lib/llvm4/lib/cmake/llvm/CheckAtomic.cmake:66 (check_library_exists):
- Unknown CMake command "check_library_exists".
- Call Stack (most recent call first):
- cmake/modules/LLDBStandalone.cmake:90 (include)
- CMakeLists.txt:3 (include)
-
---- a/cmake/modules/CheckAtomic.cmake
-+++ b/cmake/modules/CheckAtomic.cmake
-@@ -1,6 +1,7 @@
- # atomic builtins are required for threading support.
-
- INCLUDE(CheckCXXSourceCompiles)
-+INCLUDE(CheckLibraryExists)
-
- # Sometimes linking against libatomic is required for atomic ops, if
- # the platform doesn't support lock-free atomics.