summaryrefslogtreecommitdiff
path: root/system/llvm4/fix-CheckAtomic.cmake.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-17 14:30:31 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-17 14:30:31 -0600
commit4ef18bf6d42e63f7c2f93ee20dd82b359417c0a9 (patch)
tree925dbe4589d34311e24dd152e4d8b6a2b94767a1 /system/llvm4/fix-CheckAtomic.cmake.patch
parent637e7dc17f2150463814027b0c59420eccecac5e (diff)
downloadpackages-4ef18bf6d42e63f7c2f93ee20dd82b359417c0a9.tar.gz
packages-4ef18bf6d42e63f7c2f93ee20dd82b359417c0a9.tar.bz2
packages-4ef18bf6d42e63f7c2f93ee20dd82b359417c0a9.tar.xz
packages-4ef18bf6d42e63f7c2f93ee20dd82b359417c0a9.zip
system/llvm4: save from aports
Diffstat (limited to 'system/llvm4/fix-CheckAtomic.cmake.patch')
-rw-r--r--system/llvm4/fix-CheckAtomic.cmake.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/system/llvm4/fix-CheckAtomic.cmake.patch b/system/llvm4/fix-CheckAtomic.cmake.patch
new file mode 100644
index 000000000..a5309de6c
--- /dev/null
+++ b/system/llvm4/fix-CheckAtomic.cmake.patch
@@ -0,0 +1,22 @@
+This cmake file uses command CHECK_LIBRARY_EXISTS that is defined in
+module CheckLibraryExists, but it does not include that module.
+
+This caused build error in lldb, but only on x86 (not x86_64)...
+
+ -- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB - Failed
+ CMake Error at /usr/lib/llvm4/lib/cmake/llvm/CheckAtomic.cmake:66 (check_library_exists):
+ Unknown CMake command "check_library_exists".
+ Call Stack (most recent call first):
+ cmake/modules/LLDBStandalone.cmake:90 (include)
+ CMakeLists.txt:3 (include)
+
+--- a/cmake/modules/CheckAtomic.cmake
++++ b/cmake/modules/CheckAtomic.cmake
+@@ -1,6 +1,7 @@
+ # atomic builtins are required for threading support.
+
+ INCLUDE(CheckCXXSourceCompiles)
++INCLUDE(CheckLibraryExists)
+
+ # Sometimes linking against libatomic is required for atomic ops, if
+ # the platform doesn't support lock-free atomics.