summaryrefslogtreecommitdiff
path: root/system/lua5.3
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 20:04:21 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-19 20:04:21 -0500
commit146dbadd4867c64bf5594cd51ee31057dc05b023 (patch)
tree856013e082edb16eb65321d2252eba1733b50712 /system/lua5.3
parent7e8a986670ad147bcdb735cf2184357a5e5900b9 (diff)
downloadpackages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.gz
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.bz2
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.tar.xz
packages-146dbadd4867c64bf5594cd51ee31057dc05b023.zip
system: pull in lua bull crap for kyua
Diffstat (limited to 'system/lua5.3')
-rw-r--r--system/lua5.3/APKBUILD141
-rw-r--r--system/lua5.3/linenoise.patch18
-rw-r--r--system/lua5.3/lua-5.3-make.patch74
-rw-r--r--system/lua5.3/lua-5.3-module_paths.patch31
4 files changed, 264 insertions, 0 deletions
diff --git a/system/lua5.3/APKBUILD b/system/lua5.3/APKBUILD
new file mode 100644
index 000000000..34d640721
--- /dev/null
+++ b/system/lua5.3/APKBUILD
@@ -0,0 +1,141 @@
+# Maintainer:
+pkgname=lua5.3
+_pkgname=lua
+pkgver=5.3.4
+_luaver=${pkgname#lua}
+pkgrel=5
+pkgdesc="Light-weight programming language"
+url="https://www.lua.org/"
+arch="all"
+license="MIT"
+ldpath="/usr/lib/$pkgname"
+depends_dev="$pkgname"
+makedepends="libtool autoconf automake linenoise-dev"
+provides="lua"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://www.lua.org/ftp/$_pkgname-$pkgver.tar.gz
+ lua-5.3-make.patch
+ lua-5.3-module_paths.patch
+ linenoise.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+
+ # disable readline
+ sed -i '/#define LUA_USE_READLINE/d' src/luaconf.h
+
+ # we use libtool
+ cat > configure.ac <<-EOF
+ top_buildir=.
+
+ AC_INIT(src/luaconf.h)
+ AC_PROG_LIBTOOL
+ AC_OUTPUT()
+ EOF
+ libtoolize --force --install && aclocal && autoconf
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+
+ cd src
+ make V=${pkgver%.*} \
+ CFLAGS="-DLUA_USE_LINUX -DLUA_COMPAT_5_2 -DLUA_USE_LINENOISE" \
+ SYSLDFLAGS="$LDFLAGS" \
+ RPATH="/usr/lib" \
+ LIB_LIBS="-lpthread -lm -ldl -llinenoise" \
+ alpine_all
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ local i
+ cd "$builddir"
+
+ make V=${pkgver%.*} \
+ INSTALL_TOP="$pkgdir"/usr \
+ INSTALL_INC="$pkgdir"/usr/include/$pkgname \
+ INSTALL_LIB="$pkgdir"/usr/lib/$pkgname \
+ alpine_install
+
+ for i in "$pkgdir"/usr/bin/* ; do
+ mv "$i" "$i"$_luaver
+ done
+
+ for i in "$pkgdir"/usr/lib/$pkgname/*.so.*; do
+ ln -s $pkgname/${i##*/} "$pkgdir"/usr/lib/${i##*/}
+ done
+
+ install -D -m 644 doc/lua.1 "$pkgdir"/usr/share/man/man1/lua$_luaver.1
+ install -D -m 644 doc/luac.1 "$pkgdir"/usr/share/man/man1/luac$_luaver.1
+
+ install -d "$pkgdir"/usr/lib/pkgconfig
+ cat > "$pkgdir"/usr/lib/pkgconfig/lua$_luaver.pc <<-EOF
+ # lua.pc -- pkg-config data for Lua
+
+ # vars from install Makefile
+
+ # grep '^V=' ../Makefile
+ V= ${_luaver}
+ # grep '^R=' ../Makefile
+ R= ${pkgver}
+
+ # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+ prefix= /usr
+ INSTALL_BIN= \${prefix}/bin
+ INSTALL_INC= \${prefix}/include
+ INSTALL_LIB= \${prefix}/lib
+ INSTALL_MAN= \${prefix}/man/man1
+ INSTALL_LMOD= \${prefix}/share/lua/\${V}
+ INSTALL_CMOD= \${prefix}/lib/lua/\${V}
+
+ # canonical vars
+ exec_prefix=\${prefix}
+ libdir=\${exec_prefix}/lib/$pkgname
+ includedir=\${prefix}/include/$pkgname
+
+ Name: Lua
+ Description: An Extensible Extension Language
+ Version: \${R}
+ Requires:
+ Libs: -L\${libdir} -llua -lm
+ Cflags: -I\${includedir}
+
+ # (end of lua$_luaver.pc)
+ EOF
+
+}
+
+dev() {
+ default_dev
+
+ mkdir -p "$subpkgdir"/usr/$pkgname "$subpkgdir"/usr/lib/$pkgname
+ ln -s ../include/$pkgname "$subpkgdir"/usr/$pkgname/include
+ ln -s ../lib/$pkgname "$subpkgdir"/usr/$pkgname/lib
+ mv "$pkgdir"/usr/lib/$pkgname/liblua.so "$subpkgdir"/usr/lib/$pkgname/
+}
+
+libs() {
+ pkgdesc="Lua dynamic library runtime"
+ replaces="lua"
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
+}
+
+sha512sums="739e31f82e6a60fa99910c2005e991b3a1e21339af52847f653cb190b30842054d189ca116ffcfdf9b36e07888c9ce5642b1dd2988cc7eff9f8789f9a2e34997 lua-5.3.4.tar.gz
+1bc6c623024c1738155b30ff9c0edcce0f336edc25aa20c3a1400c859421ea2015d75175cce8d515e055ac3e96028426b74812e04022af18a0ed4c4601556027 lua-5.3-make.patch
+bc68772390dc8d8940176af0b9fbacc0af61891b5d27de5f1466a4e7f9b3291a1c08ba5add829bc96b789a53fa5ec2dadaa096ca6eabe54ec27724fa2810940f lua-5.3-module_paths.patch
+49880d1131b7bd2a3169a26f401769a91d9a6a62cefe68aa5a89097139289588b7ef753535a2d0ba7f45c0369c760554940fd810716b7b1353deace32432fcfe linenoise.patch"
diff --git a/system/lua5.3/linenoise.patch b/system/lua5.3/linenoise.patch
new file mode 100644
index 000000000..fdca6205a
--- /dev/null
+++ b/system/lua5.3/linenoise.patch
@@ -0,0 +1,18 @@
+--- ./src/lua.c.orig
++++ ./src/lua.c
+@@ -85,6 +85,15 @@
+ add_history(lua_tostring(L, idx)); /* add it to history */
+ #define lua_freeline(L,b) ((void)L, free(b))
+
++#elif defined(LUA_USE_LINENOISE)/* }{ */
++
++#include "linenoise.h"
++#define lua_readline(L,b,p) ((void)L, ((b)=linenoise(p)) != NULL)
++#define lua_saveline(L,idx) \
++ if (lua_rawlen(L,idx) > 0) /* non-empty line? */ \
++ linenoiseHistoryAdd(lua_tostring(L, idx)); /* add it to history */
++#define lua_freeline(L,b) ((void)L, free(b))
++
+ #else /* }{ */
+
+ #define lua_readline(L,b,p) \
diff --git a/system/lua5.3/lua-5.3-make.patch b/system/lua5.3/lua-5.3-make.patch
new file mode 100644
index 000000000..349218607
--- /dev/null
+++ b/system/lua5.3/lua-5.3-make.patch
@@ -0,0 +1,74 @@
+diff --git a/Makefile b/Makefile
+index 7fa91c8..c85ede2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -112,3 +112,18 @@ pc:
+ .PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho
+
+ # (end of Makefile)
++
++# Use libtool for binary installs, etc.
++
++export V
++export LIBTOOL = ../libtool --quiet --tag=CC
++# See libtool manual about how to set this
++
++alpine_clean:
++ cd src; $(MAKE) $@
++
++alpine_install:
++ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
++ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
+diff --git a/src/Makefile b/src/Makefile
+index 2e7a412..a72f342 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -59,10 +59,10 @@ $(LUA_A): $(BASE_O)
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
+-$(LUA_T): $(LUA_O) $(LUA_A)
++origin$(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+
+-$(LUAC_T): $(LUAC_O) $(LUA_A)
++origin$(LUAC_T): $(LUAC_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
+
+ clean:
+@@ -194,4 +194,33 @@ lvm.o: lvm.c lprefix.h lua.h luaconf.h ldebug.h lstate.h lobject.h \
+ lzio.o: lzio.c lprefix.h lua.h luaconf.h llimits.h lmem.h lstate.h \
+ lobject.h ltm.h lzio.h
+
++
++export LIBTOOL = ../libtool --quiet --tag=CC
++export LIB_VERSION = 0:0:0
++
++# The following rules use libtool for compiling and linking in order to
++# provide shared library support.
++
++LIB_NAME = liblua.la
++LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
++
++%.lo %.o: %.c
++ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
++
++$(LIB_NAME): $(LIB_OBJS)
++ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) -release $(V) \
++ -rpath $(RPATH) $(LDFLAGS) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
++
++$(LUA_T): $(LUA_O:.o=.lo) $(LIB_NAME)
++ $(LIBTOOL) --mode=link $(CC) -export-dynamic $(LDFLAGS) -o $@ \
++ $(LUA_O:.o=.lo) $(LIB_NAME) $(LUA_LIBS)
++
++$(LUAC_T): $(LUAC_O:.o=.lo) $(LIB_NAME)
++ $(LIBTOOL) --mode=link $(CC) -static $(LDFLAGS) -o $@ $(LUAC_O:.o=.lo) \
++ $(LIB_NAME)
++
++alpine_clean:
++ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
++
++alpine_all: $(LIB_NAME) $(LUA_T) $(LUAC_T)
+ # (end of Makefile)
diff --git a/system/lua5.3/lua-5.3-module_paths.patch b/system/lua5.3/lua-5.3-module_paths.patch
new file mode 100644
index 000000000..313d9c609
--- /dev/null
+++ b/system/lua5.3/lua-5.3-module_paths.patch
@@ -0,0 +1,31 @@
+diff --git a/src/luaconf.h b/src/luaconf.h
+index fd28d21..4c65295 100644
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -203,12 +201,25 @@
+ #define LUA_ROOT "/usr/local/"
+ #define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR "/"
+ #define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR "/"
++
++#define LUA_VENDOR_ROOT "/usr/"
++/* Path for version-specific Lua modules. */
++#define LUA_VENDOR_LDIR LUA_VENDOR_ROOT "share/lua/" LUA_VDIR "/"
++/* Path for Lua modules that are compatible with Lua 5.1 and newer. */
++#define LUA_VENDOR_COMMON_LDIR LUA_VENDOR_ROOT "share/lua/common/"
++#define LUA_VENDOR_CDIR LUA_VENDOR_ROOT "lib/lua/" LUA_VDIR "/"
++
+ #define LUA_PATH_DEFAULT \
+ LUA_LDIR"?.lua;" LUA_LDIR"?/init.lua;" \
+ LUA_CDIR"?.lua;" LUA_CDIR"?/init.lua;" \
++ LUA_VENDOR_LDIR"?.lua;" LUA_VENDOR_LDIR"?/init.lua;" \
++ LUA_VENDOR_CDIR"?.lua;" LUA_VENDOR_CDIR"?/init.lua;" \
++ LUA_VENDOR_COMMON_LDIR"?.lua;" LUA_VENDOR_COMMON_LDIR"?/init.lua;" \
+ "./?.lua;" "./?/init.lua"
+ #define LUA_CPATH_DEFAULT \
+- LUA_CDIR"?.so;" LUA_CDIR"loadall.so;" "./?.so"
++ LUA_CDIR"?.so;" LUA_CDIR"loadall.so;" \
++ LUA_VENDOR_CDIR"?.so;" LUA_VENDOR_CDIR"loadall.so;" \
++ "./?.so"
+ #endif /* } */
+
+