summaryrefslogtreecommitdiff
path: root/system/lutok
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/lutok
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/lutok')
-rw-r--r--system/lutok/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/system/lutok/APKBUILD b/system/lutok/APKBUILD
index 103688367..21ee0ad32 100644
--- a/system/lutok/APKBUILD
+++ b/system/lutok/APKBUILD
@@ -10,19 +10,15 @@ depends_dev="lua5.3-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/jmmv/lutok/releases/download/lutok-$pkgver/lutok-$pkgver.tar.gz"
-builddir="$srcdir/lutok-$pkgver"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
-
- LUA_CFLAGS=$(pkg-config --cflags lua5.3) \
- LUA_LIBS=$(pkg-config --libs lua5.3) \
+ LUA_CFLAGS=$(pkg-config --cflags lua) \
+ LUA_LIBS=$(pkg-config --libs lua) \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}