summaryrefslogtreecommitdiff
path: root/system/lvm2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-02 00:07:17 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-03 21:56:53 -0500
commitdcd477740a6483beb0aa5921fb11e7bac62b2615 (patch)
treec2760d9a2ab751c161cc0220d4a6ccb208a70767 /system/lvm2
parentee71f0098a7782c4a95c2f1d7ee614569214be1c (diff)
downloadpackages-dcd477740a6483beb0aa5921fb11e7bac62b2615.tar.gz
packages-dcd477740a6483beb0aa5921fb11e7bac62b2615.tar.bz2
packages-dcd477740a6483beb0aa5921fb11e7bac62b2615.tar.xz
packages-dcd477740a6483beb0aa5921fb11e7bac62b2615.zip
system/lvm2: Update to 2.03.21
Patches stdio overrides that caused a segfault. Fixes: 2b7653a985 ("system/lvm2: bump { 2.03.13 --> 2.03.15 }.")
Diffstat (limited to 'system/lvm2')
-rw-r--r--system/lvm2/APKBUILD8
-rw-r--r--system/lvm2/fix-stdio-usage.patch35
-rw-r--r--system/lvm2/mallinfo.patch11
3 files changed, 33 insertions, 21 deletions
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index 6df06c99c..626c1da98 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lvm2
-pkgver=2.03.15
+pkgver=2.03.21
pkgrel=0
pkgdesc="Logical Volume Manager 2 utilities"
url="https://sourceware.org/lvm2/"
@@ -17,7 +17,6 @@ makedepends="$makedepends_build $makedepends_host"
replaces="device-mapper $pkgname-dmeventd"
source="https://mirrors.kernel.org/sourceware/$pkgname/LVM2.$pkgver.tgz
fix-stdio-usage.patch
- mallinfo.patch
mlockall-default-config.patch
lvm.initd
lvm.confd
@@ -87,9 +86,8 @@ udev() {
}
-sha512sums="ad3cc33b9d54eebcbb79ada71baa7fdf2e76eca01d593a6aaa3649ef9345dc2fa939f09598486520c0548afde5a7691af13a35d8c1d431e5bbe51c41bbe6c2e9 LVM2.2.03.15.tgz
-47e35a2f89bae51c23ae44df1edcf2ae5635cddd4ad92eefa2b8be4c6aabbf3a212bcd26da9c6f4faf640c0142f36750795a5e3e7cf0e01668364eb748ad3161 fix-stdio-usage.patch
-9272ec8c5184ef5dc776ead8f74132e072b7563b5119a3a38b712f00d92a1e3878c9b3a54eb2b01dcba038110c686b39d4c17ecd0eb258537e9217d7ed03c408 mallinfo.patch
+sha512sums="6024811c3fa92afd2fc13a10d1c3542352aa9a016f40c3ef588bd2f5f3e41245fed4b36c8a87d9f7f8dddc6e13b7253396f5c811f99665df27751676dc7b5bde LVM2.2.03.21.tgz
+40e49bb34a9c07493ab6a9948e3ac1a85e22f069b69ad2a1369cb7d30a6ea6d72a27f380ad8951f55d939834e2f29c9da589ae475322ea41b4dfce72060b9557 fix-stdio-usage.patch
0f1feeddf35a7208a240b13d87f479eeb5410ccb534ccd62714355b10721c4eff77d725c72a2b5270320bef12828c32d60003f187db990fad3fef37ec08c1dff mlockall-default-config.patch
a853078660fd2fd943538924f56e81dc5793294e26b8f61d93e6188893f15f4a438d33792b341c1865d61e03f4a371b7c7ee0db5f4130ef7cb7aeaeb9290086a lvm.initd
07caf8fa942290f3c953cc2463aaf55bac01d0bcb9351daf3880fa4d0eefb67fe00761c46a7a4da91cd2f8e492a12fed35853a15dc939cd80d19d3303bc3951d lvm.confd
diff --git a/system/lvm2/fix-stdio-usage.patch b/system/lvm2/fix-stdio-usage.patch
index 69832c004..2b3f0a91f 100644
--- a/system/lvm2/fix-stdio-usage.patch
+++ b/system/lvm2/fix-stdio-usage.patch
@@ -1,6 +1,28 @@
---- LVM2.2.03.08/tools/lvmcmdline.c 2020-02-11 03:59:27.000000000 -0600
-+++ LVM2.2.03.08/tools/lvmcmdline.c 2020-03-22 16:17:35.470100377 -0500
-@@ -3233,7 +3233,7 @@ static int _check_standard_fds(void)
+From 4cf08811e112100a2b10c60047f3c537ad21d674 Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Sat, 28 Jan 2023 14:22:42 +0100
+Subject: [PATCH] Use `freopen()` on {stdin,stdout,stderr}
+
+* ISO C does not guarantee that the standard streams are modifiable
+ lvalues. Glibc even calls out this behaviour as non-portable:
+ https://www.gnu.org/software/libc/manual/html_node/Standard-Streams.html
+--- a/lib/log/log.c
++++ b/lib/log/log.c
+@@ -208,7 +208,11 @@ int reopen_standard_stream(FILE **stream, const char *mode)
+
+ _check_and_replace_standard_log_streams(old_stream, new_stream);
+
++#ifdef __GLIBC__
+ *stream = new_stream;
++#else
++ freopen(NULL, mode, *stream);
++#endif
+ return 1;
+ }
+
+--- a/tools/lvmcmdline.c
++++ b/tools/lvmcmdline.c
+@@ -3422,7 +3422,7 @@ static int _check_standard_fds(void)
int err = is_valid_fd(STDERR_FILENO);
if (!is_valid_fd(STDIN_FILENO) &&
@@ -9,7 +31,7 @@
if (err)
perror("stdin stream open");
else
-@@ -3243,7 +3243,7 @@ static int _check_standard_fds(void)
+@@ -3432,7 +3432,7 @@ static int _check_standard_fds(void)
}
if (!is_valid_fd(STDOUT_FILENO) &&
@@ -18,7 +40,7 @@
if (err)
perror("stdout stream open");
/* else no stdout */
-@@ -3251,7 +3251,7 @@ static int _check_standard_fds(void)
+@@ -3440,7 +3440,7 @@ static int _check_standard_fds(void)
}
if (!is_valid_fd(STDERR_FILENO) &&
@@ -27,3 +49,6 @@
printf("stderr stream open: %s\n",
strerror(errno));
return 0;
+--
+2.39.2
+
diff --git a/system/lvm2/mallinfo.patch b/system/lvm2/mallinfo.patch
deleted file mode 100644
index 471a6b255..000000000
--- a/system/lvm2/mallinfo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./lib/mm/memlock.c.orig 2015-03-09 11:18:41.560028850 -0100
-+++ ./lib/mm/memlock.c 2015-03-09 11:19:54.504373309 -0100
-@@ -137,7 +137,7 @@
-
- static void _allocate_memory(void)
- {
--#ifndef VALGRIND_POOL
-+#if !defined(VALGRIND_POOL) && defined(__GLIBC__)
- void *stack_mem;
- struct rlimit limit;
- int i, area = 0, missing = _size_malloc_tmp, max_areas = 32, hblks;