summaryrefslogtreecommitdiff
path: root/system/lvm2
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2021-10-04 10:37:36 +0000
committerDan Theisen <djt@hxx.in>2021-10-04 10:37:36 +0000
commite6c72fcc75357cbe919d228dc7dffe57f6cbb298 (patch)
treea3f42dd3a43920e2eedfd5a10c3f5a2f9da8ec0a /system/lvm2
parent5aee4146f4da48e5a003c264ad03aa0cf408e3ff (diff)
downloadpackages-e6c72fcc75357cbe919d228dc7dffe57f6cbb298.tar.gz
packages-e6c72fcc75357cbe919d228dc7dffe57f6cbb298.tar.bz2
packages-e6c72fcc75357cbe919d228dc7dffe57f6cbb298.tar.xz
packages-e6c72fcc75357cbe919d228dc7dffe57f6cbb298.zip
system/lvm2: bump to 2.03.13
Diffstat (limited to 'system/lvm2')
-rw-r--r--system/lvm2/APKBUILD10
-rw-r--r--system/lvm2/add-sys-file.patch20
-rw-r--r--system/lvm2/mlockall-default-config.patch13
3 files changed, 32 insertions, 11 deletions
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index 77a888240..24eaafdc3 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lvm2
-pkgver=2.03.09
+pkgver=2.03.13
pkgrel=0
pkgdesc="Logical Volume Manager 2 utilities"
url="https://sourceware.org/lvm2/"
@@ -19,6 +19,7 @@ source="https://mirrors.kernel.org/sourceware/$pkgname/LVM2.$pkgver.tgz
fix-stdio-usage.patch
mallinfo.patch
mlockall-default-config.patch
+ add-sys-file.patch
lvm.initd
lvm.confd
dmeventd.initd
@@ -38,7 +39,7 @@ build () {
export ac_cv_func_malloc_0_nonnull=yes
export ac_cv_func_realloc_0_nonnull=yes
- ./configure \
+ CFLAGS="-DHAVE_SYS_FILE_H" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -87,10 +88,11 @@ udev() {
}
-sha512sums="8540e46a6025ab14b592ccd9493b3224ffc0f962739a0a8de6d7b25c65c6ad96fc83ddb0e3d877b123a5e1b104476d0c20ccee2ead6d322257ec82ad1e3362d4 LVM2.2.03.09.tgz
+sha512sums="8b4fb6da5dd46ddeb754436189072bea79be594fab6d57d9be63c6ce3e3cb68d38601a2c031c493681321281cfb1f1459ace19974c00beb569364f44863cfc4a LVM2.2.03.13.tgz
bc4473c2f48ff6cab121f92211cd1b67589a6abadd8e32ffa366fed6ddbf9c87be695aa54a6e97b5b79203bf1a7d22cdb5974da84d38b4977592ef7a061612e7 fix-stdio-usage.patch
9272ec8c5184ef5dc776ead8f74132e072b7563b5119a3a38b712f00d92a1e3878c9b3a54eb2b01dcba038110c686b39d4c17ecd0eb258537e9217d7ed03c408 mallinfo.patch
-d190c40a137b006d7b63298069c93ff08d2804b990e85d44739cd7c48beec9a569903b98f0d940895fc7365723ba886acd7ef0e08f1f65a1a391d1c448ce080e mlockall-default-config.patch
+0f1feeddf35a7208a240b13d87f479eeb5410ccb534ccd62714355b10721c4eff77d725c72a2b5270320bef12828c32d60003f187db990fad3fef37ec08c1dff mlockall-default-config.patch
+be5236a6b7ab91547603a266620b4f626854e3022036e2ed4b7e64b03941ddef3892804473c3440d913f41f820bccd78281a3979a822cae5c29304e21295ab1a add-sys-file.patch
a853078660fd2fd943538924f56e81dc5793294e26b8f61d93e6188893f15f4a438d33792b341c1865d61e03f4a371b7c7ee0db5f4130ef7cb7aeaeb9290086a lvm.initd
07caf8fa942290f3c953cc2463aaf55bac01d0bcb9351daf3880fa4d0eefb67fe00761c46a7a4da91cd2f8e492a12fed35853a15dc939cd80d19d3303bc3951d lvm.confd
ca06220065525e93347efb7a5746a367cf55cb03574e50eed29bd7c4eae036bdd199b52c42d81811b6e742649e73ab8e66525f663bed66f9d1d82d0efde50332 dmeventd.initd"
diff --git a/system/lvm2/add-sys-file.patch b/system/lvm2/add-sys-file.patch
new file mode 100644
index 000000000..d21f5cdfc
--- /dev/null
+++ b/system/lvm2/add-sys-file.patch
@@ -0,0 +1,20 @@
+--- ./lib/device/dev-cache.c 2021-10-04 10:26:46.747943865 +0000
++++ ./lib/device/dev-cache.c 2021-10-04 10:23:55.715876227 +0000
+@@ -29,6 +29,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <locale.h>
++#include <sys/file.h>
+
+ struct dev_iter {
+ struct btree_iter *current;
+--- ./tools/lvmdevices.c 2021-10-04 10:34:16.660694727 +0000
++++ ./tools/lvmdevices.c 2021-10-04 10:34:33.718908403 +0000
+@@ -16,6 +16,7 @@
+ #include "lib/cache/lvmcache.h"
+ #include "lib/device/device_id.h"
+ #include "lib/device/dev-type.h"
++#include <sys/file.h>
+
+ static void _search_devs_for_pvids(struct cmd_context *cmd, struct dm_list *search_pvids, struct dm_list *found_devs)
+ {
diff --git a/system/lvm2/mlockall-default-config.patch b/system/lvm2/mlockall-default-config.patch
index 1daadeff3..898611ec7 100644
--- a/system/lvm2/mlockall-default-config.patch
+++ b/system/lvm2/mlockall-default-config.patch
@@ -1,15 +1,14 @@
---- ./conf/example.conf.in.orig
-+++ ./conf/example.conf.in
-@@ -1352,7 +1352,7 @@
- # Use the old behavior of mlockall to pin all memory.
+--- ./conf/example.conf.in.old 2021-10-04 09:59:13.191167497 +0000
++++ ./conf/example.conf.in 2021-10-04 09:59:41.718184441 +0000
+@@ -1696,7 +1696,7 @@
# Prior to version 2.02.62, LVM used mlockall() to pin the whole
# process's memory while activating devices.
-- use_mlockall = 0
+ # This configuration option has an automatic default value.
+- # use_mlockall = 0
+ use_mlockall = 1
# Configuration option activation/monitoring.
- # Monitor LVs that are activated.
-diff --git a/lib/config/defaults.h b/lib/config/defaults.h
+ # Monitor LVs that are activated.diff --git a/lib/config/defaults.h b/lib/config/defaults.h
index 8ab1fde..57b2443 100644
--- a/lib/config/defaults.h
+++ b/lib/config/defaults.h