summaryrefslogtreecommitdiff
path: root/system/m4
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:56 -0500
commitb1eb50599e4db7eb4501af75cbbfa22007081ea5 (patch)
treec94a34c882cc17adedd781e8c5f34349b2a62416 /system/m4
parentb9e85bbdcf38547ef2ca4e5c2a6e6293bbcd2752 (diff)
downloadpackages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.gz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.bz2
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.xz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.zip
The New Plan
all pkgs needed to bootstrap -> system others -> user
Diffstat (limited to 'system/m4')
-rw-r--r--system/m4/APKBUILD41
-rw-r--r--system/m4/disable-mbrtowc-test.patch10
-rw-r--r--system/m4/localename-test-fix.patch34
3 files changed, 85 insertions, 0 deletions
diff --git a/system/m4/APKBUILD b/system/m4/APKBUILD
new file mode 100644
index 000000000..af6db8b8d
--- /dev/null
+++ b/system/m4/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=m4
+pkgver=1.4.18
+pkgrel=1
+pkgdesc="GNU macro processor"
+url="https://www.gnu.org/software/m4"
+depends=
+makedepends=texinfo
+checkdepends=diffutils
+arch="all"
+license="GPL-3.0+"
+subpackages="m4-doc"
+source="ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
+ disable-mbrtowc-test.patch
+ localename-test-fix.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+}
+
+sha512sums="29254dd4267a093e8d9da3a26df8b02564044cdb4506be539ec1aff4e5d406477bcf32f5e813c840f3aec77293bfe2cdde18f6a21724a7e0bfff646ec88b74ae m4-1.4.18.tar.gz
+78bf099c96fcec8c9cebd4e34f0d7c942e99da2ec238baa9464f8443580edb0565e9026c433ee54fb564304ec8e7e90766e19474472e57b48e567fd7b356777e disable-mbrtowc-test.patch
+fac0cb58e698996284a222c4da340f92689d6db98f1fbab6e61e1c5f2d90122660296f8e5c60c94169413e3e2ee632c6264f12b98e5d3a1e1aae145a2d4aac45 localename-test-fix.patch"
diff --git a/system/m4/disable-mbrtowc-test.patch b/system/m4/disable-mbrtowc-test.patch
new file mode 100644
index 000000000..cc2be2478
--- /dev/null
+++ b/system/m4/disable-mbrtowc-test.patch
@@ -0,0 +1,10 @@
+--- m4-1.4.18/tests/test-mbrtowc5.sh.old 2016-12-31 13:54:43.000000000 +0000
++++ m4-1.4.18/tests/test-mbrtowc5.sh 2017-07-30 17:29:50.879924130 +0000
+@@ -1,6 +1,2 @@
+ #!/bin/sh
+-# Test whether the POSIX locale has encoding errors.
+-LC_ALL=C \
+-./test-mbrtowc${EXEEXT} 5 || exit
+-LC_ALL=POSIX \
+-./test-mbrtowc${EXEEXT} 5
++exit 77
diff --git a/system/m4/localename-test-fix.patch b/system/m4/localename-test-fix.patch
new file mode 100644
index 000000000..04584aba6
--- /dev/null
+++ b/system/m4/localename-test-fix.patch
@@ -0,0 +1,34 @@
+--- m4-1.4.18/tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
++++ m4-1.4.18/tests/localename.c 2017-07-30 16:40:47.098541270 +0000
+@@ -40,7 +40,7 @@
+ # if defined __APPLE__ && defined __MACH__
+ # include <xlocale.h>
+ # endif
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined __linux__
+ # include <langinfo.h>
+ # endif
+ # if !defined IN_LIBINTL
+@@ -2692,16 +2692,19 @@
+ locale_t thread_locale = uselocale (NULL);
+ if (thread_locale != LC_GLOBAL_LOCALE)
+ {
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined(_NL_LOCALE_NAME)
++ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
++# if __GLIBC__ >= 2 && !defined __UCLIBC__
+ /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
+ glibc < 2.12.
+ See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
+- const char *name =
+- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
++ if (name[0] == '\0')
++ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
+ if (name[0] == '\0')
+ /* Fallback code for glibc < 2.4, which did not implement
+ nl_langinfo (_NL_LOCALE_NAME (category)). */
+ name = thread_locale->__names[category];
++# endif
+ return name;
+ # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
+ /* FreeBSD, Mac OS X */