summaryrefslogtreecommitdiff
path: root/system/man-pages
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-25 19:32:14 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-25 19:32:14 -0500
commitdc65347c31bba922f8186874cac8db2c909ec399 (patch)
treec98ede6b7674fa74086aaffcdbd718428284848c /system/man-pages
parent81079b74e67cca2652fd0e186df23e6bc4a90951 (diff)
downloadpackages-dc65347c31bba922f8186874cac8db2c909ec399.tar.gz
packages-dc65347c31bba922f8186874cac8db2c909ec399.tar.bz2
packages-dc65347c31bba922f8186874cac8db2c909ec399.tar.xz
packages-dc65347c31bba922f8186874cac8db2c909ec399.zip
system/man-pages: pull in for build-tools
Diffstat (limited to 'system/man-pages')
-rw-r--r--system/man-pages/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/system/man-pages/APKBUILD b/system/man-pages/APKBUILD
new file mode 100644
index 000000000..395fe52d6
--- /dev/null
+++ b/system/man-pages/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=man-pages
+pkgver=4.16
+_posixver=2013-a
+pkgrel=0
+pkgdesc="Linux man pages"
+url="https://www.kernel.org/doc/man-pages/"
+arch="noarch"
+options="!strip !check" # just manpages
+license="GPL-2.0+ AND POSIX"
+depends=""
+makedepends=""
+source="https://cdn.kernel.org/pub/linux/docs/$pkgname/$pkgname-$pkgver.tar.xz
+ https://cdn.kernel.org/pub/linux/docs/$pkgname/$pkgname-posix/$pkgname-posix-${_posixver}.tar.xz
+ "
+
+build() {
+ cd "$builddir"
+
+ mkdir man0
+ for sect in 0 1 3; do
+ sed -i "/^\.so /s/man${sect}p/man$sect/" \
+ "$srcdir"/$pkgname-posix-${_posixver}/man${sect}p/*
+ mv "$srcdir"/$pkgname-posix-${_posixver}/man${sect}p/* \
+ "$srcdir"/$pkgname-$pkgver/man$sect/
+ done
+}
+
+package() {
+ cd "$builddir"
+
+ make prefix="$pkgdir"/usr install
+ find "$pkgdir"/usr/share/man -name "*.[0-9]" | xargs gzip -9
+
+ # provided by libiconv-doc
+ rm -f "$pkgdir"/usr/share/man/man3/iconv*
+
+ # provided by mdocml
+ rm -f "$pkgdir"/usr/share/man/man7/man* \
+ "$pkgdir"/usr/share/man/man7/mdoc*
+
+ # provided by tzdata
+ rm -f "$pkgdir"/usr/share/man/man5/tzfile* \
+ "$pkgdir"/usr/share/man/man8/tzselect* \
+ "$pkgdir"/usr/share/man/man8/zic* \
+ "$pkgdir"/usr/share/man/man8/zdump*
+
+ # provided by libbsd
+ rm -f "$pkgdir"/usr/share/man/man3/explicit_bzero*
+}
+
+sha512sums="df282a0480e2c1cc74e4ba02d6ff02ba95886b6583058c737028ea609b916270ba7dcaf075e0c450fd4b49b335979765abfc7d0a75f5570eec5fa2381c10201c man-pages-4.16.tar.xz
+e6ec8eb57269fadf368aeaac31b5a98b9c71723d4d5cc189f9c4642d6e865c88e44f77481dccbdb72e31526488eb531f624d455016361687a834ccfcac19fa14 man-pages-posix-2013-a.tar.xz"