summaryrefslogtreecommitdiff
path: root/system/musl-locales
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 04:23:28 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 04:23:28 +0000
commit04ffcaf1a02bf04e294a34212f8607af30268df9 (patch)
tree778c3f24abf968c53eebf938bfbe1e0e3d6b69df /system/musl-locales
parentf5d729126a44790f035b7b23efc85ff0e9c0007c (diff)
downloadpackages-04ffcaf1a02bf04e294a34212f8607af30268df9.tar.gz
packages-04ffcaf1a02bf04e294a34212f8607af30268df9.tar.bz2
packages-04ffcaf1a02bf04e294a34212f8607af30268df9.tar.xz
packages-04ffcaf1a02bf04e294a34212f8607af30268df9.zip
system/musl-locales: move from user/, update
Diffstat (limited to 'system/musl-locales')
-rw-r--r--system/musl-locales/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/musl-locales/APKBUILD b/system/musl-locales/APKBUILD
new file mode 100644
index 000000000..f537430d0
--- /dev/null
+++ b/system/musl-locales/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alyx <alyx@leuhta.com>
+# Maintainer: Alyx <alyx@leuhta.com>
+pkgname=musl-locales
+pkgver=0.20200319
+pkgrel=0
+pkgdesc="Locale program for musl"
+url="https://gitlab.com/rilian-la-te/musl-locales"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-3.0-only"
+depends=""
+makedepends="cmake make gettext-tiny-dev"
+subpackages="$pkgname-lang"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+lang() {
+ license="MIT"
+ default_lang
+}
+
+sha512sums="921c5a4dfb45ac12b1eaf284986237bd95420a58705702d0541a46fa2480ff97cd3ac929661108c67304e4e1bfe1efed7bf8edd535b7260d7eb69d72aa294e45 musl-locales-0.20200319.tar.xz"