summaryrefslogtreecommitdiff
path: root/system/musl
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-15 20:53:37 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-15 20:53:37 -0500
commit21fb7168e62542ec26e32061f2bf1539ceb60b95 (patch)
treee51517796fe3c74c669d70a1aa588475f9e06b6b /system/musl
parent3a97e7294ebdb3dd3f94f4f097f806da8071535c (diff)
downloadpackages-21fb7168e62542ec26e32061f2bf1539ceb60b95.tar.gz
packages-21fb7168e62542ec26e32061f2bf1539ceb60b95.tar.bz2
packages-21fb7168e62542ec26e32061f2bf1539ceb60b95.tar.xz
packages-21fb7168e62542ec26e32061f2bf1539ceb60b95.zip
system/musl: fix lastlog.h with utmps
Diffstat (limited to 'system/musl')
-rw-r--r--system/musl/3001-make-real-lastlog-h.patch30
-rw-r--r--system/musl/APKBUILD4
2 files changed, 33 insertions, 1 deletions
diff --git a/system/musl/3001-make-real-lastlog-h.patch b/system/musl/3001-make-real-lastlog-h.patch
new file mode 100644
index 000000000..168ef882b
--- /dev/null
+++ b/system/musl/3001-make-real-lastlog-h.patch
@@ -0,0 +1,30 @@
+Since we remove <utmp{,x}.h> from musl for utmps support, we can't use the
+included <lastlog.h>.
+
+This implements just the lastlog stuff from musl <utmp.h>.
+
+--- musl-1.1.19/include/lastlog.h 2018-02-22 12:39:19.000000000 -0600
++++ musl-1.1.19/include/lastlog.h 2018-06-15 20:04:54.428854473 -0500
+@@ -1 +1,21 @@
+-#include <utmp.h>
++#ifndef _LASTLOG_H
++#define _LASTLOG_H
++
++#ifdef __cplusplus
++extern "C" {
++#endif
++
++#define UT_HOSTSIZE 256
++#define UT_LINESIZE 32
++
++struct lastlog {
++ time_t ll_time;
++ char ll_line[UT_LINESIZE];
++ char ll_host[UT_HOSTSIZE];
++};
++
++#ifdef __cplusplus
++}
++#endif
++
++#endif
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 4baf738db..594460e9e 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
pkgver=1.1.19
-pkgrel=6
+pkgrel=7
pkgdesc="System library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -27,6 +27,7 @@ source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0007-abort-raise-SIGABRT-again-if-signal-is-ignored.patch
2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
+ 3001-make-real-lastlog-h.patch
complex-math.patch
complex-math2.patch
handle-aux-at_base.patch
@@ -125,6 +126,7 @@ e99dab95932c0c03d67da0248d63b71581050efed40c5e58b28e226925f6f436b6e7ddfbf03dc83e
d0d0817a4e1d57b74cb442a3bf8d8efe39a23a387275b75cba1b2fa354d8a7dc2fd843b5b67584aac86ec97ea394d602ec013c6e8a65da309915b0a80b4a8f98 0006-time-C11-visibility-fixes.patch
6f5f9b5fb5eba638b0d98c68c280dbcc2bdae58d94d9f6966f5de55f6dd5d7f3cdddd9ca758e8861e30841b80ba616a945fb2b885a31481707d578293b187ff0 0007-abort-raise-SIGABRT-again-if-signal-is-ignored.patch
2c8e1dde1834238097b2ee8a7bfb53471a0d9cff4a5e38b55f048b567deff1cdd47c170d0578a67b1a039f95a6c5fbb8cff369c75b6a3e4d7ed171e8e86ebb8c 2000-pthread-internals-increase-DEFAULT_GUARD_SIZE-to-2-p.patch
+ec3a8452b85121f2c04e3208ff8bb69824ddd576a2481a16a7c4a05fc107a7caf0ab772703c82956ee2bb251ca3661e4d5a1fef13ef4a2f513b168a9a46153ea 3001-make-real-lastlog-h.patch
8909dc260968770ace8f3ffdc04c6c7d20933ff115b4fa3e512fb7460860a8216c73ca7a7ad54f59cb5988ef011f02bf18aa13cc2287cc64ffdb8db84ef69d47 complex-math.patch
c34ae0c8c2b05d82bc6bd341ceb29041f6e1a1d2c7b2f4f289ab620288bfb1e1ddabc4cb2fc85220c1fbe735874c38a9b00af636644584c7cd1e895d54564a22 complex-math2.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch