summaryrefslogtreecommitdiff
path: root/system/musl
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-08 15:09:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-08 15:09:26 +0000
commit2b1a10d34bf6683f737aa1e510101b340c8df3db (patch)
tree44460fb15270c548ce28cf163b1e9740cc324a5e /system/musl
parent0a75f9b4d51fb8a04950c558e8fee3197f6ea2c3 (diff)
downloadpackages-2b1a10d34bf6683f737aa1e510101b340c8df3db.tar.gz
packages-2b1a10d34bf6683f737aa1e510101b340c8df3db.tar.bz2
packages-2b1a10d34bf6683f737aa1e510101b340c8df3db.tar.xz
packages-2b1a10d34bf6683f737aa1e510101b340c8df3db.zip
system/musl: some day it *will* build on ppc32
Diffstat (limited to 'system/musl')
-rw-r--r--system/musl/APKBUILD2
-rw-r--r--system/musl/amalgamation.patch16
2 files changed, 7 insertions, 11 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 2509e692a..27b39f584 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -117,7 +117,7 @@ utils() {
}
sha512sums="7026b67590a5dc0eda96777476a902e3d7121813d9ff9d9dabec3774365b9d43ce06314c434224fc8eef2b858107e42c10f220b6009ce4b919d8d9996cfcb839 musl-1.2.0_alpha1.tar.xz
-0f2f9db619ca14791ab3beff86e9922150c8106ba045fe858f88d1c156eb39198d6aac7eac42482f9ab9be878ce210eed24f1b1aa3eb211aa00e3d05943d536a amalgamation.patch
+3f2f4eb4bfa1ddb19276e85fa97bf65dfc804cf9ea6e8ad7f1fef4a7930439e840d270f17c3b7e9dc816beb6ba4e33132b0b1a004750bff365161d63c8e8855e amalgamation.patch
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
diff --git a/system/musl/amalgamation.patch b/system/musl/amalgamation.patch
index ba2c43d3c..8f018a07a 100644
--- a/system/musl/amalgamation.patch
+++ b/system/musl/amalgamation.patch
@@ -366,18 +366,14 @@ index cc53d536..98caa1f6 100644
val = tm->tm_hour;
if (!val) val = 12;
diff --git a/src/time/timespec_get.c b/src/time/timespec_get.c
-index 40ea9c1c..6ba68559 100644
+index 40ea9c1c..e396da09 100644
--- a/src/time/timespec_get.c
+++ b/src/time/timespec_get.c
-@@ -4,7 +4,7 @@
- * are considered erroneous. */
- int timespec_get(struct timespec * ts, int base)
- {
-- if (base != TIME_UTC) return 0;
-+ if (base != 1) return 0;
- int ret = __clock_gettime(CLOCK_REALTIME, ts);
- return ret < 0 ? 0 : base;
- }
+@@ -1,3 +1,4 @@
++#define _BSD_SOURCE
+ #include <time.h>
+
+ /* There is no other implemented value than TIME_UTC; all other values
diff --git a/src/unistd/faccessat.c b/src/unistd/faccessat.c
index 76bbd4c7..0b4564f9 100644
--- a/src/unistd/faccessat.c