summaryrefslogtreecommitdiff
path: root/system/musl
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-22 06:46:23 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-22 06:46:23 +0000
commit1d53e24413647eaa55bfa4074295adfab4a329b8 (patch)
tree7d19e083fda5133d7aef3744d6bbe38199abb00e /system/musl
parent5fd1fe7aae01ff576bb05b695f9ff710a2e43462 (diff)
downloadpackages-1d53e24413647eaa55bfa4074295adfab4a329b8.tar.gz
packages-1d53e24413647eaa55bfa4074295adfab4a329b8.tar.bz2
packages-1d53e24413647eaa55bfa4074295adfab4a329b8.tar.xz
packages-1d53e24413647eaa55bfa4074295adfab4a329b8.zip
system/{easy-kernel,musl}: fix struct iphdr UAPI thing
Diffstat (limited to 'system/musl')
-rw-r--r--system/musl/APKBUILD2
-rw-r--r--system/musl/uapi-iphdr.patch30
2 files changed, 32 insertions, 0 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index ad2bbaf06..0758f513a 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -26,6 +26,7 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
3001-make-real-lastlog-h.patch
handle-aux-at_base.patch
fgetspent_r.patch
+ uapi-iphdr.patch
ldconfig
getent.c
@@ -121,6 +122,7 @@ f01ab92b9d385c15369c0bb7d95e1bc06a009c8851e363517d0ba1bae3fc2647af69fc2f363b5d96
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
+3b3866a32321cf72b72470230b88cde6bfc9f63e6ec33fef6023286b5733f90feed32b65b82d59ec353deb2ee199c1c95825802d7588019bf016b39d327f3c73 uapi-iphdr.patch
cb71d29a87f334c75ecbc911becde7be825ab30d8f39fa6d64cb53812a7c9abaf91d9804c72540e5be3ddd3c84cfe7fd9632274309005cb8bcdf9a9b09b4b923 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/uapi-iphdr.patch b/system/musl/uapi-iphdr.patch
new file mode 100644
index 000000000..8483ca306
--- /dev/null
+++ b/system/musl/uapi-iphdr.patch
@@ -0,0 +1,30 @@
+From 7e690371dbc52b0f771bc7cdecdb757d5e1a4c11 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 22 Dec 2019 00:04:28 -0600
+Subject: [PATCH] netinet/ip.h: Add UAPI definition guard for iphdr
+
+This ensures that the musl definition of 'struct iphdr' does not conflict
+with the Linux kernel UAPI definition of it.
+
+Some software, i.e. net-tools, will not compile against 5.4 kernel headers
+without this patch and the corresponding Linux kernel patch.
+---
+ include/netinet/ip.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/netinet/ip.h b/include/netinet/ip.h
+index 8b6d7fef..0ae132a5 100644
+--- a/include/netinet/ip.h
++++ b/include/netinet/ip.h
+@@ -190,6 +190,8 @@ struct ip_timestamp {
+
+ #define IP_MSS 576
+
++#define __UAPI_DEF_IPHDR 0
++
+ #ifdef __cplusplus
+ }
+ #endif
+--
+2.22.1
+