summaryrefslogtreecommitdiff
path: root/system/nghttp2
diff options
context:
space:
mode:
authorSheila Aman <sheila@vulpine.house>2021-11-07 16:52:04 +0000
committerSheila Aman <sheila@vulpine.house>2021-11-07 16:52:04 +0000
commit5cb8eeb287e3777076efee7392a107515f9fcc22 (patch)
tree5092361fdbe265ceb9802f97e2462d29571f3540 /system/nghttp2
parent1d3deb758d3abc846405917b8fa1cc1b1e1594a3 (diff)
downloadpackages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.gz
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.bz2
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.tar.xz
packages-5cb8eeb287e3777076efee7392a107515f9fcc22.zip
user/{c-ares,libev,nghttp2}: move to system
Diffstat (limited to 'system/nghttp2')
-rw-r--r--system/nghttp2/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/system/nghttp2/APKBUILD b/system/nghttp2/APKBUILD
new file mode 100644
index 000000000..a1f7c74c6
--- /dev/null
+++ b/system/nghttp2/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Síle Ekaterin Liszka <sheila@adelielinux.org>
+pkgname=nghttp2
+pkgver=1.46.0
+pkgrel=0
+pkgdesc="Experimental HTTP/2 client, server and proxy"
+url="https://nghttp2.org/"
+arch="all"
+options="!check" # Requires cunit, which we don't currently ship
+license="MIT"
+depends=""
+makedepends="c-ares-dev libev-dev libxml2-dev openssl-dev zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+
+# secfixes:
+# 1.41.0-r0:
+# - CVE-2020-11080
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ --without-neverbleed \
+ --without-jemalloc \
+ --disable-python-bindings \
+ --enable-app
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fcf3573bcc421705190c7cf0e3230f6f3028b669cb2976d29cfeb73e706deaae91ce60d0a615472e3f296454049ea5798f1e8defdd260a98895e94fea6a7a16b nghttp2-1.46.0.tar.xz"